summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-06-21 03:13:07 -0400
committerJean Lucas2019-06-21 03:14:16 -0400
commitcbbb3571e1954e97714a492f8ed8de8b6e521f5a (patch)
treeb4fcdfd852eb95e4f4c0b23e8387cbfd52449869
parentc2e79fcc3071cd3a6854082fca8e418db5011688 (diff)
downloadaur-cbbb3571e1954e97714a492f8ed8de8b6e521f5a.tar.gz
1.2.3, update optdepends, remove git variant conflicts
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD17
2 files changed, 25 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d6ab389aabf..4619e4f37d5c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hunter
pkgdesc = ranger-like file browser written in Rust
- pkgver = 1.2.1
+ pkgver = 1.2.3
pkgrel = 1
url = https://github.com/rabite0/hunter
arch = i686
@@ -13,11 +13,18 @@ pkgbase = hunter
depends = gst-plugins-ugly
depends = gst-libav
optdepends = nerd-fonts-complete: supported icon pack
- conflicts = hunter-git
+ optdepends = bat: syntax highlighting
+ optdepends = highlight: syntax highlighting
+ optdepends = p7zip: archive support
+ optdepends = w3m: HTML support
+ optdepends = links: HTML support
+ optdepends = elinks: HTML support
+ optdepends = lynx: HTML support
+ optdepends = poppler: PDF support
+ optdepends = mupdf-tools: PDF support
conflicts = hunter-holy
- conflicts = hunter-holy-git
- source = https://github.com/rabite0/hunter/archive/v1.2.1.tar.gz
- sha512sums = 58646eb0e353d235eede2efa034dde9b5b6892eee82d64f938233faf250e019ae6a5b02162b77a9b979bf6f3adc8b71333bda0f1711d830845d01a14b21c7833
+ source = https://github.com/rabite0/hunter/archive/v1.2.3.tar.gz
+ sha512sums = 507cb50fa5d8243c95fa1f12c008541d5b0edd7a8353f47be7dce53e771e3a469405426d332d8e23181dfb4b5e3e2fbbe906bc2d48c8e2ca3f905f6325b4ae94
pkgname = hunter
diff --git a/PKGBUILD b/PKGBUILD
index e7e934212294..f4c7031ea2e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=hunter
-pkgver=1.2.1
+pkgver=1.2.3
pkgrel=1
pkgdesc='ranger-like file browser written in Rust'
arch=(i686 x86_64)
@@ -9,10 +9,19 @@ url=https://github.com/rabite0/hunter
license=(WTFPL)
depends=(file xdg-utils gst-plugins-bad gst-plugins-ugly gst-libav)
makedepends=(rust-nightly)
-optdepends=('nerd-fonts-complete: supported icon pack')
-conflicts=(hunter-git hunter-holy hunter-holy-git)
+optdepends=('nerd-fonts-complete: supported icon pack'
+ 'bat: syntax highlighting'
+ 'highlight: syntax highlighting'
+ 'p7zip: archive support'
+ 'w3m: HTML support'
+ 'links: HTML support'
+ 'elinks: HTML support'
+ 'lynx: HTML support'
+ 'poppler: PDF support'
+ 'mupdf-tools: PDF support')
+conflicts=(hunter-holy)
source=($url/archive/v$pkgver.tar.gz)
-sha512sums=('58646eb0e353d235eede2efa034dde9b5b6892eee82d64f938233faf250e019ae6a5b02162b77a9b979bf6f3adc8b71333bda0f1711d830845d01a14b21c7833')
+sha512sums=('507cb50fa5d8243c95fa1f12c008541d5b0edd7a8353f47be7dce53e771e3a469405426d332d8e23181dfb4b5e3e2fbbe906bc2d48c8e2ca3f905f6325b4ae94')
build() {
cd hunter-$pkgver