summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-06-21 03:25:16 -0400
committerJean Lucas2019-06-21 03:25:16 -0400
commitec0b9b50eca1aec93f16101f1ee69ba700f5b5c0 (patch)
tree587df512786450a7528dbb64d426c7d3b5322042
parentef75e2c93f71c9cf50a443efb5c30849c693424e (diff)
downloadaur-ec0b9b50eca1aec93f16101f1ee69ba700f5b5c0.tar.gz
Update optdepends, remove package variant conflicts
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
2 files changed, 24 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e70c4f4194e..08503b62abf0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hunter-git
pkgdesc = ranger-like file browser written in Rust (git)
- pkgver = 1.2.1+14+gcaf2429
+ pkgver = 1.2.3+22+gcd01a21
pkgrel = 1
url = https://github.com/rabite0/hunter
arch = i686
@@ -14,10 +14,18 @@ pkgbase = hunter-git
depends = gst-plugins-ugly
depends = gst-libav
optdepends = nerd-fonts-complete: supported icon pack
+ optdepends = bat: syntax highlighting
+ optdepends = highlight: syntax highlighting
+ optdepends = p7zip: archive support
+ optdepends = w3m: HTML support
+ optdepends = links: HTML support
+ optdepends = elinks: HTML support
+ optdepends = lynx: HTML support
+ optdepends = poppler: PDF support
+ optdepends = mupdf-tools: PDF support
provides = hunter
conflicts = hunter
conflicts = hunter-holy
- conflicts = hunter-holy-git
source = git+https://github.com/rabite0/hunter
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 6067723ebc90..cff563b311fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=hunter-git
-pkgver=1.2.1+14+gcaf2429
+pkgver=1.2.3+22+gcd01a21
pkgrel=1
pkgdesc='ranger-like file browser written in Rust (git)'
arch=(i686 x86_64)
@@ -9,11 +9,20 @@ url=https://github.com/rabite0/hunter
license=(WTFPL)
depends=(file xdg-utils gst-plugins-bad gst-plugins-ugly gst-libav)
makedepends=(git rust-nightly)
-optdepends=('nerd-fonts-complete: supported icon pack')
+optdepends=('nerd-fonts-complete: supported icon pack'
+ 'bat: syntax highlighting'
+ 'highlight: syntax highlighting'
+ 'p7zip: archive support'
+ 'w3m: HTML support'
+ 'links: HTML support'
+ 'elinks: HTML support'
+ 'lynx: HTML support'
+ 'poppler: PDF support'
+ 'mupdf-tools: PDF support')
provides=(hunter)
-conflicts=(hunter hunter-holy hunter-holy-git)
+conflicts=(hunter hunter-holy)
source=(git+$url)
-sha512sums=(SKIP)
+sha512sums=('SKIP')
pkgver() {
cd hunter
@@ -27,7 +36,7 @@ build() {
package() {
cd hunter
- install -D target/release/{hunter,preview-gen} extra/scope.sh -t "$pkgdir"/usr/bin
+ install -D target/release/{hunter,preview-gen} -t "$pkgdir"/usr/bin
install -Dm 644 README.md -t "$pkgdir"/usr/share/doc/hunter
install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/hunter
}