summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-08-12 18:54:50 -0400
committerJean Lucas2019-08-12 18:54:50 -0400
commitad13d794557861c2a533493fcc63910efa98743e (patch)
treef9d24396ff22bac753da48e819c41ab3db828b75
parent575a0a62c7c7cd00e48e0e9968128c96f0c6fc7c (diff)
downloadaur-ad13d794557861c2a533493fcc63910efa98743e.tar.gz
Fix/update deps/binaries and source schema, install Rust nightly if needed, 1.3.0
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD23
2 files changed, 26 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5bc2efbbf8e..5443f2b1ab38 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,23 @@
pkgbase = hunter-holy
pkgdesc = ranger-like file browser written in Rust (holy branch)
- pkgver = 1.2.3
+ pkgver = 1.3.0
pkgrel = 1
url = https://github.com/rabite0/hunter
arch = i686
arch = x86_64
license = WTFPL
- makedepends = rust-nightly
- depends = file
+ makedepends = rustup
depends = xdg-utils
- depends = gst-plugins-bad
- depends = gst-plugins-ugly
- depends = gst-libav
+ depends = gst-plugins-base-libs
+ optdepends = gst-plugins-good: media support
+ optdepends = gst-plugins-bad: media support
+ optdepends = gst-plugins-ugly: media support
+ optdepends = gst-libav: media support
+ optdepends = libsixel: media support
optdepends = nerd-fonts-complete: supported icon pack
optdepends = bat: syntax highlighting
optdepends = highlight: syntax highlighting
+ optdepends = libarchive: archive support
optdepends = p7zip: archive support
optdepends = w3m: HTML support
optdepends = links: HTML support
@@ -24,8 +27,8 @@ pkgbase = hunter-holy
optdepends = mupdf-tools: PDF support
provides = hunter
conflicts = hunter
- source = https://github.com/rabite0/hunter/archive/v1.2.3-holy.tar.gz
- sha512sums = 805561a541e6aa95eff1a64d7e686564d5727fe5179f813dd618a3382d1605057d73a3bd1d58311fd755b78c25295a7215f8aa01447c10074cfc70599c6c84d5
+ source = hunter-holy-1.3.0.tar.gz::https://github.com/rabite0/hunter/archive/v1.3.0-holy.tar.gz
+ sha512sums = 81fac08545350eac39a5b7d2b3e258a7d01c75ec8158292200d1505cd459004fa6d30d546b3bc5b5f2ab48d96bb5c7597b2a2a4fc3ac2fade941a283d2af396e
pkgname = hunter-holy
diff --git a/PKGBUILD b/PKGBUILD
index 233def0c30bb..ec58e8a78455 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,23 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=hunter-holy
-pkgver=1.2.3
+pkgver=1.3.0
pkgrel=1
pkgdesc='ranger-like file browser written in Rust (holy branch)'
arch=(i686 x86_64)
url=https://github.com/rabite0/hunter
license=(WTFPL)
-depends=(file xdg-utils gst-plugins-bad gst-plugins-ugly gst-libav)
-makedepends=(rust-nightly)
-optdepends=('nerd-fonts-complete: supported icon pack'
+depends=(xdg-utils gst-plugins-base-libs)
+makedepends=(rustup)
+optdepends=('gst-plugins-good: media support'
+ 'gst-plugins-bad: media support'
+ 'gst-plugins-ugly: media support'
+ 'gst-libav: media support'
+ 'libsixel: media support'
+ 'nerd-fonts-complete: supported icon pack'
'bat: syntax highlighting'
'highlight: syntax highlighting'
+ 'libarchive: archive support'
'p7zip: archive support'
'w3m: HTML support'
'links: HTML support'
@@ -21,17 +27,18 @@ optdepends=('nerd-fonts-complete: supported icon pack'
'mupdf-tools: PDF support')
provides=(hunter)
conflicts=(hunter)
-source=($url/archive/v$pkgver-holy.tar.gz)
-sha512sums=('805561a541e6aa95eff1a64d7e686564d5727fe5179f813dd618a3382d1605057d73a3bd1d58311fd755b78c25295a7215f8aa01447c10074cfc70599c6c84d5')
+source=(hunter-holy-$pkgver.tar.gz::$url/archive/v$pkgver-holy.tar.gz)
+sha512sums=('81fac08545350eac39a5b7d2b3e258a7d01c75ec8158292200d1505cd459004fa6d30d546b3bc5b5f2ab48d96bb5c7597b2a2a4fc3ac2fade941a283d2af396e')
build() {
cd hunter-$pkgver-holy
- cargo +nightly build --release
+ rustup override set nightly
+ cargo build --release
}
package() {
cd hunter-$pkgver-holy
- install -D target/release/{hunter,preview-gen} extra/scope.sh -t "$pkgdir"/usr/bin
+ install -D target/release/hunter{,-media} -t "$pkgdir"/usr/bin
install -Dm 644 README.md -t "$pkgdir"/usr/share/doc/hunter
install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/hunter
}