summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-06-04 20:30:42 -0400
committerJean Lucas2019-06-04 20:30:42 -0400
commit2b9d8e7a59d872684722e1e626aaf5d6df5efe0a (patch)
treeb099e77a3e55c7bf4a2d22fe49a294fce32c6614
parent8229e653f0f7a40bef150f3a4cecbf8fc98a5a55 (diff)
downloadaur-2b9d8e7a59d872684722e1e626aaf5d6df5efe0a.tar.gz
1.2.1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 090e611f87d1..8f84148000ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue May 14 03:49:26 UTC 2019
pkgbase = hunter-holy-git
pkgdesc = ranger-like file browser written in Rust (holy branch, git)
- pkgver = 1.1.4+holy
+ pkgver = 1.2.1+16+g8f6f7fb
pkgrel = 1
url = https://github.com/rabite0/hunter
arch = i686
@@ -11,8 +9,11 @@ pkgbase = hunter-holy-git
makedepends = git
makedepends = rust-nightly
depends = file
- optdepends = ranger: to open files using rifle
- optdepends = xdg-utils: fallback to open files with xdg-open
+ depends = xdg-utils
+ depends = gst-plugins-bad
+ depends = gst-plugins-ugly
+ depends = gst-libav
+ optdepends = nerd-fonts-complete: supported icon pack
provides = hunter
conflicts = hunter
conflicts = hunter-git
diff --git a/PKGBUILD b/PKGBUILD
index afbe80c6658c..551e4a64d546 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=hunter-holy-git
-pkgver=1.1.4+holy
+pkgver=1.2.1+16+g8f6f7fb
pkgrel=1
pkgdesc='ranger-like file browser written in Rust (holy branch, git)'
arch=(i686 x86_64)
url=https://github.com/rabite0/hunter
license=(WTFPL)
-depends=(file)
+depends=(file xdg-utils gst-plugins-bad gst-plugins-ugly gst-libav)
makedepends=(git rust-nightly)
-optdepends=('ranger: to open files using rifle'
- 'xdg-utils: fallback to open files with xdg-open')
+optdepends=('nerd-fonts-complete: supported icon pack')
provides=(hunter)
conflicts=(hunter hunter-git hunter-holy)
source=(git+$url#branch=holy)
@@ -18,7 +17,7 @@ sha512sums=(SKIP)
pkgver() {
cd hunter
- git describe --tags | sed 's/v//;s/-/+/g'
+ git describe --tags | sed 's#v##;s#-#+#g'
}
build() {
@@ -28,7 +27,7 @@ build() {
package() {
cd hunter
- install -D {target/release/hunter,extra/scope.sh} -t "$pkgdir"/usr/bin
+ install -D target/release/{hunter,preview-gen} extra/scope.sh -t "$pkgdir"/usr/bin
install -Dm 644 README.md -t "$pkgdir"/usr/share/doc/hunter
install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/hunter
}