summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-05-13 23:35:29 -0400
committerJean Lucas2019-05-13 23:37:05 -0400
commitad070328d05c72784632096866ff18d4bebea31b (patch)
treedd5edb2539d44adb861f33415a8accfe68b32e9c
parent6db0da8713ce5b0d700c0e4ccfbf8e884dca726e (diff)
downloadaur-ad070328d05c72784632096866ff18d4bebea31b.tar.gz
Require rust-nightly, add optdepends, dir typo
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c273d3aba9f9..70c3e73625eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
# Generated by mksrcinfo v8
-# Fri May 3 15:50:58 UTC 2019
+# Tue May 14 03:36:48 UTC 2019
pkgbase = hunter-holy-git
pkgdesc = ranger-like file browser written in Rust (holy branch, git)
- pkgver = 1.1.0+holy
- pkgrel = 2
+ pkgver = 1.1.4+holy
+ pkgrel = 1
url = https://github.com/rabite0/hunter
arch = i686
arch = x86_64
license = WTFPL
makedepends = git
- makedepends = rust
+ makedepends = rust-nightly
depends = file
optdepends = ranger: to open files using rifle
+ optdepends = xdg-open: fallback to open files with xdg-open
provides = hunter
conflicts = hunter
conflicts = hunter-git
diff --git a/PKGBUILD b/PKGBUILD
index 3be129fff196..05878105f683 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=hunter-holy-git
-pkgver=1.1.0+holy
-pkgrel=2
+pkgver=1.1.4+holy
+pkgrel=1
pkgdesc='ranger-like file browser written in Rust (holy branch, git)'
arch=(i686 x86_64)
url=https://github.com/rabite0/hunter
license=(WTFPL)
depends=(file)
-makedepends=(git rust)
-optdepends=('ranger: to open files using rifle')
+makedepends=(git rust-nightly)
+optdepends=('ranger: to open files using rifle'
+ 'xdg-open: fallback to open files with xdg-open')
provides=(hunter)
conflicts=(hunter hunter-git hunter-holy)
source=(git+$url#branch=holy)
@@ -22,12 +23,12 @@ pkgver() {
build() {
cd hunter
- cargo build --release
+ cargo +nightly build --release
}
package() {
cd hunter
install -D {target/release/hunter,extra/scope.sh} -t "$pkgdir"/usr/bin
- install -Dm 644 README.md -t "$pkgdir"/usr/share/hunter-holy
+ install -Dm 644 README.md -t "$pkgdir"/usr/share/hunter
install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/hunter
}