summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-08-12 18:53:49 -0400
committerJean Lucas2019-08-12 18:53:49 -0400
commitcc36b765404479c0f99da296c38cfdc786fa3dde (patch)
tree81dbee48023d1c93e93949edf36b48953b3588d4
parentea45d7b73ff6de692921dd199a78fda84e547694 (diff)
downloadaur-cc36b765404479c0f99da296c38cfdc786fa3dde.tar.gz
Fix/update deps/binaries/build, install Rust nightly if needed, update pkgver schema
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 21 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49acd9f90693..f3efa4351cf8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,24 @@
pkgbase = hunter-holy-git
pkgdesc = ranger-like file browser written in Rust (holy branch, git)
- pkgver = 1.2.3+23+g5c3640a
+ pkgver = 1.3.4+r12+ge49f2f4
pkgrel = 1
url = https://github.com/rabite0/hunter
arch = i686
arch = x86_64
license = WTFPL
makedepends = git
- makedepends = rust-nightly
- depends = file
+ makedepends = rustup
+ makedepends = gst-plugins-bad
depends = xdg-utils
- depends = gst-plugins-bad
- depends = gst-plugins-ugly
- depends = gst-libav
+ depends = gst-plugins-base-libs
+ depends = libsixel
+ optdepends = gst-plugins-good: media support
+ optdepends = gst-plugins-ugly: media support
+ optdepends = gst-libav: media support
optdepends = nerd-fonts-complete: supported icon pack
optdepends = bat: syntax highlighting
optdepends = highlight: syntax highlighting
+ optdepends = libarchive: archive support
optdepends = p7zip: archive support
optdepends = w3m: HTML support
optdepends = links: HTML support
diff --git a/PKGBUILD b/PKGBUILD
index 99e385137f0a..ee5f92ef9b3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,21 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=hunter-holy-git
-pkgver=1.2.3+23+g5c3640a
+pkgver=1.3.4+r12+ge49f2f4
pkgrel=1
pkgdesc='ranger-like file browser written in Rust (holy branch, git)'
arch=(i686 x86_64)
url=https://github.com/rabite0/hunter
license=(WTFPL)
-depends=(file xdg-utils gst-plugins-bad gst-plugins-ugly gst-libav)
-makedepends=(git rust-nightly)
-optdepends=('nerd-fonts-complete: supported icon pack'
+depends=(xdg-utils gst-plugins-base-libs libsixel)
+makedepends=(git rustup gst-plugins-bad)
+optdepends=('gst-plugins-good: media support'
+ 'gst-plugins-ugly: media support'
+ 'gst-libav: media support'
+ 'nerd-fonts-complete: supported icon pack'
'bat: syntax highlighting'
'highlight: syntax highlighting'
+ 'libarchive: archive support'
'p7zip: archive support'
'w3m: HTML support'
'links: HTML support'
@@ -26,17 +30,18 @@ sha512sums=('SKIP')
pkgver() {
cd hunter
- git describe --tags | sed 's#v##;s#-#+#g'
+ git describe --tags | sed 's#v##;s#-#+#g;s#+#+r#'
}
build() {
cd hunter
- cargo +nightly build --release
+ rustup override set nightly
+ cargo build --release
}
package() {
cd hunter
- install -D target/release/{hunter,preview-gen} -t "$pkgdir"/usr/bin
+ install -D target/release/hunter{,-media} -t "$pkgdir"/usr/bin
install -Dm 644 README.md -t "$pkgdir"/usr/share/doc/hunter
install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/hunter
}