summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-06-21 03:25:45 -0400
committerJean Lucas2019-06-21 03:25:45 -0400
commitd1ec4b24579c84a6c21d29280ce6d3ecbd630fda (patch)
treee1b243e881201c9e7df0ded1c103812711b5001f
parent2b9d8e7a59d872684722e1e626aaf5d6df5efe0a (diff)
downloadaur-d1ec4b24579c84a6c21d29280ce6d3ecbd630fda.tar.gz
Update optdepends, remove package variant conflicts
-rw-r--r--PKGBUILD19
1 files changed, 14 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 551e4a64d546..99e385137f0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=hunter-holy-git
-pkgver=1.2.1+16+g8f6f7fb
+pkgver=1.2.3+23+g5c3640a
pkgrel=1
pkgdesc='ranger-like file browser written in Rust (holy branch, git)'
arch=(i686 x86_64)
@@ -9,11 +9,20 @@ url=https://github.com/rabite0/hunter
license=(WTFPL)
depends=(file xdg-utils gst-plugins-bad gst-plugins-ugly gst-libav)
makedepends=(git rust-nightly)
-optdepends=('nerd-fonts-complete: supported icon pack')
+optdepends=('nerd-fonts-complete: supported icon pack'
+ 'bat: syntax highlighting'
+ 'highlight: syntax highlighting'
+ 'p7zip: archive support'
+ 'w3m: HTML support'
+ 'links: HTML support'
+ 'elinks: HTML support'
+ 'lynx: HTML support'
+ 'poppler: PDF support'
+ 'mupdf-tools: PDF support')
provides=(hunter)
-conflicts=(hunter hunter-git hunter-holy)
+conflicts=(hunter hunter-holy)
source=(git+$url#branch=holy)
-sha512sums=(SKIP)
+sha512sums=('SKIP')
pkgver() {
cd hunter
@@ -27,7 +36,7 @@ build() {
package() {
cd hunter
- install -D target/release/{hunter,preview-gen} extra/scope.sh -t "$pkgdir"/usr/bin
+ install -D target/release/{hunter,preview-gen} -t "$pkgdir"/usr/bin
install -Dm 644 README.md -t "$pkgdir"/usr/share/doc/hunter
install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/hunter
}