summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-04-23 04:38:05 -0400
committerJean Lucas2019-04-23 04:38:05 -0400
commitd8ea9961162ee44882fbafbc9aba4731021cdc46 (patch)
tree5758868bcfc9cad8162dab53fed6fb1fd7be97aa
downloadaur-d8ea9961162ee44882fbafbc9aba4731021cdc46.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6721814560f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Tue Apr 23 08:37:56 UTC 2019
+pkgbase = hunter-holy-git
+ pkgdesc = ranger-like file browser written in Rust (holy branch, git)
+ pkgver = 1.0.10+holy+3+ge46c253
+ pkgrel = 1
+ url = https://github.com/rabite0/hunter
+ arch = i686
+ arch = x86_64
+ license = WTFPL
+ makedepends = git
+ makedepends = rust
+ depends = file
+ provides = hunter
+ conflicts = hunter
+ conflicts = hunter-git
+ conflicts = hunter-holy
+ source = git+https://github.com/rabite0/hunter#branch=holy
+ sha512sums = SKIP
+
+pkgname = hunter-holy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80be51ac4fe6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jean Lucas <jean@4ray.co>
+
+pkgname=hunter-holy-git
+pkgver=1.0.10+holy+3+ge46c253
+pkgrel=1
+pkgdesc='ranger-like file browser written in Rust (holy branch, git)'
+arch=(i686 x86_64)
+url=https://github.com/rabite0/hunter
+license=(WTFPL)
+depends=(file)
+makedepends=(git rust)
+provides=(hunter)
+conflicts=(hunter hunter-git hunter-holy)
+source=(git+$url#branch=holy)
+sha512sums=(SKIP)
+
+pkgver() {
+ cd hunter
+ git describe --tags | sed 's/v//;s/-/+/g'
+}
+
+build() {
+ cd hunter
+ cargo build --release
+}
+
+package() {
+ cd hunter
+ install -D target/release/hunter -t "$pkgdir"/usr/bin
+ install -Dm 644 README.md -t "$pkgdir"/usr/share/hunter-holy
+ install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/hunter
+}