summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Schmidt2019-07-04 05:02:51 +0200
committerStefan Schmidt2019-07-04 05:03:38 +0200
commit692d20b701bdd933e1e811d7f492224aa85c4cfe (patch)
treee56d89de316fc990e5b505ba6142422e72b7effa
downloadaur-692d20b701bdd933e1e811d7f492224aa85c4cfe.tar.gz
Initial release (1.0.9.2)
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD46
-rw-r--r--hurrican.desktop9
-rw-r--r--hurrican.pngbin0 -> 3158 bytes
4 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..672db0f7c063
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = hurrican
+ pkgdesc = Freeware jump and shoot game created by Poke53280
+ pkgver = 1.0.9.2
+ pkgrel = 1
+ url = https://github.com/thrimbor/Hurrican.git
+ arch = i686
+ arch = x86_64
+ license = custom: MIT
+ makedepends = git
+ makedepends = mesa
+ makedepends = cmake
+ depends = sdl_image
+ depends = sdl_mixer
+ depends = libmodplug
+ depends = libgl
+ depends = libepoxy
+ conflicts = hurrican-svn
+ source = hurrican::git+https://github.com/thrimbor/hurrican.git
+ source = hurrican.desktop
+ source = hurrican.png
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = hurrican
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a924d2664d50
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Stefan Schmidt <thrimbor gmail com>
+
+pkgname=hurrican
+pkgver=1.0.9.2
+pkgrel=1
+pkgdesc="Freeware jump and shoot game created by Poke53280"
+arch=('i686' 'x86_64')
+url="https://github.com/thrimbor/Hurrican.git"
+license=('custom: MIT')
+depends=('sdl_image' 'sdl_mixer' 'libmodplug' 'libgl' 'libepoxy')
+makedepends=('git' 'mesa' 'cmake')
+conflicts=('hurrican-svn')
+source=(hurrican::"git+https://github.com/thrimbor/hurrican.git"
+ hurrican.desktop
+ hurrican.png)
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
+
+prepare() {
+ cd "${srcdir}"/hurrican
+ git checkout "v${pkgver}"
+}
+
+build() {
+ mkdir -p "${srcdir}/hurrican/Hurrican/build"
+ cd "${srcdir}/hurrican/Hurrican/build"
+ cmake ../ -DCMAKE_INSTALL_PREFIX:PATH=/usr
+ make
+}
+
+package() {
+ pushd "${srcdir}/hurrican/Hurrican/build"
+ make DESTDIR="$pkgdir" install
+ rm -rf "$pkgdir"/usr/share/hurrican/data/textures/pvr
+ popd
+
+ # .deskop integration
+ install -Dm0644 hurrican.desktop "$pkgdir"/usr/share/applications/hurrican.desktop
+ install -Dm0644 hurrican.png "$pkgdir"/usr/share/pixmaps/hurrican.png
+
+ cd "${srcdir}/hurrican"
+ install -Dm0644 README.md "$pkgdir"/usr/share/doc/$pkgname/README.txt
+ mkdir -p "$pkgdir"/usr/share/licenses/$pkgname/
+ ln -s /usr/share/doc/hurrican/README.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/hurrican.desktop b/hurrican.desktop
new file mode 100644
index 000000000000..ad47e61cf80a
--- /dev/null
+++ b/hurrican.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Hurrican
+Comment=A jump and shoot game based on the Turrican game series
+Icon=hurrican
+Exec=hurrican
+Categories=Game;ActionGame;
+Terminal=false
+StartupNotify=false
diff --git a/hurrican.png b/hurrican.png
new file mode 100644
index 000000000000..7c74ba5490b6
--- /dev/null
+++ b/hurrican.png
Binary files differ