summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Schmidt2020-06-14 21:33:10 +0200
committerStefan Schmidt2020-06-14 21:33:10 +0200
commitcc7faeadc9d674b2b22ab014ededc313d72b524f (patch)
tree53794ab6bfb4d5ce7fdb7c7f1bd1211bd70f8bd1
parent692d20b701bdd933e1e811d7f492224aa85c4cfe (diff)
downloadaur-cc7faeadc9d674b2b22ab014ededc313d72b524f.tar.gz
Fix submodule issues (1.0.9.2-2)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 672db0f7c063..b64ebfc990ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hurrican
pkgdesc = Freeware jump and shoot game created by Poke53280
pkgver = 1.0.9.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/thrimbor/Hurrican.git
arch = i686
arch = x86_64
@@ -16,11 +16,13 @@ pkgbase = hurrican
depends = libepoxy
conflicts = hurrican-svn
source = hurrican::git+https://github.com/thrimbor/hurrican.git
+ source = glm::git+https://github.com/g-truc/glm.git
source = hurrican.desktop
source = hurrican.png
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
pkgname = hurrican
diff --git a/PKGBUILD b/PKGBUILD
index a924d2664d50..d2306d920c7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=hurrican
pkgver=1.0.9.2
-pkgrel=1
+pkgrel=2
pkgdesc="Freeware jump and shoot game created by Poke53280"
arch=('i686' 'x86_64')
url="https://github.com/thrimbor/Hurrican.git"
@@ -11,15 +11,20 @@ depends=('sdl_image' 'sdl_mixer' 'libmodplug' 'libgl' 'libepoxy')
makedepends=('git' 'mesa' 'cmake')
conflicts=('hurrican-svn')
source=(hurrican::"git+https://github.com/thrimbor/hurrican.git"
+ glm::"git+https://github.com/g-truc/glm.git"
hurrican.desktop
hurrican.png)
sha256sums=('SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
prepare() {
cd "${srcdir}"/hurrican
git checkout "v${pkgver}"
+ git submodule init
+ git config submodule.Hurrican/3rdparty/glm.url "${srcdir}"/glm
+ git submodule update
}
build() {