summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjahway6032020-05-05 21:18:31 -0400
committerjahway6032020-05-05 21:18:31 -0400
commit00430faa98b7eab97ba06937ff7829070df6a423 (patch)
treef7f07593000d1142dcc260b9885c78ec1ed35425
downloadaur-00430faa98b7eab97ba06937ff7829070df6a423.tar.gz
Initial Hush3 AUR pkg Version 3.3.2
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD52
2 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab3634fa63da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = hush3
+ pkgdesc = HUSH (fork of KMD) full node that supports zaddrs
+ pkgver = 3.3.2
+ pkgrel = 1
+ url = http://github.com/MyHush/hush3
+ arch = x86_64
+ license = GPL3
+ makedepends = rust
+ makedepends = gcc
+ makedepends = ncurses
+ makedepends = automake
+ makedepends = curl
+ makedepends = unzip
+ makedepends = wget
+ makedepends = git
+ makedepends = python
+ makedepends = libtool
+ makedepends = autoconf
+ makedepends = m4
+ makedepends = binutils
+ depends = libsodium
+ source = hush3-3.3.2.tar.gz::https://github.com/MyHush/hush3/archive/v3.3.2.tar.gz
+ sha256sums = b1c8e511468a0c74b0237331c70a9edc2c4dfb281ba0fc6e1cc635185628eb1a
+
+pkgname = hush3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..854695f588da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Jah Way <jahway603 at protonmail dot com>
+
+pkgname=hush3
+pkgver=3.3.2
+pkgrel=1
+pkgdesc='HUSH (fork of KMD) full node that supports zaddrs'
+url='http://github.com/MyHush/hush3'
+arch=('x86_64')
+license=('GPL3')
+depends=('libsodium')
+makedepends=('rust' 'gcc' 'ncurses' 'automake'
+ 'curl' 'unzip' 'wget' 'git'
+ 'python' 'libtool' 'autoconf' 'm4'
+ 'binutils')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/MyHush/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('b1c8e511468a0c74b0237331c70a9edc2c4dfb281ba0fc6e1cc635185628eb1a')
+
+build() {
+ tar xzvf $pkgname-$pkgver.tar.gz
+ cd "$pkgname-$pkgver"
+ #./zcutil/build.sh -j$(nproc)
+ ./zcutil/build.sh
+}
+
+package() {
+ cd "$pkgname-$pkgver/src"
+
+ # create the necessary directory structure
+ install -d "${pkgdir}/opt/${pkgname}"
+
+ # install shell scripts
+ install -m 755 hush-cli "${pkgdir}/opt/${pkgname}"
+ install -m 755 hushd "${pkgdir}/opt/${pkgname}"
+ install -m 755 hush-smart-chain "${pkgdir}/opt/${pkgname}"
+ install -m 755 hush-tx "${pkgdir}/opt/${pkgname}"
+
+ # install shared libraries
+ install -m 755 komodo-cli "${pkgdir}/opt/${pkgname}"
+ install -m 755 komodod "${pkgdir}/opt/${pkgname}"
+ install -m 755 komodo-tx "${pkgdir}/opt/${pkgname}"
+
+ # install required sapling files
+ cd ..
+ install -m 644 sapling-output.params "${pkgdir}/opt/${pkgname}"
+ install -m 644 sapling-spend.params "${pkgdir}/opt/${pkgname}"
+
+ # create symlink in /usr/bin to hushd and others
+ cd /usr/bin
+ sudo ln -s /opt/$pkgname/hushd
+ sudo ln -s /opt/$pkgname/komodod
+ sudo ln -s /opt/$pkgname/komodo-cli
+}