summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjahway6032021-02-21 02:41:10 -0500
committerjahway6032021-02-21 02:41:10 -0500
commit2b074ef0697950a1d2f712880e25319d0a6b0e84 (patch)
treea8f1b1b3cd6c68614d587922f74ae81f1bca7ac5
parentf05717d3d24060523dc5b0512fc4f001313e11d8 (diff)
downloadaur-2b074ef0697950a1d2f712880e25319d0a6b0e84.tar.gz
Update to v3.6.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD67
2 files changed, 35 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 928cae5890ec..37f57d556480 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hush3-bin
pkgdesc = HUSH (Privacy Cryptocurrency and Messenger) full node that supports z-addresses
- pkgver = 3.6.0
+ pkgver = 3.6.1
pkgrel = 1
url = http://git.hush.is/hush/hush3
arch = x86_64
@@ -11,12 +11,10 @@ pkgbase = hush3-bin
depends = libsodium
depends = lib32-zlib
conflicts = hush3
- source = hush3-3.6.0.tar.gz::https://git.hush.is/attachments/e163324a-52eb-4c4c-9c34-0a18c3748f0a
- source = sapling-output.params::https://git.hush.is/attachments/e813da7d-ecec-4c78-b0fb-40d505689e2b
- source = sapling-spend.params::https://git.hush.is/attachments/dc290d37-64d3-41e8-ae83-df364cb0ba3c
- sha256sums = 9c2f19c50fdc44af2c89494b06cda2c9e176d7ae2f038ca0fb7c0cd083dd71b9
- sha256sums = 2f0ebbcbb9bb0bcffe95a397e7eba89c29eb4dde6191c339db88570e3f3fb0e4
- sha256sums = 8e48ffd23abb3a5fd9c5589204f32d9c31285a04b78096ba40a79b75677efc13
+ source = hush3-3.6.1.tar.gz::https://git.hush.is/jahway603/arch-bins/raw/branch/master/hush3/hush3_v3_6_1.tar.gz
+ source = http://git.hush.is/hush/hush3/raw/branch/master/LICENSE
+ sha256sums = c2acf75036b74bc092c47e1fc3f8a80bd6f72a9e230f7edc06b72412f99a0048
+ sha256sums = 6eae06cda3a8320e607ac0ee96cbdfc52b977463151ff4d5b119a26ee0cf666d
pkgname = hush3-bin
diff --git a/PKGBUILD b/PKGBUILD
index 5b8154d2c29a..5819c649ea08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=hush3-bin
_pkgname=hush3
-pkgver=3.6.0
+pkgver=3.6.1
pkgrel=1
pkgdesc='HUSH (Privacy Cryptocurrency and Messenger) full node that supports z-addresses'
url='http://git.hush.is/hush/hush3'
@@ -11,49 +11,42 @@ license=('GPL3')
depends=('libsodium' 'lib32-zlib')
makedepends=('wget' 'git' 'curl')
conflicts=('hush3')
-source=("$_pkgname-$pkgver.tar.gz::https://git.hush.is/attachments/e163324a-52eb-4c4c-9c34-0a18c3748f0a"
- "sapling-output.params::https://git.hush.is/attachments/e813da7d-ecec-4c78-b0fb-40d505689e2b"
- "sapling-spend.params::https://git.hush.is/attachments/dc290d37-64d3-41e8-ae83-df364cb0ba3c")
-sha256sums=('9c2f19c50fdc44af2c89494b06cda2c9e176d7ae2f038ca0fb7c0cd083dd71b9'
- '2f0ebbcbb9bb0bcffe95a397e7eba89c29eb4dde6191c339db88570e3f3fb0e4'
- '8e48ffd23abb3a5fd9c5589204f32d9c31285a04b78096ba40a79b75677efc13')
+source=("$_pkgname-$pkgver.tar.gz::https://git.hush.is/jahway603/arch-bins/raw/branch/master/hush3/hush3_v3_6_1.tar.gz"
+ "$url/raw/branch/master/LICENSE")
+sha256sums=('c2acf75036b74bc092c47e1fc3f8a80bd6f72a9e230f7edc06b72412f99a0048'
+ '6eae06cda3a8320e607ac0ee96cbdfc52b977463151ff4d5b119a26ee0cf666d')
+yeah="${_pkgname}_v3_6_1"
build() {
tar xzvf $_pkgname-$pkgver.tar.gz
}
package() {
- # create the necessary directory structure
- install -d "${pkgdir}/opt/${pkgname}"
- install -d "${pkgdir}/usr/share/hush"
- install -d "${pkgdir}/usr/bin"
-
- # rename KMD binaries used to not overwrite any installed
- mv komodo-cli hush-komodo-cli
- mv komodod hush-komodod
- mv komodo-tx hush-komodo-tx
-
- # install required scripts
- install -m 755 hush-cli "${pkgdir}/opt/${pkgname}"
- install -m 755 hushd "${pkgdir}/opt/${pkgname}"
- install -m 755 hush-smart-chain "${pkgdir}/opt/${pkgname}"
- install -m 755 hush-tx "${pkgdir}/opt/${pkgname}"
- install -m 755 hush-komodo-cli "${pkgdir}/opt/${pkgname}"
- install -m 755 hush-komodod "${pkgdir}/opt/${pkgname}"
- install -m 755 hush-komodo-tx "${pkgdir}/opt/${pkgname}"
+ install -Dm644 "${srcdir}/LICENSE" "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+
+ cd "$_pkgname_v3_6_1"
+ install -Dm755 "${srcdir}/$yeah/hush-cli" "${pkgdir}/opt/$_pkgname/hush-cli"
+ install -Dm755 "${srcdir}/$yeah/hushd" "${pkgdir}/opt/$_pkgname/hushd"
+ install -Dm755 "${srcdir}/$yeah/hush-smart-chain" "${pkgdir}/opt/$_pkgname/hush-smart-chain"
+ install -Dm755 "${srcdir}/$yeah/hush-tx" "${pkgdir}/opt/$_pkgname/hush-tx"
+ install -Dm755 "${srcdir}/$yeah/hush-komodo-cli" "${pkgdir}/opt/$_pkgname/hush-komodo-cli"
+ install -Dm755 "${srcdir}/$yeah/hush-komodod" "${pkgdir}/opt/$_pkgname/hush-komodod"
+ install -Dm755 "${srcdir}/$yeah/hush-komodo-tx" "${pkgdir}/opt/$_pkgname/hush-komodo-tx"
# install required sapling files
- install -m 644 sapling-output.params "${pkgdir}/opt/${pkgname}"
- install -m 644 sapling-spend.params "${pkgdir}/opt/${pkgname}"
-
+ install -Dm644 "${srcdir}/$yeah/sapling-output.params" "${pkgdir}/opt/$_pkgname/sapling-output.params"
+ install -Dm644 "${srcdir}/$yeah/sapling-spend.params" "${pkgdir}/opt/$_pkgname/sapling-spend.params"
+
# links scripts to /usr/bin
- ln -s /opt/${pkgname}/hush-cli "${pkgdir}/usr/bin"
- ln -s /opt/${pkgname}/hushd "${pkgdir}/usr/bin"
- ln -s /opt/${pkgname}/hush-smart-chain "${pkgdir}/usr/bin"
- ln -s /opt/${pkgname}/hush-tx "${pkgdir}/usr/bin"
- ln -s /opt/${pkgname}/hush-komodo-cli "${pkgdir}/usr/bin"
- ln -s /opt/${pkgname}/hush-komodod "${pkgdir}/usr/bin"
- ln -s /opt/${pkgname}/hush-komodo-tx "${pkgdir}/usr/bin"
- ln -s /opt/${pkgname}/sapling-output.params "${pkgdir}/usr/share/hush"
- ln -s /opt/${pkgname}/sapling-spend.params "${pkgdir}/usr/share/hush"
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/usr/share/hush"
+ ln -s /opt/$_pkgname/hush-cli "${pkgdir}/usr/bin"
+ ln -s /opt/$_pkgname/hushd "${pkgdir}/usr/bin"
+ ln -s /opt/$_pkgname/hush-smart-chain "${pkgdir}/usr/bin"
+ ln -s /opt/$_pkgname/hush-tx "${pkgdir}/usr/bin"
+ ln -s /opt/$_pkgname/hush-komodo-cli "${pkgdir}/usr/bin"
+ ln -s /opt/$_pkgname/hush-komodod "${pkgdir}/usr/bin"
+ ln -s /opt/$_pkgname/hush-komodo-tx "${pkgdir}/usr/bin"
+ ln -s /opt/$_pkgname/sapling-output.params "${pkgdir}/usr/share/hush"
+ ln -s /opt/$_pkgname/sapling-spend.params "${pkgdir}/usr/share/hush"
}