summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjahway6032021-09-19 18:30:22 -0400
committerjahway6032021-09-19 18:30:22 -0400
commit5fea250de2a93c816cb5d1c963c9a6fc9d857009 (patch)
tree61461ccda806ecc4b89425b4556a1da1f0523f3b
parent4031fb15b5c0c0dcaffd26ba299f4f8afe28a32f (diff)
downloadaur-5fea250de2a93c816cb5d1c963c9a6fc9d857009.tar.gz
added hushd systemd user service script
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--hushd.service9
3 files changed, 20 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20fa33940062..4f2d31844fae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hush3-bin
pkgdesc = HUSH (Privacy Cryptocurrency and Messenger) full node that supports z-addresses
pkgver = 3.8.0
- pkgrel = 2
+ pkgrel = 3
url = http://git.hush.is/hush/hush3
arch = x86_64
license = GPL3
@@ -14,8 +14,10 @@ pkgbase = hush3-bin
source = hush-3.8.0-amd64.deb::https://git.hush.is/attachments/28a44c53-636e-4f07-91ef-0b8c4d07f604
source = http://git.hush.is/hush/hush3/raw/branch/master/LICENSE
source = http://git.hush.is/hush/hush3/raw/branch/master/src/hush-smart-chain
+ source = hushd.service
sha256sums = e80d61509343f1a9c4744aa7f04046e34012a983342e8f5145ed293b1bf79a0f
sha256sums = 6eae06cda3a8320e607ac0ee96cbdfc52b977463151ff4d5b119a26ee0cf666d
sha256sums = c7afef544ec5c462b33996fdbd746932e7be3428c2addfad0da3a97ba1b737cf
+ sha256sums = 54503ef9d84e2b83b2e1e290c3da839a4d3bfc255cb01b8e5b905247a05af704
pkgname = hush3-bin
diff --git a/PKGBUILD b/PKGBUILD
index 6918a36b35cd..99c3b806e891 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=hush3-bin
_pkgname=hush3
pkgver=3.8.0
-pkgrel=2
+pkgrel=3
pkgdesc='HUSH (Privacy Cryptocurrency and Messenger) full node that supports z-addresses'
url='http://git.hush.is/hush/hush3'
arch=('x86_64')
@@ -13,10 +13,12 @@ makedepends=('wget' 'git' 'curl')
conflicts=('hush3')
source=("hush-$pkgver-amd64.deb::https://git.hush.is/attachments/28a44c53-636e-4f07-91ef-0b8c4d07f604"
"$url/raw/branch/master/LICENSE"
- "$url/raw/branch/master/src/hush-smart-chain")
+ "$url/raw/branch/master/src/hush-smart-chain"
+ "hushd.service")
sha256sums=('e80d61509343f1a9c4744aa7f04046e34012a983342e8f5145ed293b1bf79a0f'
'6eae06cda3a8320e607ac0ee96cbdfc52b977463151ff4d5b119a26ee0cf666d'
- 'c7afef544ec5c462b33996fdbd746932e7be3428c2addfad0da3a97ba1b737cf')
+ 'c7afef544ec5c462b33996fdbd746932e7be3428c2addfad0da3a97ba1b737cf'
+ '54503ef9d84e2b83b2e1e290c3da839a4d3bfc255cb01b8e5b905247a05af704')
package() {
# extract from deb file
@@ -53,4 +55,7 @@ package() {
ln -s /opt/${_pkgname}/sapling-output.params "${pkgdir}/usr/share/hush"
ln -s /opt/${_pkgname}/sapling-spend.params "${pkgdir}/usr/share/hush"
ln -s /opt/${_pkgname}/asmap.dat "${pkgdir}/usr/share/hush"
+
+ # install systemd service
+ install -Dm644 -t "${pkgdir}"/usr/lib/systemd/user "${srcdir}"/hushd.service
}
diff --git a/hushd.service b/hushd.service
new file mode 100644
index 000000000000..d93d4ede38fb
--- /dev/null
+++ b/hushd.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Hush daemon
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/hushd
+
+[Install]
+WantedBy=default.target