summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjahway6032021-04-27 02:35:02 -0400
committerjahway6032021-04-27 02:35:02 -0400
commitcec729c9182d487ebdf06d69af49f118383ebd6a (patch)
tree5fc0394ae5d33a5a6938ffe774ed7b193b546532
parentc44975cd195e7a1ef63de6c9fbb0a86280df1c03 (diff)
downloadaur-cec729c9182d487ebdf06d69af49f118383ebd6a.tar.gz
Updated to v3.7.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD29
2 files changed, 19 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d41f08eec922..5ae726409c35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hush3-bin
pkgdesc = HUSH (Privacy Cryptocurrency and Messenger) full node that supports z-addresses
- pkgver = 3.6.3
+ pkgver = 3.7.1
pkgrel = 1
url = http://git.hush.is/hush/hush3
arch = x86_64
@@ -11,9 +11,9 @@ pkgbase = hush3-bin
depends = libsodium
depends = lib32-zlib
conflicts = hush3
- source = hush3-3.6.3.tar.gz::https://git.hush.is/attachments/40414690-81e5-463d-9bd3-904e572ea599
+ source = hush-3.7.1-amd64.deb::https://git.hush.is/attachments/22856a9f-f1b0-4d41-a832-772864a8a617
source = http://git.hush.is/hush/hush3/raw/branch/master/LICENSE
- sha256sums = 0d5ebf9170af4946841577e8fa092adfdd8bf18be1eb8de06f8dd4be1ec44a57
+ sha256sums = 2485642848322318b477f80ff16c72b1c2288bd510fd2c36f134eec2fb596889
sha256sums = 6eae06cda3a8320e607ac0ee96cbdfc52b977463151ff4d5b119a26ee0cf666d
pkgname = hush3-bin
diff --git a/PKGBUILD b/PKGBUILD
index 23cd35252293..1adcd1c898d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=hush3-bin
_pkgname=hush3
-pkgver=3.6.3
+pkgver=3.7.1
pkgrel=1
pkgdesc='HUSH (Privacy Cryptocurrency and Messenger) full node that supports z-addresses'
url='http://git.hush.is/hush/hush3'
@@ -11,27 +11,30 @@ license=('GPL3')
depends=('libsodium' 'lib32-zlib')
makedepends=('wget' 'git' 'curl')
conflicts=('hush3')
-source=("$_pkgname-$pkgver.tar.gz::https://git.hush.is/attachments/40414690-81e5-463d-9bd3-904e572ea599"
+source=("hush-$pkgver-amd64.deb::https://git.hush.is/attachments/22856a9f-f1b0-4d41-a832-772864a8a617"
"$url/raw/branch/master/LICENSE")
-sha256sums=('0d5ebf9170af4946841577e8fa092adfdd8bf18be1eb8de06f8dd4be1ec44a57'
+sha256sums=('2485642848322318b477f80ff16c72b1c2288bd510fd2c36f134eec2fb596889'
'6eae06cda3a8320e607ac0ee96cbdfc52b977463151ff4d5b119a26ee0cf666d')
package() {
+ # extract from deb file
+ tar -xf "$srcdir/data.tar.xz"
+
install -Dm644 "${srcdir}/LICENSE" "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
# install required scripts
- install -Dm755 "${srcdir}/hush-cli" "${pkgdir}/opt/$_pkgname/hush-cli"
- install -Dm755 "${srcdir}/hushd" "${pkgdir}/opt/$_pkgname/hushd"
- install -Dm755 "${srcdir}/hush-smart-chain" "${pkgdir}/opt/$_pkgname/hush-smart-chain"
- install -Dm755 "${srcdir}/hush-tx" "${pkgdir}/opt/$_pkgname/hush-tx"
- install -Dm755 "${srcdir}/komodo-cli" "${pkgdir}/opt/$_pkgname/hush-komodo-cli"
- install -Dm755 "${srcdir}/komodod" "${pkgdir}/opt/$_pkgname/hush-komodod"
- install -Dm755 "${srcdir}/komodo-tx" "${pkgdir}/opt/$_pkgname/hush-komodo-tx"
+ install -Dm755 "${srcdir}/usr/bin/hush-cli" "${pkgdir}/opt/$_pkgname/hush-cli"
+ install -Dm755 "${srcdir}/usr/bin/hushd" "${pkgdir}/opt/$_pkgname/hushd"
+ #install -Dm755 "${srcdir}/usr/bin/hush-smart-chain" "${pkgdir}/opt/$_pkgname/hush-smart-chain" # missing from this release
+ install -Dm755 "${srcdir}/usr/bin/hush-tx" "${pkgdir}/opt/$_pkgname/hush-tx"
+ install -Dm755 "${srcdir}/usr/bin/hush-komodo-cli" "${pkgdir}/opt/$_pkgname/hush-komodo-cli"
+ install -Dm755 "${srcdir}/usr/bin/hush-komodod" "${pkgdir}/opt/$_pkgname/hush-komodod"
+ install -Dm755 "${srcdir}/usr/bin/hush-komodo-tx" "${pkgdir}/opt/$_pkgname/hush-komodo-tx"
# install required sapling files and asmap.dat
- install -Dm644 "${srcdir}/sapling-output.params" "${pkgdir}/opt/$_pkgname/sapling-output.params"
- install -Dm644 "${srcdir}/sapling-spend.params" "${pkgdir}/opt/$_pkgname/sapling-spend.params"
- install -Dm644 "${srcdir}/asmap.dat" "${pkgdir}/opt/$_pkgname/asmap.dat"
+ install -Dm644 "${srcdir}/usr/share/hush/sapling-output.params" "${pkgdir}/opt/$_pkgname/sapling-output.params"
+ install -Dm644 "${srcdir}/usr/share/hush/sapling-spend.params" "${pkgdir}/opt/$_pkgname/sapling-spend.params"
+ install -Dm644 "${srcdir}/usr/share/hush/asmap.dat" "${pkgdir}/opt/$_pkgname/asmap.dat"
# create symlinks
install -d "${pkgdir}/usr/bin"