summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjahway6032020-05-16 00:35:15 -0400
committerjahway6032020-05-16 00:35:15 -0400
commitdd86ae4d963331277d06f22b3b16ee92fe1ce81c (patch)
tree3eef50035c1e6c48ac9063517560c202e091f68c
downloadaur-dd86ae4d963331277d06f22b3b16ee92fe1ce81c.tar.gz
Initial Hush3-bin AUR pkg Version 3.3.2
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD53
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f98927da3066
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = hush3-bin
+ pkgdesc = HUSH (fork of KMD) full node that supports zaddrs
+ pkgver = 3.3.2
+ pkgrel = 1
+ url = http://github.com/MyHush/hush3
+ arch = x86_64
+ license = GPL3
+ makedepends = wget
+ makedepends = git
+ makedepends = curl
+ depends = libsodium
+ depends = lib32-zlib
+ source = https://github.com/MyHush/hush3/releases/download/v3.3.2/hush-3.3.2-linux.tar.xz
+ sha256sums = c57d4c826ca8fa6a7b8a01dca46eee01c81579d216ade21a88df55012a458b38
+
+pkgname = hush3-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7999e43d4d70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Jah Way <jahway603 at protonmail dot com>
+
+pkgname=hush3-bin
+pkgver=3.3.2
+pkgrel=1
+pkgdesc='HUSH (fork of KMD) full node that supports zaddrs'
+url='http://github.com/MyHush/hush3'
+arch=('x86_64')
+license=('GPL3')
+depends=('libsodium' 'lib32-zlib')
+makedepends=('wget' 'git' 'curl')
+source=("https://github.com/MyHush/hush3/releases/download/v$pkgver/hush-$pkgver-linux.tar.xz")
+sha256sums=('c57d4c826ca8fa6a7b8a01dca46eee01c81579d216ade21a88df55012a458b38')
+
+build() {
+ tar -xvf hush-3.3.2-linux.tar.xz
+}
+
+package() {
+ # create the necessary directory structure
+ install -d "${pkgdir}/opt/${pkgname}"
+ install -d "${pkgdir}/usr/share/hush"
+ install -d "${pkgdir}/usr/bin"
+
+ # rename KMD binaries used to not overwrite any installed
+ mv komodo-cli hush-komodo-cli
+ mv komodod hush-komodod
+ mv komodo-tx hush-komodo-tx
+
+ # install required scripts
+ install -m 755 hush-cli "${pkgdir}/opt/${pkgname}"
+ install -m 755 hushd "${pkgdir}/opt/${pkgname}"
+ install -m 755 hush-smart-chain "${pkgdir}/opt/${pkgname}"
+ install -m 755 hush-tx "${pkgdir}/opt/${pkgname}"
+ install -m 755 hush-komodo-cli "${pkgdir}/opt/${pkgname}"
+ install -m 755 hush-komodod "${pkgdir}/opt/${pkgname}"
+ install -m 755 hush-komodo-tx "${pkgdir}/opt/${pkgname}"
+
+ # install required sapling files
+ install -m 644 sapling-output.params "${pkgdir}/opt/${pkgname}"
+ install -m 644 sapling-spend.params "${pkgdir}/opt/${pkgname}"
+
+ # links scripts to /usr/bin
+ ln -s /opt/${pkgname}/hush-cli "${pkgdir}/usr/bin"
+ ln -s /opt/${pkgname}/hushd "${pkgdir}/usr/bin"
+ ln -s /opt/${pkgname}/hush-smart-chain "${pkgdir}/usr/bin"
+ ln -s /opt/${pkgname}/hush-tx "${pkgdir}/usr/bin"
+ ln -s /opt/${pkgname}/hush-komodo-cli "${pkgdir}/usr/bin"
+ ln -s /opt/${pkgname}/hush-komodod "${pkgdir}/usr/bin"
+ ln -s /opt/${pkgname}/hush-komodo-tx "${pkgdir}/usr/bin"
+ ln -s /opt/${pkgname}/sapling-output.params "${pkgdir}/usr/share/hush"
+ ln -s /opt/${pkgname}/sapling-spend.params "${pkgdir}/usr/share/hush"
+}