summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhillip Smith2015-06-02 10:58:29 +1000
committerPhillip Smith2015-06-02 10:58:29 +1000
commit0c527d08981c59058253514cd21117bc12b7f241 (patch)
tree26d45dd97322c5e9d6701a89e26cfc2b7201344d
downloadaur-0c527d08981c59058253514cd21117bc12b7f241.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7168db93ffcc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = husk
+ pkgdesc = An iptables front-end to allow rules to be expressed in a more flexible, free-form style using language.
+ pkgver = 0.9.13
+ pkgrel = 1
+ url = http://huskfw.info/
+ arch = any
+ license = GPL
+ makedepends = make
+ depends = coreutils
+ depends = iptables
+ depends = perl
+ depends = perl-config-inifiles
+ depends = perl-config-simple
+ conflicts = husk-git
+ backup = etc/husk/addr_groups.conf
+ backup = etc/husk/husk.conf
+ backup = etc/husk/interfaces.conf
+ source = https://github.com/fukawi2/husk/archive/v0.9.13.tar.gz
+ md5sums = 0219ea53c0c95318d6b2c58b21fc0692
+
+pkgname = husk
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c4a470ad3827
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/husk-*.pkg.tar.xz
+/v*.tar.gz
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c4d7cb14465
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Phillip Smith <fukawi2@NO-SPAM.gmail.com>
+# http://github.com/fukawi2/aur-packages
+pkgname=husk
+pkgver=0.9.13
+pkgrel=1
+pkgdesc="An iptables front-end to allow rules to be expressed in a more flexible, free-form style using language."
+arch=('any')
+url="http://huskfw.info/"
+license=('GPL')
+depends=('coreutils' 'iptables' 'perl' 'perl-config-inifiles' 'perl-config-simple')
+makedepends=('make')
+conflicts=('husk-git')
+backup=('etc/husk/addr_groups.conf'
+ 'etc/husk/husk.conf'
+ 'etc/husk/interfaces.conf')
+source=("https://github.com/fukawi2/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('0219ea53c0c95318d6b2c58b21fc0692')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i Makefile \
+ -e 's|/usr/local/|/usr/|g' \
+ -e 's|/usr/sbin|/usr/bin|g' \
+ -e 's|pod2man|/usr/bin/core_perl/pod2man|g' \
+ -e 's|pod2html|/usr/bin/core_perl/pod2html|g'
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR=$pkgdir install
+}
+
+# vim:set ts=2 sw=2 et: