summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Lamskoy2023-10-13 00:26:26 +0300
committerEugene Lamskoy2023-10-13 00:26:26 +0300
commite95b3e44b3cdb59e696767e8ae54ba258bb4d525 (patch)
tree2536709f56054bfcbea3dbb96d79d57b811648cd
parente77fc778fd851f9c8f65fe8c8eab3183012a3589 (diff)
downloadaur-e95b3e44b3cdb59e696767e8ae54ba258bb4d525.tar.gz
nltools added
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD26
2 files changed, 27 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffd47543e260..5236ebd980d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -31,6 +31,7 @@ pkgbase = husky-git
source = htick::git+https://github.com/huskyproject/htick.git
source = hptsqfix::git+https://github.com/huskyproject/hptsqfix.git
source = msged::git+https://github.com/huskyproject/msged.git
+ source = nltools::git+https://github.com/huskyproject/nltools.git
sha256sums = 73a603d930e184a1d094f53311916b4f8dcd8f7c31ea3373e236e797a3341a15
sha256sums = c5bb6b91f34b23cb1d2f9cff5d8d0956ce372cca3b602ada87ff3b4375498ea7
sha256sums = SKIP
@@ -48,5 +49,6 @@ pkgbase = husky-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
pkgname = husky-git
diff --git a/PKGBUILD b/PKGBUILD
index 15357694d616..520aad1f6b9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,9 +28,10 @@ source=(
'htick::git+https://github.com/huskyproject/htick.git'
'hptsqfix::git+https://github.com/huskyproject/hptsqfix.git'
'msged::git+https://github.com/huskyproject/msged.git'
+ 'nltools::git+https://github.com/huskyproject/nltools.git'
)
-_tosserModules="huskylib fidoconf smapi areafix hpt areastat bsopack sqpack nltools hptkill hptsqfix htick hptzip"
+_tosserModules="huskylib fidoconf smapi areafix hpt areastat bsopack sqpack nltools hptkill hptsqfix htick hptzip nltools"
_prefix=/usr
_wanna_shared=1
@@ -307,6 +308,28 @@ build() {
-DCMAKE_INSTALL_PREFIX:PATH=${_prefix}
cmake --build build-archlinux
popd
+
+ echo "BUILDING nltools"
+ pushd nltools
+ rm -rf build-archlinux
+ rm -rf huskylib smapi fidoconf hptzip
+ ln -s "../huskylib/huskylib" huskylib
+ ln -s "../smapi/smapi" smapi
+ ln -s "../fidoconf/fidoconf" fidoconf
+ ln -s "../hptzip/hptzip" hptzip
+ cp ../cvsdate.h ./
+ cmake \
+ -Bbuild-archlinux \
+ -DBUILD_SHARED_LIBS=OFF \
+ -Dcurses_LIB="/usr/lib/libcursesw.so" \
+ -Dhptzip_LIB="../hptzip/build-archlinux/libhptzip${_bld_lib}" \
+ -Dhusky_LIB="../huskylib/build-archlinux/libhusky${_bld_lib}" \
+ -Dfidoconfig_LIB="../fidoconf/build-archlinux/libfidoconfig${_bld_lib}" \
+ -Dsmapi_LIB="../smapi/build-archlinux/libsmapi${_bld_lib}" \
+ -DCMAKE_INSTALL_PREFIX:PATH=${_prefix}
+ cmake --build build-archlinux
+ popd
+
}
package() {
@@ -338,4 +361,5 @@ sha256sums=('73a603d930e184a1d094f53311916b4f8dcd8f7c31ea3373e236e797a3341a15'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')