summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Lamskoy2018-06-28 00:44:31 +0300
committerEugene Lamskoy2018-06-28 00:44:31 +0300
commit31e3e6a358032a8bb01bc28c113c2a534dad1204 (patch)
treeb283cb9bb2bf5d7c49f575aecb3551977f963583
parent633afbacd4b7c09b7156786158d16af2760af522 (diff)
downloadaur-31e3e6a358032a8bb01bc28c113c2a534dad1204.tar.gz
husky-all bundle
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 27 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d3001f9d149..ccf84d72b8bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -21,9 +21,18 @@ pkgbase = husky-tosser
md5sums = 6dc36f0c2d0a49a603a107035ba5f07a
pkgname = husky-tosser
- pkgdesc = Husky Fido Tosser Bundle - hpt, areafix and other tools
+ pkgdesc = Husky Fido Tosser: hpt (tosser) and netmail/echomail tools
+ conflicts = husky-all
pkgname = husky-msged
- pkgdesc = msged from Husky Fido Tosser bundle
+ pkgdesc = Husky Fido Tosser: msged (message editor)
depends = husky-tosser
+ conflicts = husky-all
+
+pkgname = husky-all
+ pkgdesc = Husky Fido Tosser Complete Bundle: hpt (tosser), netmail/echomail tools, msged (message editor)
+ provides = husky-tosser=1.9_20150211
+ provides = husky-msged=1.9_20150211
+ conflicts = husky-tosser
+ conflicts = husky-msged
diff --git a/PKGBUILD b/PKGBUILD
index d4fc86afddb2..54cad4e7c370 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-pkgname=(husky-tosser husky-msged)
+pkgname=(husky-tosser husky-msged husky-all)
_realpkg=husky
pkgver=1.9_20150211
pkgrel=1
@@ -39,19 +39,32 @@ build() {
}
package_husky-tosser() {
- pkgdesc='Husky Fido Tosser Bundle - hpt, areafix and other tools'
+ pkgdesc="Husky Fido Tosser: hpt (tosser) and netmail/echomail tools"
+ conflicts=("husky-all")
for i in $_tosserModules; do
cd "${srcdir}/${_realpkg}/${i}"
make DESTDIR="$pkgdir" install
done
}
package_husky-msged() {
- pkgdesc='msged from Husky Fido Tosser bundle'
+ pkgdesc='Husky Fido Tosser: msged (message editor)'
depends=('husky-tosser')
+ conflicts=("husky-all")
cd "${srcdir}/${_realpkg}/msged"
make DESTDIR="$pkgdir" install
}
+package_husky-all() {
+ pkgdesc='Husky Fido Tosser Complete Bundle: hpt (tosser), netmail/echomail tools, msged (message editor)'
+ provides=("husky-tosser=${pkgver}" "husky-msged=${pkgver}")
+ conflicts=("husky-tosser" "husky-msged")
+ for i in $_buildModules; do
+ cd "${srcdir}/${_realpkg}/${i}"
+ make DESTDIR="$pkgdir" install
+ done
+}
+
+
md5sums=('799c230ec374e22abcdb0b5452dce37c'
'0ec212f2bb31d149cd1717ab681f519a'
'48ba1f5f4ded114e500ef83ce1fe407a'