summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Lamskoy2018-06-01 18:53:00 +0300
committerEugene Lamskoy2018-06-01 18:54:13 +0300
commit541b83ea8922f33873c762a1ec5f9075631dfc60 (patch)
tree962d11d60a5ef5db4e6c22b7e675fc054d2ddb29
downloadaur-541b83ea8922f33873c762a1ec5f9075631dfc60.tar.gz
Initial release
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD42
-rw-r--r--areastat_makefile98
-rw-r--r--huskymak.cfg288
-rw-r--r--nltools_makefile90
-rw-r--r--smapi_makefile105
6 files changed, 646 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88874a252997
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Fri Jun 1 15:54:05 UTC 2018
+pkgbase = husky-tosser
+ pkgdesc = Husky Fido Tosser 1.9 (tosser and utils only, no msged)
+ pkgver = 1.9_20150211
+ pkgrel = 1
+ url = http://husky.sourceforge.net/hpt.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = huskymak.cfg
+ source = areastat_makefile
+ source = nltools_makefile
+ source = smapi_makefile
+ source = http://downloads.sourceforge.net/project/husky/husky/1.9-current/2015.02.11/husky-all-1.9-source-20150211.tgz
+ md5sums = 189e2dbe6704b9d30dd1f133371f017e
+ md5sums = 0ec212f2bb31d149cd1717ab681f519a
+ md5sums = 48ba1f5f4ded114e500ef83ce1fe407a
+ md5sums = c7238eec644bd1aeaf0a0c993f5dd8fc
+ md5sums = 6dc36f0c2d0a49a603a107035ba5f07a
+
+pkgname = husky-tosser
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4eb1e688a3f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# contributor Eugene Lamskoy
+# maintainer Ivan Agarkov ( ivan.agarkov@gmail.com )
+
+pkgname=husky-tosser
+_realpkg=husky
+pkgver=1.9_20150211
+pkgrel=1
+pkgdesc="Husky Fido Tosser 1.9 (tosser and utils only, no msged)"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://husky.sourceforge.net/hpt.html"
+source=('huskymak.cfg'
+ 'areastat_makefile'
+ 'nltools_makefile'
+ 'smapi_makefile'
+ 'http://downloads.sourceforge.net/project/husky/husky/1.9-current/2015.02.11/husky-all-1.9-source-20150211.tgz')
+
+prepare() {
+ cp -f huskymak.cfg ${_realpkg}/
+ cp -f areastat_makefile ${_realpkg}/areastat/Makefile
+ cp -f nltools_makefile ${_realpkg}/nltools/Makefile
+ cp -f smapi_makefile ${_realpkg}/smapi/Makefile
+}
+
+build() {
+ for i in huskylib smapi fidoconf areafix hpt htick areastat bsopack nltools; do
+ cd "${srcdir}/${_realpkg}/${i}"
+ make
+ done
+}
+
+package() {
+ for i in huskylib smapi fidoconf areafix hpt htick areastat bsopack nltools; do
+ cd "${srcdir}/${_realpkg}/${i}"
+ make DESTDIR="$pkgdir" install
+ done
+}
+md5sums=('189e2dbe6704b9d30dd1f133371f017e'
+ '0ec212f2bb31d149cd1717ab681f519a'
+ '48ba1f5f4ded114e500ef83ce1fe407a'
+ 'c7238eec644bd1aeaf0a0c993f5dd8fc'
+ '6dc36f0c2d0a49a603a107035ba5f07a')
diff --git a/areastat_makefile b/areastat_makefile
new file mode 100644
index 000000000000..34afb02636a3
--- /dev/null
+++ b/areastat_makefile
@@ -0,0 +1,98 @@
+# $Id: Makefile,v 1.7 2012/02/25 16:57:00 stas_degteff Exp $
+#
+# Generic Makefile for areastat (estt by Dmitry Rusov)
+
+.PHONY: docs html info mans clean distclean uninstall all install
+
+ifeq ($(DEBIAN), 1)
+# Every Debian-Source-Paket has one included.
+include /usr/share/husky/huskymak.cfg
+else
+include ../huskymak.cfg
+endif
+
+ifeq ($(DEBUG), 1)
+ CFLAGS = -I$(INCDIR) -Ih $(DEBCFLAGS) $(WARNFLAGS)
+ LFLAGS = $(DEBLFLAGS)
+else
+ CFLAGS = -I$(INCDIR) -Ih $(OPTCFLAGS) $(WARNFLAGS)
+ LFLAGS = $(OPTLFLAGS)
+endif
+
+ifneq ($(DYNLIBS), 1)
+ LFLAGS += -static -lc
+endif
+
+ifeq ($(SHORTNAME), 1)
+ LIBS = -L$(LIBDIR) -lfidoconf -lsmapi -lhusky
+else
+ LIBS = -L$(LIBDIR) -lfidoconfig -lsmapi -lhusky
+endif
+
+CDEFS=-D$(OSTYPE) -DUNAME=\"$(UNAME)\" $(ADDCDEFS)
+
+SRC_DIR=src/
+
+OBJS= areastat.o
+MANS= man/areastat.1 man/areastat.conf.5
+
+areastat: $(OBJS)
+ $(CC) $(OBJS) $(LFLAGS) $(LIBS) -o areastat
+
+
+%.o: $(SRC_DIR)%.c
+ $(CC) $(CFLAGS) $(CDEFS) -c $<
+
+info:
+ makeinfo --no-split areastat.texi
+
+html:
+ export LC_ALL=C; makeinfo --html --no-split areastat.texi
+
+docs: #info html
+
+
+man: $(foreach m,$(MANS),$(m).gz)
+
+%.gz: %
+ gzip -9c $< > $@
+
+clean:
+ rm -f *.o *~ src/*.o src/*~
+
+distclean: clean
+ -$(RM) $(RMOPT) areastat
+ -$(RM) $(RMOPT) areastat.info
+ -$(RM) $(RMOPT) areastat.html
+ -for m in $(MANS); do $(RM) $(RMOPT) $$m ; done
+
+all: areastat docs man
+
+install: all
+ $(INSTALL) $(IBOPT) areastat $(DESTDIR)$(BINDIR)
+ifdef INFODIR
+ -$(MKDIR) $(MKDIROPT) $(DESTDIR)$(INFODIR)
+ $(INSTALL) $(IMOPT) areastat.info $(DESTDIR)$(INFODIR)
+ -install-info --info-dir=$(DESTDIR)$(INFODIR) $(DESTDIR)$(INFODIR)$(DIRSEP)areastat.info
+endif
+ifdef HTMLDIR
+ -$(MKDIR) $(MKDIROPT) $(DESTDIR)$(HTMLDIR)
+ $(INSTALL) $(IMOPT) areastat*html $(DESTDIR)$(HTMLDIR)
+endif
+ifdef MANDIR
+ -$(MKDIR) $(MKDIROPT) $(DESTDIR)$(MANDIR)$(DIRSEP)man1
+ for m in $(MANS); do $(INSTALL) $(IMOPT) $$m.gz $(DESTDIR)$(MANDIR)$(DIRSEP)man1; done
+endif
+
+uninstall:
+ $(RM) $(RMOPT) $(BINDIR)$(DIRSEP)areastat$(EXE)
+ifdef INFODIR
+ $(RM) $(RMOPT) $(INFODIR)$(DIRSEP)areastat.info
+endif
+ifdef HTMLDIR
+ $(RM) $(RMOPT) $(HTMLDIR)$(DIRSEP)areastat.html
+endif
+ifdef MANDIR
+ $(RM) $(RMOPT) $(MANDIR)$(DIRSEP)man1$(DIRSEP)areastat.1.gz
+endif
+
diff --git a/huskymak.cfg b/huskymak.cfg
new file mode 100644
index 000000000000..9546fd7b23f5
--- /dev/null
+++ b/huskymak.cfg
@@ -0,0 +1,288 @@
+# Config-Makefile for Husky-packages
+# You must modify this file according to your needs.
+
+##############################################################################
+#PART 1: DIRECTORIES AND FILENAMES
+#You always need to change these to match your preferences
+##############################################################################
+
+# Prefix for all directories
+# Set to your homedir if you have no root privilegies
+PREFIX=/usr
+
+# Where libraries (both .a and .so files) should be placed
+# You should take care that this directory is listed in the LD_LIBRARY_PATH
+# environment variable (if necessary, modify your /etc/profile file).
+LIBDIR=$(PREFIX)/lib
+
+# Where the programs should be placed.
+BINDIR=$(PREFIX)/bin
+
+# Where manual pages should be placed.
+MANDIR=$(PREFIX)/man
+
+# Where include files should be placed (don't worry, no files will be over-
+# written, Husky will use its own subdirectories below this directory):
+INCDIR=$(PREFIX)/include
+
+# The fidoconfig config file will be in this DIRECTORY:
+CFGDIR=$(PREFIX)/etc/fido
+
+# Filename (without path) for the config file (default: config)
+#CFGNAME=config
+
+# IF you have a working texinfo installation (consisting of the "makeinfo"
+# and "install-info" programs), you should uncomment and adapt this
+# line - it will cause GNU info documentation to be built and installed
+# into the given directory. If you leave it commented out, the documentation
+# will not be compiled, and you won't know how to use the software ;-).
+# You should take care that this directory is listed in the INFOPATH
+# environment variable (if necessary, modify your /etc/profile file).
+# INFODIR=/usr/local/info
+
+# The same as above, but for DVI documentation. This requires a working
+# "texi2dvi" program.
+# DVIDIR=${PREFIX}/share/doc/husky
+
+# The same as above, but for HTML documentation. This requires a working
+# "texi2html" program.
+#HTMLDIR=$(PREFIX)/lib/husky
+
+
+MSGEDCFG=\"$(CFGDIR)/msged.cfg\"
+
+
+##############################################################################
+#PART 2: PLATFORM DEPENDENT SECTION
+#If you are running Linux with GNU gcc, you don't need to modify anything in
+#the following sections. If you are running any other operating system or using
+#any other C compiler, you should check the values. For some operating
+#systems, the comments contain information on what you need to change.
+##############################################################################
+
+
+##############################################################################
+# Programs
+##############################################################################
+
+# C-Compiler
+CC=gcc
+
+# C++-Compiler
+CXX=g++
+
+#Msged needs access to a termcap library. Define its name here.
+#On Linux, termcap is integrated into ncurses:
+TERMCAP=ncurses
+#On FreeBSD or commerical Unices, you may try one of the following:
+#TERMCAP=termcap
+#TERMCAP=terminfo
+
+# C++-Compiler
+GPP=g++
+
+# Pascal-Compiler (the compiler is optional, but the value of this
+# variable must be defined even if you don't have a Pascal compiler).
+PC=ppc386
+
+# archiver (for object-files)
+AR=ar
+
+# how to build shared libraries
+# use gcc on Linux and FreeBSD
+# use ld on BeOS and also try ld if gcc does not work for you
+# only "gcc" will put so version numbers into the shared object
+# On Solaris use "-G" as additional linkerflag !!!!!!!
+# MKSHARED=ld
+# LD=ld -G
+MKSHARED=gcc
+
+# remove file
+RM=rm
+
+# The "install" program.
+# On Linux and FreeBSD/NetBSD, use this:
+INSTALL=install
+# On Tru64 Unix, use this:
+# INSTALL=installbsd
+# On Solaris, use this:
+# INSTALL=/usr/ucb/install
+
+# link file (DOS: copy file)
+LN=ln
+
+# create directory
+MKDIR=mkdir
+
+# update dynamic library cache
+# If your operating system does not need this, you may comment out this line.
+#LDCONFIG=/sbin/ldconfig
+
+# rename a file
+MV=mv
+
+#copy a file
+CP=cp
+
+#Make a library file usable. You may leave this empty if it is n/a.
+RANLIB=ar s
+
+# C-style header file to pascal unit converter (shipped with fpc)
+H2PAS=h2pas
+
+#############################################################################
+# program options
+#############################################################################
+
+# type of operating system (UNIX,MSDOS,OS2,WINNT)
+# for BeOS, use UNIX!
+OSTYPE=UNIX
+
+# short name of operating system (used for PID lines etc.)
+UNAME=LNX
+#UNAME=BSD
+#UNAME=OS2
+#UNAME=BEOS
+
+# Do you want debug information? (This is for developers only.)
+DEBUG=0
+
+# 8.3 names - NOTE: This switch is obsolete and probably does not work!
+SHORTNAMES=0
+
+# Perl support
+PERL=0
+
+# ZipInternal packer
+USE_HPTZIP=0
+
+# The DYNLIBS switch controls if dynamic or static linkage is used.
+# This is tricky. If you set DYNLIBS=1, dynamic libraries (.so files)
+# will be generated and used. This will only work if you are running "gcc"
+# on Linux, FreeBSD or another real Unix operating system.
+
+# On other systems, you must set DYNLIBS=0. Even on Linux, you might
+# want to do this if you are sick of shared library version mismatch
+# problems.
+
+# If you set DYNLIBS=0, but have Unix/Linux, you might want to add
+# "-static" to the OPTCFLAGS and WARNCFLAGS variables (above) in order
+# to avoid linkage with old .so files that may be floating around
+# (see 'ifeq ( $(DYNLIBS), 0 )' conditions)
+#
+DYNLIBS=1
+
+# C-compiler: specify name of executable
+EXENAMEFLAG=-o
+
+# C-compiler: generate warnings
+WARNFLAGS=-Wall
+
+# C-compiler: optimization
+OPTCFLAGS=-c -s -O3 -fomit-frame-pointer -fstrength-reduce -fPIC
+
+ifeq ( $(DYNLIBS), 0 )
+ ifeq ($(OSTYPE), UNIX)
+ WARNFLAGS+= -static
+ OPTCFLAGS+= -static
+ endif
+endif
+
+# C-compiler: debug
+DEBCFLAGS=-c -ggdb
+
+# C-compiler: additional defines, for features of your OS
+# On Solaris, Msged only works with the curses interface, so use:
+#ADDCDEFS+=-DUSE_CURSES
+# Some FS and some OS don't support filelocking. Try alternative locking
+# *** THIS IS BETA-CODE *** report problems or success to FIDOSOFT.HUSKY ***
+#ADDCDEFS+=-DALTLOCKING
+# If your are not under UNIX, EMX or DJGPP and have popen() uncomment this:
+#ADDCDEFS+=-DHAVE_POPEN
+
+# Pascal-Compiler: optimization
+OPTPFLAGS=
+
+# Pascal-Compiler: debug
+DEBPFLAGS=
+
+# Pascal-Compiler: additional defines, for features of your OS
+ADDPDEFS=
+
+# object linker: optimization
+OPTLFLAGS=-s
+
+# object linker: debug
+DEBLFLAGS=-g
+
+# options for installing programs
+OPTIBOPT=-c -s -m 555
+DEBIBOPT=-c -m 555
+
+ifeq ($(DEBUG), 1)
+ IBOPT = $(DEBIBOPT)
+else
+ IBOPT = $(OPTIBOPT)
+endif
+
+# options for installing scripts
+ISOPT=-c -m 555
+
+# options for installing shared libs
+ILOPT=-c -m 555
+
+# options for installing static libs
+ISLOPT=-c -m 444
+
+# options for installing man-pages
+IMOPT=-c -m 444
+
+# options for installing includes
+IIOPT=-c -m 444
+
+# options for making links
+LNOPT=-sf
+
+# archiver options
+AR_R = r
+
+# options for creating directories
+MKDIROPT=-p
+
+# options for removing files (e.g. for clean, distclean, uninstall)
+RMOPT=-f
+
+
+#############################################################################
+# file extensions
+#############################################################################
+
+# extension of executable (e.g. ".exe")
+_EXE=
+
+# extension of object file
+_OBJ=.o
+
+# extension of static libs
+_LIB=.a
+
+# extension of dynamic libs
+_DLL=.so
+
+# extension of compiled pascal units
+_TPU=.ppu
+
+# directory separator (DOS-like: "\\", Unix-like: "/")
+
+ifeq (${OSTYPE}, UNIX)
+ DIRSEP=/
+else
+ DIRSEP=\\
+endif
+
+OPTCFLAGS += -I../fidoconf -I../huskylib -I../smapi -I../areafix
+WARNFLAGS += -I../fidoconf -I../huskylib -I../smapi -I../areafix
+LFLAGS += -L../huskylib -L../smapi -L../fidoconf -L../areafix
+OPTLFLAGS += -L../huskylib -L../smapi -L../fidoconf -L../areafix
+
+#export LD_LIBRARY_PATH=:../huskylib:../smapi:../fidoconf:../areafix
diff --git a/nltools_makefile b/nltools_makefile
new file mode 100644
index 000000000000..b0feb4b065ea
--- /dev/null
+++ b/nltools_makefile
@@ -0,0 +1,90 @@
+# $Id: Makefile,v 1.19 2012/04/18 18:08:10 stas_degteff Exp $
+# Makefile for nltools with Husky build enviroment
+# Use GNU version of 'make' program
+
+ifeq ($(DEBIAN), 1)
+# Every Debian-Source-Paket has one included.
+include /usr/share/husky/huskymak.cfg
+else
+include ../huskymak.cfg
+endif
+
+.PHONY: default
+
+all: default
+
+default: nldiff$(_EXE) nlcrc$(_EXE) ulc$(_EXE) nlupdate$(_EXE)
+
+ifeq ($(DEBUG), 1)
+ CFLAGS= -I$(INCDIR) -Ih $(DEBCFLAGS)
+ LFLAGS=$(DEBLFLAGS)
+else
+ CFLAGS= -I$(INCDIR) -Ih $(OPTCFLAGS)
+ LFLAGS=$(OPTLFLAGS)
+endif
+ifeq ($(SHORTNAME), 1)
+ LIBS=-L$(LIBDIR) -lfidoconf -lsmapi -lhusky
+else
+ LIBS=-L$(LIBDIR) -lfidoconfig -lsmapi -lhusky
+endif
+
+ifeq ($(USE_HPTZIP), 1)
+ LIBS+= -lhptzip -lz
+ CFLAGS += -DUSE_HPTZIP
+endif
+
+CDEFS=-D$(OSTYPE) $(ADDCDEFS)
+
+%$(_OBJ): src$(DIRSEP)%.c
+ $(CC) $(CFLAGS) $(CDEFS) -c $<
+
+nldiff$(_EXE): nldiff$(_OBJ) crc16$(_OBJ)
+ $(CC) $(LFLAGS) -o nldiff$(_EXE) nldiff$(_OBJ) crc16$(_OBJ) \
+ $(LIBS)
+
+nlcrc$(_EXE): crc16$(_OBJ) nlcrc$(_OBJ)
+ $(CC) $(LFLAGS) -o nlcrc$(_EXE) crc16$(_OBJ) nlcrc$(_OBJ) \
+ $(LIBS)
+
+ulc$(_EXE): ulcsort$(_OBJ) ulcomp$(_OBJ) ulc$(_OBJ) string$(_OBJ) \
+ nldate$(_OBJ) julian$(_OBJ) nlfind$(_OBJ)
+ $(CC) $(LFLAGS) -o ulc$(_EXE) ulcsort$(_OBJ) ulcomp$(_OBJ) ulc$(_OBJ) \
+ string$(_OBJ) nldate$(_OBJ) julian$(_OBJ) nlfind$(_OBJ) \
+ $(LIBS)
+
+nlupdate$(_EXE): nlupdate$(_OBJ) string$(_OBJ) nldate$(_OBJ) julian$(_OBJ) \
+ nlfind$(_OBJ)
+ $(CC) $(LFLAGS) -o nlupd$(_EXE) nlupdate$(_OBJ) string$(_OBJ) \
+ nldate$(_OBJ) julian$(_OBJ) nlfind$(_OBJ) $(LIBS)
+
+clean:
+ -$(RM) $(RMOPT) crc16$(_OBJ)
+ -$(RM) $(RMOPT) nlcrc$(_OBJ)
+ -$(RM) $(RMOPT) nldiff$(_OBJ)
+ -$(RM) $(RMOPT) ulc$(_OBJ)
+ -$(RM) $(RMOPT) ulcomp$(_OBJ)
+ -$(RM) $(RMOPT) ulcsort$(_OBJ)
+ -$(RM) $(RMOPT) julian$(_OBJ)
+ -$(RM) $(RMOPT) nlfind$(_OBJ)
+ -$(RM) $(RMOPT) nldate$(_OBJ)
+ -$(RM) $(RMOPT) nlupdate$(_OBJ)
+ -$(RM) $(RMOPT) string$(_OBJ)
+ -$(RM) $(RMOPT) patmat$(_OBJ)
+
+distclean: clean
+ -$(RM) $(RMOPT) nlcrc$(_EXE)
+ -$(RM) $(RMOPT) nldiff$(_EXE)
+ -$(RM) $(RMOPT) ulc$(_EXE)
+ -$(RM) $(RMOPT) nlupd$(_EXE)
+
+install: ulc$(_EXE) nldiff$(_EXE) nlcrc$(_EXE) nlupd$(_EXE)
+ $(INSTALL) $(IBOPT) ulc$(_EXE) $(DESTDIR)$(BINDIR)
+ $(INSTALL) $(IBOPT) nldiff$(_EXE) $(DESTDIR)$(BINDIR)
+ $(INSTALL) $(IBOPT) nlcrc$(_EXE) $(DESTDIR)$(BINDIR)
+ $(INSTALL) $(IBOPT) nlupd$(_EXE) $(DESTDIR)$(BINDIR)
+
+uninstall:
+ -$(RM) $(RMOPT) $(BINDIR)$(DIRSEP)ulc$(_EXE)
+ -$(RM) $(RMOPT) $(BINDIR)$(DIRSEP)nldiff$(_EXE)
+ -$(RM) $(RMOPT) $(BINDIR)$(DIRSEP)nlcrc$(_EXE)
+ -$(RM) $(RMOPT) $(BINDIR)$(DIRSEP)nlupd$(_EXE)
diff --git a/smapi_makefile b/smapi_makefile
new file mode 100644
index 000000000000..f75c4b22bbb9
--- /dev/null
+++ b/smapi_makefile
@@ -0,0 +1,105 @@
+# Makefile for the Husky build environment
+
+# include Husky-Makefile-Config
+ifeq ($(DEBIAN), 1)
+# Every Debian-Source-Paket has one included.
+include /usr/share/husky/huskymak.cfg
+else ifdef RPM_BUILD_ROOT
+# RPM build requires all files to be in the source directory
+include huskymak.cfg
+else
+include ../huskymak.cfg
+endif
+
+ifeq ($(OSTYPE), UNIX)
+ LIBPREFIX=lib
+ DLLPREFIX=lib
+endif
+
+include make/makefile.inc
+
+ifeq ($(DEBUG), 1)
+ CFLAGS=$(WARNFLAGS) $(DEBCFLAGS)
+ LFLAGS=$(DEBLFLAGS)
+else
+ CFLAGS=$(WARNFLAGS) $(OPTCFLAGS)
+ LFLAGS=$(OPTLFLAGS)
+endif
+
+SRC_DIR = src/
+H_DIR = smapi
+
+CDEFS=-D$(OSTYPE) $(ADDCDEFS) -I$(H_DIR) -I$(INCDIR)
+LIBS=-lhusky
+
+ifeq ($(DYNLIBS), 1)
+all: $(TARGETLIB) $(TARGETDLL).$(VER)
+else
+all: $(TARGETLIB)
+endif
+
+
+%$(_OBJ): $(SRC_DIR)%.c
+ $(CC) $(CFLAGS) $(CDEFS) $(SRC_DIR)$*.c
+
+$(TARGETLIB): $(OBJS)
+ $(AR) $(AR_R) $(TARGETLIB) $?
+ifdef RANLIB
+ $(RANLIB) $(TARGETLIB)
+endif
+
+ifeq ($(DYNLIBS), 1)
+ ifeq (~$(MKSHARED)~,~ld~)
+$(TARGETDLL).$(VER): $(OBJS)
+ $(LD) $(LFLAGS) -o $(TARGETDLL).$(VER) $(OBJS) -L$(LIBDIR) $(LIBS)
+ else
+$(TARGETDLL).$(VER): $(OBJS)
+ $(CC) $(LFLAGS) -shared -Wl,-soname,$(TARGETDLL).$(VERH) \
+ -o $(TARGETDLL).$(VER) $(OBJS) -L$(LIBDIR) $(LIBS)
+ endif
+
+instdyn: $(TARGETLIB) $(TARGETDLL).$(VER)
+ -$(MKDIR) $(MKDIROPT) $(DESTDIR)$(DIRSEP)$(LIBDIR)
+ $(INSTALL) $(ILOPT) $(TARGETDLL).$(VER) $(DESTDIR)$(DIRSEP)$(LIBDIR)
+ -$(RM) $(RMOPT) $(DESTDIR)$(DIRSEP)$(LIBDIR)$(DIRSEP)$(TARGETDLL).$(VERH)
+ -$(RM) $(RMOPT) $(DESTDIR)$(DIRSEP)$(LIBDIR)$(DIRSEP)$(TARGETDLL)
+# Changed the symlinks from symlinks with full path to just symlinks.
+# Better so :)
+ cd $(DESTDIR)$(DIRSEP)$(LIBDIR) ;\
+ $(LN) $(LNOPT) $(TARGETDLL).$(VER) $(TARGETDLL).$(VERH) ;\
+ $(LN) $(LNOPT) $(TARGETDLL).$(VER) $(TARGETDLL)
+ifneq (~$(LDCONFIG)~, ~~)
+ $(LDCONFIG)
+endif
+
+else
+instdyn: $(TARGETLIB)
+
+endif
+
+FORCE:
+
+install-h-dir: FORCE
+ -$(MKDIR) $(MKDIROPT) $(DESTDIR)$(DIRSEP)$(INCDIR)$(DIRSEP)$(H_DIR)
+
+%.h: FORCE
+ -$(INSTALL) $(IIOPT) $(H_DIR)$(DIRSEP)$@ $(DESTDIR)$(DIRSEP)$(INCDIR)$(DIRSEP)$(H_DIR)
+
+install-h: install-h-dir $(HEADERS)
+
+install: install-h instdyn
+ -$(MKDIR) $(MKDIROPT) $(DESTDIR)$(DIRSEP)$(LIBDIR)
+ $(INSTALL) $(ISLOPT) $(TARGETLIB) $(DESTDIR)$(DIRSEP)$(LIBDIR)
+
+uninstall:
+ -cd $(DESTDIR)$(DIRSEP)$(INCDIR)$(DIRSEP)$(H_DIR) ;\
+ $(RM) $(RMOPT) $(HEADERS)
+ -$(RM) $(RMOPT) $(DESTDIR)$(DIRSEP)$(LIBDIR)$(DIRSEP)$(TARGETLIB)
+ -$(RM) $(RMOPT) $(DESTDIR)$(DIRSEP)$(LIBDIR)$(DIRSEP)$(TARGETDLL)*
+
+clean:
+ -$(RM) $(RMOPT) *$(_OBJ)
+
+distclean: clean
+ -$(RM) $(RMOPT) $(TARGETLIB)
+ -$(RM) $(RMOPT) $(TARGETDLL).$(VER)