summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2024-01-02 14:19:49 +0800
committertaotieren2024-01-02 14:19:49 +0800
commitad093a314fa6da3ee10768b101017a3cee25632a (patch)
tree1ebe95803817e113f1fa0fc5982bad700ec4e76d
downloadaur-ad093a314fa6da3ee10768b101017a3cee25632a.tar.gz
update hvml-fpm-git
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD78
2 files changed, 109 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4154321b6f72
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = hvml-fpm-git
+ pkgdesc = The HVML FastCGI Process Manager: an HVML FastCGI implementation.
+ pkgver = r22.f030336
+ pkgrel = 1
+ url = https://github.com/HVML/HVML-FPM
+ arch = x86_64
+ arch = aarch64
+ arch = riscv64
+ arch = mips64
+ arch = powerpc
+ arch = powerpc64le
+ groups = hvml-git
+ groups = hybridos2-git
+ license = LGPL-3.0
+ makedepends = ccache
+ makedepends = cmake
+ makedepends = git
+ makedepends = ninja
+ makedepends = python
+ makedepends = zlib
+ depends = glib2
+ depends = glibc
+ depends = purc
+ optdepends = xguipro: xGUI (the X Graphics User Interface) Pro is a modern, cross-platform, and advanced HVML renderer which is based on tailored WebKit.
+ provides = hvml-fpm
+ conflicts = hvml-fpm
+ options = !strip
+ source = hvml-fpm-git::git+https://github.com/HVML/HVML-FPM.git
+ sha256sums = SKIP
+
+pkgname = hvml-fpm-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7cd735d17d87
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,78 @@
+# Maintainer: taotieren <admin@taotieren.com>
+
+pkgbase=hvml-fpm-git
+pkgname=hvml-fpm-git
+pkgver=r22.f030336
+pkgrel=1
+pkgdesc="The HVML FastCGI Process Manager: an HVML FastCGI implementation."
+arch=(x86_64
+ aarch64
+ riscv64
+ mips64
+ powerpc
+ powerpc64le)
+url="https://github.com/HVML/HVML-FPM"
+license=('LGPL-3.0')
+groups=(hvml-git
+ hybridos2-git)
+provides=(${pkgbase%-git})
+conflicts=(${pkgbase%-git})
+replaces=()
+depends=(glib2
+ glibc
+ purc)
+makedepends=(
+ ccache
+ cmake
+# fcgi
+ git
+ ninja
+ python
+ zlib)
+checkdepends=()
+optdepends=('xguipro: xGUI (the X Graphics User Interface) Pro is a modern, cross-platform, and advanced HVML renderer which is based on tailored WebKit.')
+source=("${pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+options=('!strip')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ ( set -o pipefail
+ git describe --long --tag --abbrev=7 2>/dev/null | sed 's/^v//g;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+ )
+}
+
+prepare()
+{
+ git -C "${srcdir}/${pkgname}" clean -dfx
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+
+# see:https://wiki.archlinux.org/title/CMake_package_guidelines
+# cmake -DCMAKE_BUILD_TYPE=Release \
+# gcc build
+ cmake -DCMAKE_BUILD_TYPE=None \
+ -DPORT=Linux \
+ -DENABLE_API_TESTS=ON \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DSYSEXEC_INSTALL_DIR=/usr/bin \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_LIBEXECDIR=lib \
+ -B build \
+ -G Ninja
+
+ ninja -C build
+}
+
+
+# check() {
+# cd "${srcdir}/${pkgname}/build/bin/"
+# bash ./testexecutor
+# }
+
+package() {
+ DESTDIR="${pkgdir}" ninja -C "${srcdir}"/${pkgname}/build install
+}