summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2017-04-27 20:49:24 +0100
committerEric Engestrom2017-04-27 20:49:24 +0100
commit223ebdba2ff44adb2beda6421cc5baa50e9738ae (patch)
tree1d9348149d22777fa91ac8db36e5f9573ef82ef5
parentbe4c869c82852d95cc315183cf1f467a1c5d4a89 (diff)
downloadaur-223ebdba2ff44adb2beda6421cc5baa50e9738ae.tar.gz
update to 1.2-1 and split of git version to hw-probe-git
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD17
3 files changed, 10 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e0e951e91bd..2291de11c70e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,23 @@
pkgbase = hw-probe
pkgdesc = Tool to probe for hardware, check its operability and upload result to the Linux hardware DB: http://linux-hardware.org
- pkgver = r3.0015b3d
+ pkgver = 1.2
pkgrel = 1
url = https://github.com/linuxhw/hw-probe
arch = any
license = GPLv2
- makedepends = git
depends = perl>=5
depends = hwinfo
depends = curl
depends = dmidecode
depends = pciutils
depends = usbutils
+ depends = net-tools
optdepends = hdparm
optdepends = smartmontools
optdepends = inxi
optdepends = pnputils
provides = hw-probe
- source = https://github.com/linuxhw/hw-probe
+ source = https://github.com/linuxhw/hw-probe/archive/1.2.tar.gz
md5sums = SKIP
pkgname = hw-probe
diff --git a/.gitignore b/.gitignore
index c82ba50b8dfe..464ea1267f04 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,2 @@
-/hw-probe/
+/*.tar.gz
/*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
index 56cf36324824..736e7146b047 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,20 @@
# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
pkgname=hw-probe
-pkgver=r3.0015b3d
+pkgver=1.2
pkgrel=1
pkgdesc="Tool to probe for hardware, check its operability and upload result to the Linux hardware DB: http://linux-hardware.org"
arch=('any')
url="https://github.com/linuxhw/hw-probe"
license=('GPLv2')
-makedepends=('git')
-source=("git+$url")
+source=("$url/archive/$pkgver.tar.gz")
md5sums=('SKIP')
-depends=('perl>=5' 'hwinfo' 'curl' 'dmidecode' 'pciutils' 'usbutils')
+depends=('perl>=5' 'hwinfo' 'curl' 'dmidecode' 'pciutils' 'usbutils' 'net-tools')
optdepends=('hdparm' 'smartmontools' 'inxi' 'pnputils')
provides=('hw-probe')
-pkgver() {
- cd "${srcdir}/hw-probe"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
package() {
- cd "${srcdir}/hw-probe"
- install -Dm755 hw-probe.pl "${pkgdir}/usr/bin/${provides[0]}"
+ cd "$srcdir"/hw-probe-$pkgver
+ install -dm755 "$pkgdir"/usr
+ make install prefix="$pkgdir"/usr
}