summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2016-06-11 12:52:06 +0100
committerEric Engestrom2016-06-11 12:52:06 +0100
commitbe4c869c82852d95cc315183cf1f467a1c5d4a89 (patch)
tree75e38d9fbccb0ae26407441c4c005f5a379d3450
downloadaur-be4c869c82852d95cc315183cf1f467a1c5d4a89.tar.gz
initial commit - r3.0015b3d-1
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD25
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e0e951e91bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = hw-probe
+ pkgdesc = Tool to probe for hardware, check its operability and upload result to the Linux hardware DB: http://linux-hardware.org
+ pkgver = r3.0015b3d
+ pkgrel = 1
+ url = https://github.com/linuxhw/hw-probe
+ arch = any
+ license = GPLv2
+ makedepends = git
+ depends = perl>=5
+ depends = hwinfo
+ depends = curl
+ depends = dmidecode
+ depends = pciutils
+ depends = usbutils
+ optdepends = hdparm
+ optdepends = smartmontools
+ optdepends = inxi
+ optdepends = pnputils
+ provides = hw-probe
+ source = https://github.com/linuxhw/hw-probe
+ md5sums = SKIP
+
+pkgname = hw-probe
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c82ba50b8dfe
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+/hw-probe/
+/*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56cf36324824
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
+
+pkgname=hw-probe
+pkgver=r3.0015b3d
+pkgrel=1
+pkgdesc="Tool to probe for hardware, check its operability and upload result to the Linux hardware DB: http://linux-hardware.org"
+arch=('any')
+url="https://github.com/linuxhw/hw-probe"
+license=('GPLv2')
+makedepends=('git')
+source=("git+$url")
+md5sums=('SKIP')
+depends=('perl>=5' 'hwinfo' 'curl' 'dmidecode' 'pciutils' 'usbutils')
+optdepends=('hdparm' 'smartmontools' 'inxi' 'pnputils')
+provides=('hw-probe')
+
+pkgver() {
+ cd "${srcdir}/hw-probe"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/hw-probe"
+ install -Dm755 hw-probe.pl "${pkgdir}/usr/bin/${provides[0]}"
+}