summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroutfoxxed2023-09-30 00:33:25 -0700
committeroutfoxxed2023-09-30 00:38:48 -0700
commit4d9fe0e384870d5eeee4e26e33b811f0be892dd3 (patch)
tree1fedef15648eab895101a209f82afa3d0104da42
downloadaur-4d9fe0e384870d5eeee4e26e33b811f0be892dd3.tar.gz
Package hy3 stable revision 0.30.0
-rw-r--r--.SRCINFO17
-rwxr-xr-xPKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6df48eacb19a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = hy3
+ pkgdesc = Hyprland plugin for i3 like tiling
+ pkgver = 0.30.0
+ pkgrel = 1
+ url = https://github.com/outfoxxed/hy3
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ depends = gcc-libs
+ depends = glibc
+ depends = hyprland=0.30.0
+ conflicts = hyprland-git
+ source = hy3-0.30.0.tar.gz::https://github.com/outfoxxed/hy3/archive/refs/tags/hl0.30.0.tar.gz
+ sha256sums = 18c23136d3bf0d1b0f7229cdd092c99a0bdf64d45e69b70fcdde1a2a0d531f05
+
+pkgname = hy3
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..69e336225b27
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: outfoxxed <outfoxxed@outfoxxed.me>
+
+pkgname=hy3
+pkgver=0.30.0
+pkgrel=1
+pkgdesc='Hyprland plugin for i3 like tiling'
+arch=('x86_64')
+url='https://github.com/outfoxxed/hy3'
+license=('GPL3')
+makedepends=('git' 'cmake')
+depends=('gcc-libs' 'glibc' 'hyprland=0.30.0')
+conflicts=('hyprland-git')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/hl$pkgver.tar.gz")
+sha256sums=('18c23136d3bf0d1b0f7229cdd092c99a0bdf64d45e69b70fcdde1a2a0d531f05')
+
+build() {
+ cmake -B build -S "$pkgname-hl$pkgver" -DCMAKE_BUILD_TYPE=Debug -DCMAKE_INSTALL_PREFIX='/usr'
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}