summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP Cimalando2018-05-27 21:37:07 +0200
committerJP Cimalando2018-05-27 21:37:27 +0200
commit1182a1532a9046b1937d18a7302edd6bee20f546 (patch)
tree86a5590c6756427424d74c76d8bb720958efb908
downloadaur-1182a1532a9046b1937d18a7302edd6bee20f546.tar.gz
initial version
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD51
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c227459bf4a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = hybridreverb2-git
+ pkgdesc = Hybrid impulse convolution reverb, available as LV2 and VST
+ pkgver = r12.3a5e6dc
+ pkgrel = 1
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = unzip
+ depends = fftw
+ depends = alsa-lib
+ depends = freetype2
+ depends = libxext
+ source = git+https://github.com/jpcima/HybridReverb2.git
+ source = http://www2.ika.ruhr-uni-bochum.de/HybridReverb2/HybridReverb2_large_database.zip
+ sha256sums = SKIP
+ sha256sums = 55805e9b1c914d3486aec02d0242e3ff92e85b9e24aaa9899be9a3ae562edb4a
+
+pkgname = hybridreverb2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58072552238d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: JP Cimalando <jp-dev inbox.ru>
+pkgname=hybridreverb2-git
+_pkgname=HybridReverb2
+pkgver=r12.3a5e6dc
+pkgrel=1
+epoch=
+pkgdesc="Hybrid impulse convolution reverb, available as LV2 and VST"
+arch=('i686' 'x86_64')
+url=""
+license=('GPL')
+groups=()
+depends=('fftw' 'alsa-lib' 'freetype2' 'libxext')
+makedepends=('unzip')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+https://github.com/jpcima/$_pkgname.git"
+ "http://www2.ika.ruhr-uni-bochum.de/$_pkgname/${_pkgname}_large_database.zip")
+noextract=()
+sha256sums=('SKIP'
+ '55805e9b1c914d3486aec02d0242e3ff92e85b9e24aaa9899be9a3ae562edb4a')
+validpgpkeys=()
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$_pkgname"
+ git submodule update --init --recursive
+}
+
+build() {
+ mkdir -p "$_pkgname"/build
+ cd "$_pkgname"/build
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd "$_pkgname/build"
+ make DESTDIR="$pkgdir/" install
+ unzip -d "$pkgdir"/usr/share/"$_pkgname" "$srcdir"/"$_pkgname"_large_database.zip
+}