summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP Cimalando2019-11-26 03:42:14 +0100
committerJP Cimalando2019-11-26 03:42:14 +0100
commit95d58cbd72ad4dac27a11bce6825501d18f8dd39 (patch)
treee2b0c5388fea5e50cf858f54e364798dd4ebe0af
parent14a9080c55ceb57428903b1608f2c8d91ab9650f (diff)
downloadaur-95d58cbd72ad4dac27a11bce6825501d18f8dd39.tar.gz
Try re-adding juce-gcc9.patch in binary mode, preserving CRLF
-rw-r--r--.SRCINFO2
-rw-r--r--.gitattributes1
-rw-r--r--PKGBUILD2
-rw-r--r--juce-gcc9.patch272
4 files changed, 139 insertions, 138 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 401436cc8a62..5cc432857d66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hybridreverb2-git
pkgdesc = Hybrid impulse convolution reverb, available as LV2 and VST
pkgver = r92.6beac8e
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/jpcima/HybridReverb2
arch = i686
arch = x86_64
diff --git a/.gitattributes b/.gitattributes
new file mode 100644
index 000000000000..c480e811fbfe
--- /dev/null
+++ b/.gitattributes
@@ -0,0 +1 @@
+*.patch binary
diff --git a/PKGBUILD b/PKGBUILD
index dc36e70058e0..6dfbe2878771 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=hybridreverb2-git
_pkgname=HybridReverb2
pkgver=r92.6beac8e
_rirver=1.0.0
-pkgrel=2
+pkgrel=3
epoch=
pkgdesc="Hybrid impulse convolution reverb, available as LV2 and VST"
arch=('i686' 'x86_64')
diff --git a/juce-gcc9.patch b/juce-gcc9.patch
index 864ca289ef09..13b604ef9851 100644
--- a/juce-gcc9.patch
+++ b/juce-gcc9.patch
@@ -3,149 +3,149 @@ index c57ad53c635..934c61c4781 100644
--- a/modules/juce_graphics/colour/juce_PixelFormats.h
+++ b/modules/juce_graphics/colour/juce_PixelFormats.h
@@ -107,22 +107,9 @@ class JUCE_API PixelARGB
-
- //==============================================================================
- forcedinline uint8 getAlpha() const noexcept { return components.a; }
-- forcedinline uint8 getRed() const noexcept { return components.r; }
-+ forcedinline uint8 getRed() const noexcept { return components.r; }
- forcedinline uint8 getGreen() const noexcept { return components.g; }
-- forcedinline uint8 getBlue() const noexcept { return components.b; }
--
-- #if JUCE_GCC
-- // NB these are here as a workaround because GCC refuses to bind to packed values.
-- forcedinline uint8& getAlpha() noexcept { return comps [indexA]; }
-- forcedinline uint8& getRed() noexcept { return comps [indexR]; }
-- forcedinline uint8& getGreen() noexcept { return comps [indexG]; }
-- forcedinline uint8& getBlue() noexcept { return comps [indexB]; }
-- #else
-- forcedinline uint8& getAlpha() noexcept { return components.a; }
-- forcedinline uint8& getRed() noexcept { return components.r; }
-- forcedinline uint8& getGreen() noexcept { return components.g; }
-- forcedinline uint8& getBlue() noexcept { return components.b; }
-- #endif
-+ forcedinline uint8 getBlue() const noexcept { return components.b; }
-
- //==============================================================================
- /** Copies another pixel colour over this one.
+
+ //==============================================================================
+ forcedinline uint8 getAlpha() const noexcept { return components.a; }
+- forcedinline uint8 getRed() const noexcept { return components.r; }
++ forcedinline uint8 getRed() const noexcept { return components.r; }
+ forcedinline uint8 getGreen() const noexcept { return components.g; }
+- forcedinline uint8 getBlue() const noexcept { return components.b; }
+-
+- #if JUCE_GCC
+- // NB these are here as a workaround because GCC refuses to bind to packed values.
+- forcedinline uint8& getAlpha() noexcept { return comps [indexA]; }
+- forcedinline uint8& getRed() noexcept { return comps [indexR]; }
+- forcedinline uint8& getGreen() noexcept { return comps [indexG]; }
+- forcedinline uint8& getBlue() noexcept { return comps [indexB]; }
+- #else
+- forcedinline uint8& getAlpha() noexcept { return components.a; }
+- forcedinline uint8& getRed() noexcept { return components.r; }
+- forcedinline uint8& getGreen() noexcept { return components.g; }
+- forcedinline uint8& getBlue() noexcept { return components.b; }
+- #endif
++ forcedinline uint8 getBlue() const noexcept { return components.b; }
+
+ //==============================================================================
+ /** Copies another pixel colour over this one.
@@ -341,9 +328,6 @@ class JUCE_API PixelARGB
- {
- uint32 internal;
- Components components;
-- #if JUCE_GCC
-- uint8 comps[4]; // helper struct needed because gcc does not allow references to packed union members
-- #endif
- };
- }
- #ifndef DOXYGEN
+ {
+ uint32 internal;
+ Components components;
+- #if JUCE_GCC
+- uint8 comps[4]; // helper struct needed because gcc does not allow references to packed union members
+- #endif
+ };
+ }
+ #ifndef DOXYGEN
@@ -428,13 +412,9 @@ class JUCE_API PixelRGB
-
- //==============================================================================
- forcedinline uint8 getAlpha() const noexcept { return 0xff; }
-- forcedinline uint8 getRed() const noexcept { return r; }
-+ forcedinline uint8 getRed() const noexcept { return r; }
- forcedinline uint8 getGreen() const noexcept { return g; }
-- forcedinline uint8 getBlue() const noexcept { return b; }
--
-- forcedinline uint8& getRed() noexcept { return r; }
-- forcedinline uint8& getGreen() noexcept { return g; }
-- forcedinline uint8& getBlue() noexcept { return b; }
-+ forcedinline uint8 getBlue() const noexcept { return b; }
-
- //==============================================================================
- /** Copies another pixel colour over this one.
+
+ //==============================================================================
+ forcedinline uint8 getAlpha() const noexcept { return 0xff; }
+- forcedinline uint8 getRed() const noexcept { return r; }
++ forcedinline uint8 getRed() const noexcept { return r; }
+ forcedinline uint8 getGreen() const noexcept { return g; }
+- forcedinline uint8 getBlue() const noexcept { return b; }
+-
+- forcedinline uint8& getRed() noexcept { return r; }
+- forcedinline uint8& getGreen() noexcept { return g; }
+- forcedinline uint8& getBlue() noexcept { return b; }
++ forcedinline uint8 getBlue() const noexcept { return b; }
+
+ //==============================================================================
+ /** Copies another pixel colour over this one.
@@ -651,11 +631,9 @@ class JUCE_API PixelAlpha
-
- //==============================================================================
- forcedinline uint8 getAlpha() const noexcept { return a; }
-- forcedinline uint8& getAlpha() noexcept { return a; }
--
-- forcedinline uint8 getRed() const noexcept { return 0; }
-+ forcedinline uint8 getRed() const noexcept { return 0; }
- forcedinline uint8 getGreen() const noexcept { return 0; }
-- forcedinline uint8 getBlue() const noexcept { return 0; }
-+ forcedinline uint8 getBlue() const noexcept { return 0; }
-
- //==============================================================================
- /** Copies another pixel colour over this one.
+
+ //==============================================================================
+ forcedinline uint8 getAlpha() const noexcept { return a; }
+- forcedinline uint8& getAlpha() noexcept { return a; }
+-
+- forcedinline uint8 getRed() const noexcept { return 0; }
++ forcedinline uint8 getRed() const noexcept { return 0; }
+ forcedinline uint8 getGreen() const noexcept { return 0; }
+- forcedinline uint8 getBlue() const noexcept { return 0; }
++ forcedinline uint8 getBlue() const noexcept { return 0; }
+
+ //==============================================================================
+ /** Copies another pixel colour over this one.
diff --git a/modules/juce_graphics/native/juce_RenderingHelpers.h b/modules/juce_graphics/native/juce_RenderingHelpers.h
index b8137ac4d04..10bd64e1459 100644
--- a/modules/juce_graphics/native/juce_RenderingHelpers.h
+++ b/modules/juce_graphics/native/juce_RenderingHelpers.h
@@ -577,18 +577,10 @@ namespace EdgeTableFillers
- : destData (image), sourceColour (colour)
- {
- if (sizeof (PixelType) == 3 && (size_t) destData.pixelStride == sizeof (PixelType))
-- {
- areRGBComponentsEqual = sourceColour.getRed() == sourceColour.getGreen()
- && sourceColour.getGreen() == sourceColour.getBlue();
-- filler[0].set (sourceColour);
-- filler[1].set (sourceColour);
-- filler[2].set (sourceColour);
-- filler[3].set (sourceColour);
-- }
- else
-- {
- areRGBComponentsEqual = false;
-- }
- }
-
- forcedinline void setEdgeTableYPos (int y) noexcept
+ : destData (image), sourceColour (colour)
+ {
+ if (sizeof (PixelType) == 3 && (size_t) destData.pixelStride == sizeof (PixelType))
+- {
+ areRGBComponentsEqual = sourceColour.getRed() == sourceColour.getGreen()
+ && sourceColour.getGreen() == sourceColour.getBlue();
+- filler[0].set (sourceColour);
+- filler[1].set (sourceColour);
+- filler[2].set (sourceColour);
+- filler[3].set (sourceColour);
+- }
+ else
+- {
+ areRGBComponentsEqual = false;
+- }
+ }
+
+ forcedinline void setEdgeTableYPos (int y) noexcept
@@ -670,7 +662,6 @@ namespace EdgeTableFillers
- const Image::BitmapData& destData;
- PixelType* linePixels;
- PixelARGB sourceColour;
-- PixelRGB filler[4];
- bool areRGBComponentsEqual;
-
- forcedinline PixelType* getPixel (int x) const noexcept
+ const Image::BitmapData& destData;
+ PixelType* linePixels;
+ PixelARGB sourceColour;
+- PixelRGB filler[4];
+ bool areRGBComponentsEqual;
+
+ forcedinline PixelType* getPixel (int x) const noexcept
@@ -685,47 +676,10 @@ namespace EdgeTableFillers
-
- forcedinline void replaceLine (PixelRGB* dest, PixelARGB colour, int width) const noexcept
- {
-- if ((size_t) destData.pixelStride == sizeof (*dest))
-- {
-- if (areRGBComponentsEqual) // if all the component values are the same, we can cheat..
-- {
-- memset ((void*) dest, colour.getRed(), (size_t) width * 3);
-- }
-- else
-- {
-- if (width >> 5)
-- {
-- auto intFiller = reinterpret_cast<const int*> (filler);
--
-- while (width > 8 && (((pointer_sized_int) dest) & 7) != 0)
-- {
-- dest->set (colour);
-- ++dest;
-- --width;
-- }
--
-- while (width > 4)
-- {
-- auto d = reinterpret_cast<int*> (dest);
-- *d++ = intFiller[0];
-- *d++ = intFiller[1];
-- *d++ = intFiller[2];
-- dest = reinterpret_cast<PixelRGB*> (d);
-- width -= 4;
-- }
-- }
--
-- while (--width >= 0)
-- {
-- dest->set (colour);
-- ++dest;
-- }
-- }
-- }
-+ if ((size_t) destData.pixelStride == sizeof (*dest) && areRGBComponentsEqual)
-+ memset ((void*) dest, colour.getRed(), (size_t) width * 3); // if all the component values are the same, we can cheat..
- else
-- {
-- JUCE_PERFORM_PIXEL_OP_LOOP (set (colour))
-- }
-+ JUCE_PERFORM_PIXEL_OP_LOOP (set (colour));
- }
-
- forcedinline void replaceLine (PixelAlpha* dest, const PixelARGB colour, int width) const noexcept
+
+ forcedinline void replaceLine (PixelRGB* dest, PixelARGB colour, int width) const noexcept
+ {
+- if ((size_t) destData.pixelStride == sizeof (*dest))
+- {
+- if (areRGBComponentsEqual) // if all the component values are the same, we can cheat..
+- {
+- memset ((void*) dest, colour.getRed(), (size_t) width * 3);
+- }
+- else
+- {
+- if (width >> 5)
+- {
+- auto intFiller = reinterpret_cast<const int*> (filler);
+-
+- while (width > 8 && (((pointer_sized_int) dest) & 7) != 0)
+- {
+- dest->set (colour);
+- ++dest;
+- --width;
+- }
+-
+- while (width > 4)
+- {
+- auto d = reinterpret_cast<int*> (dest);
+- *d++ = intFiller[0];
+- *d++ = intFiller[1];
+- *d++ = intFiller[2];
+- dest = reinterpret_cast<PixelRGB*> (d);
+- width -= 4;
+- }
+- }
+-
+- while (--width >= 0)
+- {
+- dest->set (colour);
+- ++dest;
+- }
+- }
+- }
++ if ((size_t) destData.pixelStride == sizeof (*dest) && areRGBComponentsEqual)
++ memset ((void*) dest, colour.getRed(), (size_t) width * 3); // if all the component values are the same, we can cheat..
+ else
+- {
+- JUCE_PERFORM_PIXEL_OP_LOOP (set (colour))
+- }
++ JUCE_PERFORM_PIXEL_OP_LOOP (set (colour));
+ }
+
+ forcedinline void replaceLine (PixelAlpha* dest, const PixelARGB colour, int width) const noexcept