summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormickybart2017-05-08 14:48:06 -0400
committermickybart2017-05-08 14:48:10 -0400
commitf055ca416995c52c75c9045bcdc9575c0645c2b8 (patch)
tree73b5971521c2c6908c63c2942e897db674235a09
parenta2671fbd21ddf3d864e6c1f596c0e45394a6a19f (diff)
downloadaur-hybris-ready.tar.gz
version 0.2
remove dependency to hybris-device to be able to generate generic rootfs move qt5-wayland-compositor to qt5-wayland-hybris
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
-rw-r--r--hybris-ready.install5
3 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c8af0b7b6e8..80b0ea868cf7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,24 @@
pkgbase = hybris-ready
- pkgver = 0.1
+ pkgver = 0.2
pkgrel = 1
url = https://github.com/mickybart/
arch = armv7h
source = hybris-ready.install
source = gls-common::git+https://github.com/mickybart/gnulinux_support-common
source = bootanim::git+https://github.com/mickybart/hybris-ready-bootanim
- md5sums = 9c7d863fd54b8651fb016b40a11173fb
+ md5sums = 81c15ce7b501b7806057a92605757578
md5sums = SKIP
md5sums = SKIP
pkgname = hybris-ready
pkgdesc = hybris ready permit to fully support GNU/Linux and Android Hardware
install = hybris-ready.install
- depends = hybris-device
depends = hybris-usb
depends = libhybris
depends = libgl
depends = libwayland-egl
depends = inotify-tools
+ optdepends = hybris-device: required to support an android device
optdepends = hybris-ready-bootanim: required to display a pretty boot animation
pkgname = hybris-ready-bootanim
@@ -31,12 +31,13 @@ pkgname = hybris-ready-bootanim
pkgname = hybris-ready-qt5-qpa-meta
pkgdesc = Qt QPA Platform for hybris
depends = hybris-ready
+ depends = qt5-wayland-hybris
depends = qt5-qpa-hwcomposer-plugin
depends = qt5-qpa-surfaceflinger-plugin
pkgname = hybris-ready-plasma-support-meta
pkgdesc = plasma support for hybris system
depends = hybris-ready
- depends = qt5-wayland-compositor
+ depends = qt5-wayland-hybris
depends = kwin-hybris
diff --git a/PKGBUILD b/PKGBUILD
index d3ceaa285c61..2f60e95e1ead 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=hybris-ready
pkgname=('hybris-ready' 'hybris-ready-bootanim' 'hybris-ready-qt5-qpa-meta' 'hybris-ready-plasma-support-meta')
-pkgver=0.1
+pkgver=0.2
pkgrel=1
arch=('armv7h')
url="https://github.com/mickybart/"
@@ -11,7 +11,7 @@ makedepends=()
source=('hybris-ready.install'
'gls-common::git+https://github.com/mickybart/gnulinux_support-common'
'bootanim::git+https://github.com/mickybart/hybris-ready-bootanim')
-md5sums=('9c7d863fd54b8651fb016b40a11173fb'
+md5sums=('81c15ce7b501b7806057a92605757578'
'SKIP'
'SKIP')
@@ -22,10 +22,11 @@ build() {
package_hybris-ready() {
pkgdesc="hybris ready permit to fully support GNU/Linux and Android Hardware"
- depends=('hybris-device' 'hybris-usb'
+ depends=('hybris-usb'
'libhybris' 'libgl' 'libwayland-egl'
'inotify-tools')
- optdepends=('hybris-ready-bootanim: required to display a pretty boot animation')
+ optdepends=('hybris-device: required to support an android device'
+ 'hybris-ready-bootanim: required to display a pretty boot animation')
install='hybris-ready.install'
cd ${srcdir}
@@ -67,14 +68,14 @@ package_hybris-ready-bootanim() {
package_hybris-ready-qt5-qpa-meta() {
pkgdesc="Qt QPA Platform for hybris"
- depends=('hybris-ready'
+ depends=('hybris-ready' 'qt5-wayland-hybris'
'qt5-qpa-hwcomposer-plugin' 'qt5-qpa-surfaceflinger-plugin')
}
package_hybris-ready-plasma-support-meta() {
pkgdesc="plasma support for hybris system"
- depends=('hybris-ready' 'qt5-wayland-compositor' 'kwin-hybris')
+ depends=('hybris-ready' 'qt5-wayland-hybris' 'kwin-hybris')
}
diff --git a/hybris-ready.install b/hybris-ready.install
index b8503c24c87c..2e11cb70b4aa 100644
--- a/hybris-ready.install
+++ b/hybris-ready.install
@@ -1,7 +1,8 @@
post_install(){
- printf '===> Android Hw\n'
- printf ' To start Android services, bootanim, ... Please execute: \n\n'
+ printf '===> Android Hardware: \n'
+ printf ' please install an hybris-device that matching your hardware\n'
+ printf '===> Android initialization : \n'
printf ' systemctl enable hybris-ready.service\n\n'
}