summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-02-21 21:29:19 -0600
committerLuis Martinez2021-02-21 21:29:19 -0600
commit887d9230c6ef8abdb55952b947bf70df35c6c844 (patch)
treead2a3fadab23ec34c605064274be5ec44bac3ddb
downloadaur-887d9230c6ef8abdb55952b947bf70df35c6c844.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD28
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee948d0e8bd6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = hydro-git
+ pkgdesc = Ultra-pure, lag-free Fish shell prompt with async git status
+ pkgver = r94.745837f
+ pkgrel = 1
+ url = https://github.com/jorgebucaran/hydro
+ arch = any
+ groups = fish-plugins
+ license = MIT
+ makedepends = git
+ depends = fish
+ provides = hydro
+ conflicts = hydro
+ source = hydro-git::git+https://github.com/jorgebucaran/hydro
+ md5sums = SKIP
+
+pkgname = hydro-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fdeea0d36d04
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Whitelist
+!PKGBUILD
+!.SRCINFO
+
+# Blacklist
+*
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0576fe4b7cf6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: lmartinez
+pkgname=hydro-git
+_pkgname=${pkgname%-git}
+pkgver=r94.745837f
+pkgrel=1
+pkgdesc="Ultra-pure, lag-free Fish shell prompt with async git status"
+arch=('any')
+url="https://github.com/jorgebucaran/hydro"
+license=('MIT')
+groups=('fish-plugins')
+depends=('fish')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm 644 conf.d/hydro.fish "$pkgdir/etc/fish/conf.d/hydro.fish"
+ find functions -type f -exec install -Dm 644 '{}' "$pkgdir/etc/fish/{}" \;
+ install -Dm 644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}