summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Serajnik2021-04-21 00:17:56 +0200
committerMichael Serajnik2021-04-21 00:17:56 +0200
commit0f6f803fcf4717e9ffb4fd4e487f4b084a985975 (patch)
tree009a343253cf53f4780cd6c6bec0e6b3d21c8bdf
parent477516c082af8c252b03e20b3941ac866a14b908 (diff)
downloadaur-0f6f803fcf4717e9ffb4fd4e487f4b084a985975.tar.gz
Update for v436
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--paths-in-opt.patch12
3 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11181159717e..01c26582b63a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
- pkgver = 435
+ pkgver = 436
pkgrel = 1
url = http://hydrusnetwork.github.io/hydrus/
install = hydrus.install
@@ -33,13 +33,13 @@ pkgbase = hydrus
conflicts = hydrus-docs
conflicts = hydrus-sources
options = !strip
- source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=a02c318cbb895c19d5a7bffc5a7fb9cab350b636
+ source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=eb3e3d7df77ebb669a6e4298ae22dde332b6be6a
source = paths-in-opt.patch
source = hydrus-client
source = hydrus-server
source = hydrus.desktop
sha256sums = SKIP
- sha256sums = 3cf240b1f3fc405b4e86030e45d54984bd425e37c6f48205a9419c2c0a94bcd2
+ sha256sums = 6dde03b452b842d089cfdffb4cf8554b4985934d664054b2bb71006694f923c6
sha256sums = d2cb826ce0dd1892ab95fc3b14dbe6bd312210f653d0aea31938eeb7e361fdc5
sha256sums = 463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806
sha256sums = 9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923
diff --git a/PKGBUILD b/PKGBUILD
index 7413f5f7230d..1973e655349e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ DOC_DIRS=(opt/hydrus/help)
pkgbase=hydrus
pkgname=(hydrus)
-pkgver=435
+pkgver=436
pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
@@ -24,13 +24,13 @@ optdepends=('ffmpeg: show duration and other information on video thumbnails'
'python-cloudscraper: bypass cloudflare "checking your browser" challenges'
'python-pyqt5-chart: display bandwidth usage charts'
'python-pyopenssl: to generate certificates for accessing client API and server via HTTPS')
-source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=a02c318cbb895c19d5a7bffc5a7fb9cab350b636"
+source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=eb3e3d7df77ebb669a6e4298ae22dde332b6be6a"
paths-in-opt.patch
hydrus-client
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
- '3cf240b1f3fc405b4e86030e45d54984bd425e37c6f48205a9419c2c0a94bcd2'
+ '6dde03b452b842d089cfdffb4cf8554b4985934d664054b2bb71006694f923c6'
'd2cb826ce0dd1892ab95fc3b14dbe6bd312210f653d0aea31938eeb7e361fdc5'
'463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806'
'9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923')
diff --git a/paths-in-opt.patch b/paths-in-opt.patch
index 8bb3275287e5..64ec3007c32a 100644
--- a/paths-in-opt.patch
+++ b/paths-in-opt.patch
@@ -1,8 +1,8 @@
diff --git a/hydrus/client/gui/ClientGUI.py b/hydrus/client/gui/ClientGUI.py
-index c73d9a8..717afce 100644
+index 418c93e..91e2683 100644
--- a/hydrus/client/gui/ClientGUI.py
+++ b/hydrus/client/gui/ClientGUI.py
-@@ -3903,7 +3903,7 @@ class FrameGUI( ClientGUITopLevelWindows.MainFrameThatResizes ):
+@@ -4133,7 +4133,7 @@ class FrameGUI( ClientGUITopLevelWindows.MainFrameThatResizes ):
python_executable = python_executable.replace( 'pythonw', 'python' )
@@ -12,7 +12,7 @@ index c73d9a8..717afce 100644
cmd = [ python_executable, server_script_path, db_param ]
diff --git a/hydrus/core/HydrusConstants.py b/hydrus/core/HydrusConstants.py
-index a9eef8d..ca32f46 100644
+index db6a88b..49e5fdb 100644
--- a/hydrus/core/HydrusConstants.py
+++ b/hydrus/core/HydrusConstants.py
@@ -5,33 +5,9 @@ import typing
@@ -50,9 +50,9 @@ index a9eef8d..ca32f46 100644
+HYDRUS_MODULE_DIR = '/opt/hydrus/hydrus'
+BASE_DIR = os.path.expanduser("~/.local/share/hydrus")
- PLATFORM_WINDOWS = sys.platform == 'win32'
- PLATFORM_MACOS = sys.platform == 'darwin'
-@@ -41,32 +17,16 @@ PLATFORM_HAIKU = sys.platform == 'haiku1'
+ muh_platform = sys.platform.lower()
+
+@@ -43,32 +19,16 @@ PLATFORM_HAIKU = muh_platform == 'haiku1'
RUNNING_FROM_SOURCE = sys.argv[0].endswith( '.py' ) or sys.argv[0].endswith( '.pyw' )
RUNNING_FROM_MACOS_APP = os.path.exists( os.path.join( BASE_DIR, 'running_from_app' ) )