summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2017-01-24 18:38:49 +0000
committerScore_Under2017-01-24 18:38:49 +0000
commit142e20f98d97545128d0f072c7dbddd26b145c2c (patch)
tree368a505c43538c5fa888850245cc9b2853dbb6e8
parent1a3bd5c99e5fab6eed164eb4102d073b11330335 (diff)
downloadaur-142e20f98d97545128d0f072c7dbddd26b145c2c.tar.gz
Update for v241
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--paths-in-opt.patch21
3 files changed, 15 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40dff634e6b4..549a72e510a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Jan 13 03:26:25 UTC 2017
+# Tue Jan 24 18:37:28 UTC 2017
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
- pkgver = 240
+ pkgver = 241
pkgrel = 1
url = http://hydrusnetwork.github.io/hydrus/
install = hydrus.install
@@ -34,13 +34,13 @@ pkgbase = hydrus
conflicts = hydrus-docs
conflicts = hydrus-sources
options = !strip
- source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=643586ce0473f48b5437c3bdf62efc6178a70f0b
+ source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=e24ade0548970cb0a340e64beed2892c2b6c4265
source = paths-in-opt.patch
source = hydrus-client
source = hydrus-server
source = hydrus.desktop
sha256sums = SKIP
- sha256sums = 7ab3687dbf0ffa5108acd2c5f01f0c50b0e04a55a1117d0bb56e55e02ac08bce
+ sha256sums = 495605cba87d031cfb864ecb593fd9d75085dc13685bfbb7a077fd6367d4198d
sha256sums = b2bf66b1068969e9598742d5c128cb04fd609512b0cff0ad5e25ecb6cdd35678
sha256sums = 5fd3eb69bb5f9a0b88d7c1b25abdee42aa2b2fc5e1690635f60ed1f47848c46b
sha256sums = 9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923
diff --git a/PKGBUILD b/PKGBUILD
index e866e2945259..00bbd1ca6723 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ DOC_DIRS=(opt/hydrus/help)
pkgbase=hydrus
pkgname=(hydrus)
-pkgver=240
+pkgver=241
pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
@@ -20,13 +20,13 @@ makedepends=(git)
optdepends=('ffmpeg: show duration and other information on video thumbnails'
'miniupnpc: automatic port forwarding'
'desktop-file-utils: to add Hydrus to your desktop environment menus')
-source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=643586ce0473f48b5437c3bdf62efc6178a70f0b"
+source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=e24ade0548970cb0a340e64beed2892c2b6c4265"
paths-in-opt.patch
hydrus-client
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
- '7ab3687dbf0ffa5108acd2c5f01f0c50b0e04a55a1117d0bb56e55e02ac08bce'
+ '495605cba87d031cfb864ecb593fd9d75085dc13685bfbb7a077fd6367d4198d'
'b2bf66b1068969e9598742d5c128cb04fd609512b0cff0ad5e25ecb6cdd35678'
'5fd3eb69bb5f9a0b88d7c1b25abdee42aa2b2fc5e1690635f60ed1f47848c46b'
'9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923')
diff --git a/paths-in-opt.patch b/paths-in-opt.patch
index facd38a72da9..c2237773cf08 100644
--- a/paths-in-opt.patch
+++ b/paths-in-opt.patch
@@ -1,17 +1,8 @@
diff --git a/include/ClientGUI.py b/include/ClientGUI.py
-index 3db6a1a..4a310f2 100755
+index db5a7e7..b12df2c 100755
--- a/include/ClientGUI.py
+++ b/include/ClientGUI.py
-@@ -219,7 +219,7 @@ class FrameGUI( ClientGUITopLevelWindows.FrameThatResizes ):
-
- aboutinfo.SetDescription( description )
-
-- with open( os.path.join( HC.BASE_DIR, 'license.txt' ), 'rb' ) as f: license = f.read()
-+ with open( '/usr/share/licenses/hydrus/license.txt', 'rb' ) as f: license = f.read()
-
- aboutinfo.SetLicense( license )
-
-@@ -378,7 +378,7 @@ class FrameGUI( ClientGUITopLevelWindows.FrameThatResizes ):
+@@ -383,7 +383,7 @@ class FrameGUI( ClientGUITopLevelWindows.FrameThatResizes ):
python_executable = python_executable.replace( 'pythonw', 'python' )
@@ -21,10 +12,10 @@ index 3db6a1a..4a310f2 100755
time_waited = 0
diff --git a/include/HydrusConstants.py b/include/HydrusConstants.py
-index 3f5f659..8807427 100755
+index 2cbc4b0..13038df 100755
--- a/include/HydrusConstants.py
+++ b/include/HydrusConstants.py
-@@ -3,27 +3,12 @@ import sys
+@@ -3,30 +3,15 @@ import sys
# dirs
@@ -56,5 +47,9 @@ index 3f5f659..8807427 100755
+INCLUDE_DIR = "/opt/hydrus/include"
+STATIC_DIR = "/opt/hydrus/static"
+ DEFAULT_DB_DIR = os.path.join( BASE_DIR, 'db' )
+-LICENSE_PATH = os.path.join( BASE_DIR, 'license.txt' )
++LICENSE_PATH = "/usr/share/licenses/hydrus/license.txt"
+
#