summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorimtbl2020-07-15 23:07:49 +0200
committerimtbl2020-07-15 23:07:49 +0200
commit877c1a7e8a73ede99b546a90880a47663845a731 (patch)
treec51f4080ea0751f41b95aa0e37f96995cd3fc844
parentc9e89ff477689f3f5702dac76fd0d2ac0af811c6 (diff)
downloadaur-877c1a7e8a73ede99b546a90880a47663845a731.tar.gz
Update for v404
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--paths-in-opt.patch12
3 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 499736860f20..88755ef9a68c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
- pkgver = 403
+ pkgver = 404
pkgrel = 1
url = http://hydrusnetwork.github.io/hydrus/
install = hydrus.install
@@ -34,13 +34,13 @@ pkgbase = hydrus
conflicts = hydrus-docs
conflicts = hydrus-sources
options = !strip
- source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=572e72ef76ae16c30580670e7620abdef804da31
+ source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=5fae633bcaeaa1850aa15c14c083e73abaa988d3
source = paths-in-opt.patch
source = hydrus-client
source = hydrus-server
source = hydrus.desktop
sha256sums = SKIP
- sha256sums = 62958435b7d7040abfa38547887bdc8c354ead15b26285e84ded515ac04068a1
+ sha256sums = c3a171448f6904434d720a394c11ff405a960f17079a7ae2c4ef6e0395198ee0
sha256sums = 7b0dbc6f38f9aaff409e435ba807199575166976b52715d6b54418f89dbde634
sha256sums = 463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806
sha256sums = 9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923
diff --git a/PKGBUILD b/PKGBUILD
index 8af0c5b3ce02..753fe19d0575 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ DOC_DIRS=(opt/hydrus/help)
pkgbase=hydrus
pkgname=(hydrus)
-pkgver=403
+pkgver=404
pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
@@ -23,13 +23,13 @@ optdepends=('ffmpeg: show duration and other information on video thumbnails'
'desktop-file-utils: to add Hydrus to your desktop environment menus'
'python-cloudscraper: bypass cloudflare "checking your browser" challenges'
)
-source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=572e72ef76ae16c30580670e7620abdef804da31"
+source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=5fae633bcaeaa1850aa15c14c083e73abaa988d3"
paths-in-opt.patch
hydrus-client
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
- '62958435b7d7040abfa38547887bdc8c354ead15b26285e84ded515ac04068a1'
+ 'c3a171448f6904434d720a394c11ff405a960f17079a7ae2c4ef6e0395198ee0'
'7b0dbc6f38f9aaff409e435ba807199575166976b52715d6b54418f89dbde634'
'463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806'
'9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923')
diff --git a/paths-in-opt.patch b/paths-in-opt.patch
index d9edc30266be..cf2736e86b32 100644
--- a/paths-in-opt.patch
+++ b/paths-in-opt.patch
@@ -1,8 +1,8 @@
diff --git a/hydrus/client/gui/ClientGUI.py b/hydrus/client/gui/ClientGUI.py
-index 2c3933e..c84a039 100644
+index db9fd6f..c925431 100644
--- a/hydrus/client/gui/ClientGUI.py
+++ b/hydrus/client/gui/ClientGUI.py
-@@ -772,7 +772,7 @@ class FrameGUI( ClientGUITopLevelWindows.MainFrameThatResizes ):
+@@ -792,7 +792,7 @@ class FrameGUI( ClientGUITopLevelWindows.MainFrameThatResizes ):
python_executable = python_executable.replace( 'pythonw', 'python' )
@@ -25,7 +25,7 @@ index 7de8ef2..1196c62 100644
DEFAULT_HYDRUS_STYLESHEET = ''
ORIGINAL_STYLE_NAME = None
diff --git a/hydrus/core/HydrusConstants.py b/hydrus/core/HydrusConstants.py
-index f14ed6e..4d7a20e 100644
+index 857715d..ff6a7ae 100644
--- a/hydrus/core/HydrusConstants.py
+++ b/hydrus/core/HydrusConstants.py
@@ -5,33 +5,9 @@ import typing
@@ -63,9 +63,9 @@ index f14ed6e..4d7a20e 100644
+HYDRUS_MODULE_DIR = '/opt/hydrus/hydrus'
+BASE_DIR = os.path.expanduser("~/.local/share/hydrus")
- PLATFORM_WINDOWS = False
- PLATFORM_MACOS = False
-@@ -44,23 +20,16 @@ elif sys.platform == 'linux': PLATFORM_LINUX = True
+ PLATFORM_WINDOWS = sys.platform == 'win32'
+ PLATFORM_MACOS = sys.platform == 'darwin'
+@@ -41,23 +17,16 @@ PLATFORM_HAIKU = sys.platform == 'haiku1'
RUNNING_FROM_SOURCE = sys.argv[0].endswith( '.py' ) or sys.argv[0].endswith( '.pyw' )
RUNNING_FROM_MACOS_APP = os.path.exists( os.path.join( BASE_DIR, 'running_from_app' ) )