summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2020-01-26 16:19:57 +0000
committerScore_Under2020-01-26 16:19:57 +0000
commit9e2fee121c4383249e1c4b94b22d491c8efc6a71 (patch)
tree9e408724e2f796d01e8666281d41f80ddce1afcf
parenta9e0a649c25eca701a16928f9d8c9daf986bc90c (diff)
downloadaur-9e2fee121c4383249e1c4b94b22d491c8efc6a71.tar.gz
Update for v381
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--paths-in-opt.patch13
3 files changed, 16 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 111e48ae456d..f4cabb273f2b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
- pkgver = 380
- pkgrel = 2
+ pkgver = 381
+ pkgrel = 1
url = http://hydrusnetwork.github.io/hydrus/
install = hydrus.install
arch = any
@@ -33,13 +33,13 @@ pkgbase = hydrus
conflicts = hydrus-docs
conflicts = hydrus-sources
options = !strip
- source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=70671ee703976f4f14c795b5687fb6e197c1cbea
+ source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=3d3c2533ba9f46661698ea108adb385e5e9eaae6
source = paths-in-opt.patch
source = hydrus-client
source = hydrus-server
source = hydrus.desktop
sha256sums = SKIP
- sha256sums = 5cd4414cbf226eddc6319216a6def95e73c148f37746effaae983a4c690b71a2
+ sha256sums = e6c77ba667604cfb2e7d9959e79d3ad05c976dcc6297f25a8fcad730a63d2f11
sha256sums = 7b0dbc6f38f9aaff409e435ba807199575166976b52715d6b54418f89dbde634
sha256sums = 463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806
sha256sums = 9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923
diff --git a/PKGBUILD b/PKGBUILD
index c944ddc60ace..792683680326 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@ DOC_DIRS=(opt/hydrus/help)
pkgbase=hydrus
pkgname=(hydrus)
-pkgver=380
-pkgrel=2
+pkgver=381
+pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
license=(WTFPL)
@@ -22,13 +22,13 @@ optdepends=('ffmpeg: show duration and other information on video thumbnails'
'miniupnpc: automatic port forwarding'
'desktop-file-utils: to add Hydrus to your desktop environment menus'
)
-source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=70671ee703976f4f14c795b5687fb6e197c1cbea"
+source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=3d3c2533ba9f46661698ea108adb385e5e9eaae6"
paths-in-opt.patch
hydrus-client
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
- '5cd4414cbf226eddc6319216a6def95e73c148f37746effaae983a4c690b71a2'
+ 'e6c77ba667604cfb2e7d9959e79d3ad05c976dcc6297f25a8fcad730a63d2f11'
'7b0dbc6f38f9aaff409e435ba807199575166976b52715d6b54418f89dbde634'
'463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806'
'9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923')
diff --git a/paths-in-opt.patch b/paths-in-opt.patch
index 2e6183008913..8b0054631bf7 100644
--- a/paths-in-opt.patch
+++ b/paths-in-opt.patch
@@ -1,8 +1,8 @@
diff --git a/include/ClientGUI.py b/include/ClientGUI.py
-index 479efc1..86cbd71 100755
+index b6913b2..e23ef1b 100755
--- a/include/ClientGUI.py
+++ b/include/ClientGUI.py
-@@ -598,7 +598,7 @@ class FrameGUI( ClientGUITopLevelWindows.MainFrameThatResizes ):
+@@ -738,7 +738,7 @@ class FrameGUI( ClientGUITopLevelWindows.MainFrameThatResizes ):
python_executable = python_executable.replace( 'pythonw', 'python' )
@@ -12,10 +12,10 @@ index 479efc1..86cbd71 100755
cmd = [ python_executable, server_script_path, db_param ]
diff --git a/include/HydrusConstants.py b/include/HydrusConstants.py
-index 9ec3402..0ea9266 100755
+index 3969396..bd6651a 100755
--- a/include/HydrusConstants.py
+++ b/include/HydrusConstants.py
-@@ -2,30 +2,9 @@ import os
+@@ -2,33 +2,9 @@ import os
import sys
# dirs
@@ -36,6 +36,9 @@ index 9ec3402..0ea9266 100755
-
-else:
-
+- # maybe this is better?
+- # os.path.dirname( __file__ )
+-
- RUNNING_FROM_FROZEN_BUILD = False
-
- BASE_DIR = sys.path[0]
@@ -48,7 +51,7 @@ index 9ec3402..0ea9266 100755
PLATFORM_WINDOWS = False
PLATFORM_MACOS = False
-@@ -38,23 +17,16 @@ elif sys.platform == 'linux': PLATFORM_LINUX = True
+@@ -41,23 +17,16 @@ elif sys.platform == 'linux': PLATFORM_LINUX = True
RUNNING_FROM_SOURCE = sys.argv[0].endswith( '.py' ) or sys.argv[0].endswith( '.pyw' )
RUNNING_FROM_MACOS_APP = os.path.exists( os.path.join( BASE_DIR, 'running_from_app' ) )