summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2022-03-15 19:19:48 +0000
committerScore_Under2022-03-15 19:24:53 +0000
commit7c08103084a5c8e675b3e8be5bca3d2d519571a7 (patch)
tree8a16149c387a6f196e61ae3df5dd70938005e1cd
parent8df31477af4199805c11703c5dc842a40c4e24ed (diff)
downloadaur-7c08103084a5c8e675b3e8be5bca3d2d519571a7.tar.gz
Format a little more like non-git package
-rw-r--r--PKGBUILD59
1 files changed, 30 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f0fc35a7684b..f2173bc913c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,41 @@
# Previous maintainer: Michael Serajnik <m at mser dot at>
# Maintainer: Score_Under <seejay 11@gmail com>
options=(!strip) # Don't strip libs because there aren't any
-DOC_DIRS=("opt/hydrus/help")
+DOC_DIRS=(opt/hydrus/help)
+
pkgname=hydrus-git
_pkgname=hydrus
pkgver=459.3.r0.g0dfba5a8
pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
-arch=("any")
-license=("WTFPL")
-install="hydrus.install"
-provides=("hydrus")
-conflicts=("hydrus" "hydrus-docs" "hydrus-sources")
-url="http://hydrusnetwork.github.io/hydrus/"
-depends=("python" "python-opencv" "python-beautifulsoup4" "python-yaml"
- "python-lz4>=0.10.1" "python-numpy" "python-twisted" "python-pillow"
- "python-pysocks" "python-psutil" "python-send2trash" "python-html5lib"
- "python-requests" "python-qtpy" "emoji-font" "python-mpv"
- "python-service-identity" "qt5-python-bindings" "fmt" "pyside2")
-makedepends=("git" "mkdocs" "mkdocs-material")
-optdepends=("ffmpeg: show duration and other information on video thumbnails"
- "miniupnpc: automatic port forwarding"
- "desktop-file-utils: to add Hydrus to your desktop environment menus"
- "python-cloudscraper: bypass cloudflare \"checking your browser\" challenges"
- "python-pyqt5-chart: display bandwidth usage charts"
- "python-pyopenssl: to generate certificates for accessing client API and server via HTTPS")
+arch=(any)
+license=(WTFPL)
+install=hydrus.install
+provides=(hydrus)
+conflicts=(hydrus hydrus-docs hydrus-sources)
+url=http://hydrusnetwork.github.io/hydrus/
+depends=(python python-opencv python-beautifulsoup4 python-yaml
+ 'python-lz4>=0.10.1' python-numpy python-twisted python-pillow
+ python-pysocks python-psutil python-send2trash python-html5lib
+ python-requests python-qtpy emoji-font python-mpv
+ python-service-identity qt5-python-bindings fmt pyside2)
+makedepends=(git mkdocs mkdocs-material)
+optdepends=('ffmpeg: show duration and other information on video thumbnails'
+ 'miniupnpc: automatic port forwarding'
+ 'desktop-file-utils: to add Hydrus to your desktop environment menus'
+ 'python-cloudscraper: bypass cloudflare "checking your browser" challenges'
+ 'python-pyqt5-chart: display bandwidth usage charts'
+ 'python-pyopenssl: to generate certificates for accessing client API and server via HTTPS')
source=("git+https://github.com/hydrusnetwork/${_pkgname}.git"
- "paths-in-opt.patch"
- "hydrus-client"
- "hydrus-server"
- "hydrus.desktop")
-sha256sums=("SKIP"
- "6dde03b452b842d089cfdffb4cf8554b4985934d664054b2bb71006694f923c6"
- "d2cb826ce0dd1892ab95fc3b14dbe6bd312210f653d0aea31938eeb7e361fdc5"
- "463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806"
- "9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923")
+ paths-in-opt.patch
+ hydrus-client
+ hydrus-server
+ hydrus.desktop)
+sha256sums=('SKIP'
+ '6dde03b452b842d089cfdffb4cf8554b4985934d664054b2bb71006694f923c6'
+ 'd2cb826ce0dd1892ab95fc3b14dbe6bd312210f653d0aea31938eeb7e361fdc5'
+ '463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806'
+ '9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923')
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -53,7 +54,7 @@ prepare() {
build() {
cd "${srcdir}/${_pkgname}"
- echo "Compiling .py files..."
+ msg 'Compiling .py files...'
python -OO -m compileall -fq .
msg 'Building documentation...'