summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2022-03-15 19:14:12 +0000
committerScore_Under2022-03-15 19:14:12 +0000
commit8df31477af4199805c11703c5dc842a40c4e24ed (patch)
tree0c3e4320c2073fdaced966c08cbbdcd522717122
parent340dcfba639bf57311878d8f9c1fa26d9f84c4fb (diff)
downloadaur-8df31477af4199805c11703c5dc842a40c4e24ed.tar.gz
Update dependencies and build process for new hydrus
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3466d11fa84a..f0fc35a7684b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,8 +17,8 @@ depends=("python" "python-opencv" "python-beautifulsoup4" "python-yaml"
"python-lz4>=0.10.1" "python-numpy" "python-twisted" "python-pillow"
"python-pysocks" "python-psutil" "python-send2trash" "python-html5lib"
"python-requests" "python-qtpy" "emoji-font" "python-mpv"
- "python-service-identity" "qt5-python-bindings")
-makedepends=("git")
+ "python-service-identity" "qt5-python-bindings" "fmt" "pyside2")
+makedepends=("git" "mkdocs" "mkdocs-material")
optdepends=("ffmpeg: show duration and other information on video thumbnails"
"miniupnpc: automatic port forwarding"
"desktop-file-utils: to add Hydrus to your desktop environment menus"
@@ -55,6 +55,9 @@ build() {
echo "Compiling .py files..."
python -OO -m compileall -fq .
+
+ msg 'Building documentation...'
+ mkdocs build -d help
}
package() {