summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsithlord482016-01-17 14:01:55 -0500
committersithlord482016-01-17 14:01:55 -0500
commit02df88d6590e75d11aa0b84e6b81e2c6355ee83e (patch)
treec50f0a2bc7f85ce4adc51b8fc25830db1d148eb7
downloadaur-02df88d6590e75d11aa0b84e6b81e2c6355ee83e.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
-rw-r--r--hyne-git.install5
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..14086be2ccd6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Jan 17 19:01:16 UTC 2016
+pkgbase = hyne-git
+ pkgdesc = Final Fantasy 8 Save Editor
+ pkgver = 1.9.0
+ pkgrel = 1
+ url = http://github.com/myst6re/hyne
+ install = hyne-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = qt5-base
+ depends = zlib
+ source = git://github.com/sithlord48/hyne.git
+ md5sums = SKIP
+
+pkgname = hyne-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23652cfc6b79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Chris Rizzitello <sithlord48@gmail.com>
+pkgname=hyne-git
+confilicts=('hyne')
+pkgver=1.9.0
+pkgrel=1
+pkgdesc="Final Fantasy 8 Save Editor"
+arch=('i686' 'x86_64')
+url=("http://github.com/myst6re/hyne")
+license=('GPL3')
+depends=('qt5-base' 'zlib') #Qt5)
+#optdepends=('otf-ipafont: font for displaying japanese')
+install=$pkgname.install
+source=("git://github.com/sithlord48/hyne.git")
+md5sums=(SKIP)
+
+pkgver() {
+ cd "hyne"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "hyne"
+ qmake-qt5 Hyne.pro #Qt5 Build
+ make
+}
+package(){
+ cd "hyne"
+ INSTALL_ROOT=$pkgdir make install
+ install -D -m644 debian/menu "$pkgdir"/usr/share/menu/hyne
+}
diff --git a/hyne-git.install b/hyne-git.install
new file mode 100644
index 000000000000..c13d3ad0f0ab
--- /dev/null
+++ b/hyne-git.install
@@ -0,0 +1,5 @@
+#!/bin/sh
+post_install() {
+ echo Inorder to display all fonts correctly please install a font that supports ;
+ echo japanse character for both kanja and shift-jis such as " otf-ipafont " ;
+}