summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Abbott2016-10-07 23:04:21 -0400
committerAaron Abbott2016-10-07 23:04:21 -0400
commit5b93508a9e1b39dbcff5f8c54744e3d105619fe8 (patch)
treea7efeb5502388971bc3f0b0d6a5472115843eed9
parent71550a8b511ae8ab761534bbdfd1fe3cb4ee7144 (diff)
downloadaur-5b93508a9e1b39dbcff5f8c54744e3d105619fe8.tar.gz
Applied @auk's patch to upgrade to v0.8.1
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD31
-rw-r--r--autohide-menu.patch12
3 files changed, 23 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c4f4110ec2fb..216e8a54f51a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
# Generated by mksrcinfo v8
-# Mon Sep 12 15:41:11 UTC 2016
-pkgbase = hyperterm
- pkgdesc = A terminal emulator built with JS/HTML/CSS on electron
- pkgver = 0.7.1
- pkgrel = 4
- url = https://hyperterm.org/
+# Sat Oct 8 03:04:02 UTC 2016
+pkgbase = hyper
+ pkgdesc = A terminal built on web technologies
+ pkgver = 0.8.1
+ pkgrel = 1
+ url = https://hyper.is/
arch = any
license = MIT
makedepends = npm
makedepends = python2
depends = nodejs
depends = electron
- source = https://github.com/zeit/hyperterm/archive/0.7.1.tar.gz
- source = autohide-menu.patch
- md5sums = f06827cbae82f13237cc20dfd0ee170d
- md5sums = f5ca4b1eed8199186edfed94dd137dbc
+ conflicts = hyperterm
+ replaces = hyperterm
+ source = https://github.com/zeit/hyper/archive/0.8.1.tar.gz
+ md5sums = bf5575c5bcf8cbedcdf4d7118128c2cd
-pkgname = hyperterm
+pkgname = hyper
diff --git a/PKGBUILD b/PKGBUILD
index 49c69c6cbff6..b4aafe6126de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Aaron Abbott <aabmass@gmail.com>
# Contributer: fleischie
-pkgname=hyperterm
-pkgver=0.7.1
-pkgrel=4
+pkgname=hyper
+pkgver=0.8.1
+pkgrel=1
epoch=
-pkgdesc="A terminal emulator built with JS/HTML/CSS on electron"
+pkgdesc="A terminal built on web technologies"
arch=('any')
-url="https://hyperterm.org/"
+url="https://hyper.is/"
license=('MIT')
groups=()
depends=('nodejs' 'electron')
@@ -14,33 +14,26 @@ makedepends=('npm' 'python2')
checkdepends=()
optdepends=()
provides=()
-conflicts=()
-replaces=()
+conflicts=('hyperterm')
+replaces=('hyperterm')
backup=()
options=()
install=
changelog=
source=(
"https://github.com/zeit/$pkgname/archive/${pkgver}.tar.gz"
- "autohide-menu.patch"
)
noextract=()
-md5sums=('f06827cbae82f13237cc20dfd0ee170d'
- 'f5ca4b1eed8199186edfed94dd137dbc')
+md5sums=('bf5575c5bcf8cbedcdf4d7118128c2cd')
validpgpkeys=()
prepare() {
- cd "$pkgname-$pkgver"
-
- # this patch temporarily "fixes" https://github.com/zeit/hyperterm/issues/158
- # thanks @fleischie
- patch -p1 < ../autohide-menu.patch
-
+ cd "$pkgname-$pkgver"
npm install
}
build() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
npm run pack
}
@@ -51,11 +44,11 @@ package() {
_libinstall="${pkgdir}${_appdir}"
mkdir -p "$pkgdir/usr/bin" "$_libinstall"
- cp -R dist/linux/* "$_libinstall"
+ cp -R dist/linux-unpacked/* "$_libinstall"
# link the binary to /usr/bin
cd $pkgdir/usr/bin
- ln -s "../lib/$pkgname/HyperTerm" HyperTerm
+ ln -s "../lib/$pkgname/Hyper" Hyper
# # TODO: remove included electron libs and use the system ones by symlink
# cd "$_libinstall"
diff --git a/autohide-menu.patch b/autohide-menu.patch
deleted file mode 100644
index dd48670ae9dd..000000000000
--- a/autohide-menu.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -aur package.pristine/app/index.js package.new/app/index.js
---- package.pristine/app/index.js 2016-07-26 20:35:30.000000000 +0200
-+++ package.new/app/index.js 2016-09-12 15:23:14.737276532 +0200
-@@ -56,7 +56,8 @@
- icon: resolve(__dirname, 'static/icon.png'),
- // we only want to show when the prompt
- // is ready for user input
-- show: process.env.HYPERTERM_DEBUG || isDev
-+ show: process.env.HYPERTERM_DEBUG || isDev,
-+ autoHideMenuBar: true
- };
- const browserOptions = plugins.getDecoratedBrowserOptions(browserDefaults);