summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Abbott2016-11-15 23:31:31 -0500
committerAaron Abbott2016-11-15 23:31:31 -0500
commit6189bb6e08cac69ecc90e1500bef0dbbecedd511 (patch)
tree47b838d4b30be3c2b7a62715f1636ce73965c67b
parent0aa597563127489d6faa63ff1c1200c9bedcbfad (diff)
downloadaur-6189bb6e08cac69ecc90e1500bef0dbbecedd511.tar.gz
Fixed Hyper->hyper rename and webpack babel bug
-rw-r--r--.SRCINFO8
-rw-r--r--Hyper.desktop2
-rw-r--r--PKGBUILD9
-rw-r--r--babel-loader.patch12
4 files changed, 24 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a90ab055700..47bb77d87059 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Oct 19 04:19:13 UTC 2016
+# Wed Nov 16 04:30:58 UTC 2016
pkgbase = hyper
pkgdesc = A terminal built on web technologies
pkgver = 0.8.3
- pkgrel = 1
+ pkgrel = 2
url = https://hyper.is/
arch = any
license = MIT
@@ -16,9 +16,11 @@ pkgbase = hyper
source = https://github.com/zeit/hyper/archive/0.8.3.tar.gz
source = https://raw.githubusercontent.com/zeit/art/master/hyper/mark/Hyper-Mark-120%403x.png
source = Hyper.desktop
+ source = babel-loader.patch
md5sums = 5f894b0af6cef3c91da19f425b9c6d32
md5sums = f3481e14cba331160339b3b5ab78872b
- md5sums = 8ccbe8d3e3b6cdc9bc5fd4301d368d5f
+ md5sums = 74cb7ba38e37332aa8300e4b6ba9c61c
+ md5sums = aa0867111699f0e903779506ad03a373
pkgname = hyper
diff --git a/Hyper.desktop b/Hyper.desktop
index 756971a110cc..e07a4bdcd553 100644
--- a/Hyper.desktop
+++ b/Hyper.desktop
@@ -1,7 +1,7 @@
[Desktop Entry]
Name=Hyper
Comment=JS/HTML/CSS Terminal
-Exec=Hyper
+Exec=hyper
Icon=/usr/share/pixmaps/hyper.png
Terminal=false
Type=Application
diff --git a/PKGBUILD b/PKGBUILD
index b627fd6082ee..66dbe78b4c7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=hyper
pkgver=0.8.3
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="A terminal built on web technologies"
arch=('any')
@@ -27,15 +27,18 @@ source=(
"https://github.com/zeit/$pkgname/archive/${pkgver}.tar.gz"
"https://raw.githubusercontent.com/zeit/art/master/hyper/mark/Hyper-Mark-120%403x.png"
"Hyper.desktop"
+ "babel-loader.patch"
)
noextract=()
md5sums=('5f894b0af6cef3c91da19f425b9c6d32'
'f3481e14cba331160339b3b5ab78872b'
- '8ccbe8d3e3b6cdc9bc5fd4301d368d5f')
+ '74cb7ba38e37332aa8300e4b6ba9c61c'
+ 'aa0867111699f0e903779506ad03a373')
validpgpkeys=()
prepare() {
cd "$pkgname-$pkgver"
+ patch -p2 < $srcdir/babel-loader.patch
npm install
}
@@ -55,7 +58,7 @@ package() {
# link the binary to /usr/bin
cd $pkgdir/usr/bin
- ln -s "../lib/$pkgname/Hyper" Hyper
+ ln -s "../lib/$pkgname/hyper" hyper
# # TODO: remove included electron libs and use the system ones by symlink
# cd "$_libinstall"
diff --git a/babel-loader.patch b/babel-loader.patch
new file mode 100644
index 000000000000..773c3180d47e
--- /dev/null
+++ b/babel-loader.patch
@@ -0,0 +1,12 @@
+diff -Naur src/hyper-0.8.3/webpack.config.js src-patch/hyper-0.8.3/webpack.config.js
+--- src/hyper-0.8.3/webpack.config.js 2016-10-17 20:37:13.000000000 -0400
++++ src-patch/hyper-0.8.3/webpack.config.js 2016-11-15 23:18:56.614125855 -0500
+@@ -18,7 +18,7 @@
+ {
+ test: /\.(js|jsx)$/,
+ exclude: /node_modules/,
+- loader: 'babel'
++ loader: 'babel-loader'
+ },
+ {
+ test: /\.json/,