summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Abbott2016-12-12 23:56:40 -0500
committerAaron Abbott2016-12-12 23:58:30 -0500
commit76ffe22d15bd725791f6af7521c9ed3165e69df3 (patch)
tree37176c7ea81f5adefebbbae806f06943e8ed4a84
parent6189bb6e08cac69ecc90e1500bef0dbbecedd511 (diff)
downloadaur-76ffe22d15bd725791f6af7521c9ed3165e69df3.tar.gz
Updated to 1.0.0 removed babel patch
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
-rw-r--r--babel-loader.patch12
3 files changed, 23 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 47bb77d87059..12d9734611fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Nov 16 04:30:58 UTC 2016
+# Tue Dec 13 04:57:58 UTC 2016
pkgbase = hyper
pkgdesc = A terminal built on web technologies
- pkgver = 0.8.3
- pkgrel = 2
+ pkgver = 1.0.0
+ pkgrel = 1
url = https://hyper.is/
arch = any
license = MIT
@@ -13,14 +13,12 @@ pkgbase = hyper
depends = electron
conflicts = hyperterm
replaces = hyperterm
- source = https://github.com/zeit/hyper/archive/0.8.3.tar.gz
+ source = https://github.com/zeit/hyper/archive/1.0.0.tar.gz
source = https://raw.githubusercontent.com/zeit/art/master/hyper/mark/Hyper-Mark-120%403x.png
source = Hyper.desktop
- source = babel-loader.patch
- md5sums = 5f894b0af6cef3c91da19f425b9c6d32
+ md5sums = 9b6831e25f6e521dcf95edaeded9d9d8
md5sums = f3481e14cba331160339b3b5ab78872b
md5sums = 74cb7ba38e37332aa8300e4b6ba9c61c
- md5sums = aa0867111699f0e903779506ad03a373
pkgname = hyper
diff --git a/PKGBUILD b/PKGBUILD
index 66dbe78b4c7d..23b08d4faeeb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributer: auk
pkgname=hyper
-pkgver=0.8.3
-pkgrel=2
+pkgver=1.0.0
+pkgrel=1
epoch=
pkgdesc="A terminal built on web technologies"
arch=('any')
@@ -27,23 +27,33 @@ source=(
"https://github.com/zeit/$pkgname/archive/${pkgver}.tar.gz"
"https://raw.githubusercontent.com/zeit/art/master/hyper/mark/Hyper-Mark-120%403x.png"
"Hyper.desktop"
- "babel-loader.patch"
)
noextract=()
-md5sums=('5f894b0af6cef3c91da19f425b9c6d32'
+md5sums=('9b6831e25f6e521dcf95edaeded9d9d8'
'f3481e14cba331160339b3b5ab78872b'
- '74cb7ba38e37332aa8300e4b6ba9c61c'
- 'aa0867111699f0e903779506ad03a373')
+ '74cb7ba38e37332aa8300e4b6ba9c61c')
validpgpkeys=()
+## This function uses yarn if it installed, otherwise npm as the default.
+npm_or_yarn() {
+ if hash yarn 2>/dev/null; then
+ yarn "$@"
+ else
+ npm "$@"
+ fi
+}
+
prepare() {
cd "$pkgname-$pkgver"
- patch -p2 < $srcdir/babel-loader.patch
- npm install
+
+ # calls yarn if available, else npm
+ npm_or_yarn install
}
build() {
cd "$pkgname-$pkgver"
+
+ # can't use npm_or_yarn b/c yarn rebuild doesn't work
npm run pack
}
diff --git a/babel-loader.patch b/babel-loader.patch
deleted file mode 100644
index 773c3180d47e..000000000000
--- a/babel-loader.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur src/hyper-0.8.3/webpack.config.js src-patch/hyper-0.8.3/webpack.config.js
---- src/hyper-0.8.3/webpack.config.js 2016-10-17 20:37:13.000000000 -0400
-+++ src-patch/hyper-0.8.3/webpack.config.js 2016-11-15 23:18:56.614125855 -0500
-@@ -18,7 +18,7 @@
- {
- test: /\.(js|jsx)$/,
- exclude: /node_modules/,
-- loader: 'babel'
-+ loader: 'babel-loader'
- },
- {
- test: /\.json/,