summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Abbott2017-05-12 20:11:40 -0400
committerAaron Abbott2017-05-12 20:11:40 -0400
commitc3fe2f13490b8a82c96758198da2b3b592fcdc82 (patch)
treeb0f7db5febbe8f13ab97a785e5d582f69b17e11d
parent8f5c98adcf5883923398fa0c4ebdf322bad60776 (diff)
downloadaur-c3fe2f13490b8a82c96758198da2b3b592fcdc82.tar.gz
Bump to 1.3.3 and fix build bug
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
2 files changed, 18 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 55e0c47da82..eae71076c7b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu May 11 22:38:38 UTC 2017
+# Sat May 13 00:11:01 UTC 2017
pkgbase = hyper
pkgdesc = A terminal built on web technologies
- pkgver = 1.3.2
+ pkgver = 1.3.3
pkgrel = 1
url = https://hyper.is/
arch = any
@@ -15,10 +15,10 @@ pkgbase = hyper
depends = gconf
conflicts = hyperterm
replaces = hyperterm
- source = https://github.com/zeit/hyper/archive/1.3.2.tar.gz
+ source = https://github.com/zeit/hyper/archive/1.3.3.tar.gz
source = https://raw.githubusercontent.com/zeit/art/master/hyper/mark/Hyper-Mark-120@3x.png
source = Hyper.desktop
- md5sums = 385c0d909f82f492aeaa158a0164e9ef
+ md5sums = 53a85a4e9b8950226df5c192a31be242
md5sums = f3481e14cba331160339b3b5ab78872b
md5sums = 74cb7ba38e37332aa8300e4b6ba9c61c
diff --git a/PKGBUILD b/PKGBUILD
index 5e093b10af5..f4edce1decb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributer: auk
pkgname=hyper
-pkgver=1.3.2
+pkgver=1.3.3
pkgrel=1
epoch=
pkgdesc="A terminal built on web technologies"
@@ -29,7 +29,7 @@ source=(
"Hyper.desktop"
)
noextract=()
-md5sums=('385c0d909f82f492aeaa158a0164e9ef'
+md5sums=('53a85a4e9b8950226df5c192a31be242'
'f3481e14cba331160339b3b5ab78872b'
'74cb7ba38e37332aa8300e4b6ba9c61c')
validpgpkeys=()
@@ -44,17 +44,23 @@ prepare() {
build() {
cd "$pkgname-$pkgver"
- # node modules path => "nmp"
- nmp="./node_modules/.bin"
-
# This build command is the same as the one defined in package.json via
- # npm run dist except that it doesn't build for debian, rpm, etc.
+ # npm run dist except that it doesn't build for debian, rpm, etc. and
+ # doesn't require some other dependencies
+
+ # add node_modules binaries to PATH
+ oldpath=$PATH
+ PATH=$(pwd)/node_modules/.bin:$PATH
+
npm run build &&
- $nmp/cross-env BABEL_ENV=production babel \
+ cross-env BABEL_ENV=production babel \
--out-file app/dist/bundle.js \
--no-comments \
--minified app/dist/bundle.js &&
- $nmp/build --linux --dir
+ command build --linux --dir # need to use command because the
+ # function name is build
+
+ PATH=$oldpath
}
package() {