summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Abbott2016-07-26 21:05:52 -0400
committerAaron Abbott2016-07-26 21:05:52 -0400
commitdeccf713a28cd74493e7d96bfe5178c4e97a1b40 (patch)
tree06048f5b2b3caa679f443049373df64a5883f6b0
parentae78ab47055f148cda9f95db2ce8e948f4a23a91 (diff)
downloadaur-deccf713a28cd74493e7d96bfe5178c4e97a1b40.tar.gz
Updated to version 0.7.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD40
2 files changed, 10 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 547aa6cd3a16..ef0181f1eed3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Jul 22 05:41:09 UTC 2016
+# Wed Jul 27 01:05:44 UTC 2016
pkgbase = hyperterm
pkgdesc = A terminal emulator built with JS/HTML/CSS on electron
- pkgver = 0.6.0
+ pkgver = 0.7.1
pkgrel = 1
url = https://hyperterm.org/
arch = any
@@ -10,8 +10,8 @@ pkgbase = hyperterm
makedepends = npm
depends = nodejs
depends = electron
- source = https://github.com/zeit/hyperterm/archive/0.6.0.tar.gz
- md5sums = 8e298b3a10494d4e9e7ffd82780f0aab
+ source = https://github.com/zeit/hyperterm/archive/v0.7.1.tar.gz
+ md5sums = f06827cbae82f13237cc20dfd0ee170d
pkgname = hyperterm
diff --git a/PKGBUILD b/PKGBUILD
index 479e1f99d16b..bed47d678884 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Aaron Abbott <aabmass@gmail.com>
pkgname=hyperterm
-pkgver=0.6.0
+pkgver=0.7.1
pkgrel=1
epoch=
pkgdesc="A terminal emulator built with JS/HTML/CSS on electron"
@@ -19,56 +19,29 @@ backup=()
options=()
install=
changelog=
-source=("https://github.com/zeit/$pkgname/archive/$pkgver.tar.gz")
+source=("https://github.com/zeit/$pkgname/archive/v${pkgver}.tar.gz")
noextract=()
-md5sums=('8e298b3a10494d4e9e7ffd82780f0aab')
+md5sums=('f06827cbae82f13237cc20dfd0ee170d')
validpgpkeys=()
prepare() {
cd "$pkgname-$pkgver"
-
- mkdir -p build
- ./scripts/install.sh
- cd app
npm install
}
build() {
- cd "$pkgname-$pkgver/app"
-
- npm run build
-}
-
-check() {
cd "$pkgname-$pkgver"
- npm run lint
- cd app
- npm run lint
+ npm run pack
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
_appdir="/usr/lib/$pkgname"
_libinstall="${pkgdir}${_appdir}"
- VERSION=`node -e 'process.stdout.write(require("./package").version)'`
-
- cp -r app/assets build/
- cp app/index.html build/
- cp -r app/dist build/
- mkdir -p dist
- ./node_modules/electron-packager/cli.js ./ \
- --platform=linux \
- --arch=x64 \
- --out=dist \
- --app-version="$VERSION" \
- --icon=static/icon.png \
- --prune \
- --ignore=app/
-
mkdir -p "$pkgdir/usr/bin" "$_libinstall"
- cp -R dist/HyperTerm-linux-x64/* "$_libinstall"
+ cp -R dist/linux/* "$_libinstall"
# link the binary to /usr/bin
cd $pkgdir/usr/bin
@@ -78,5 +51,4 @@ package() {
# cd "$_libinstall"
# rm libnode.so libffmpeg.so
# ln -s /usr/share/electron/lib{node,ffmpeg}.so .
-
}