summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Abbott2017-01-18 23:53:53 -0500
committerAaron Abbott2017-01-18 23:53:53 -0500
commitdf402f98be81e22f1a22e46a58ef9c08b81ecb4f (patch)
treeac0c8869c8899b2617bef7b9232a9592903c19b3
parent27be56c3031945cf075d9aa0a3feac68f171df2f (diff)
downloadaur-df402f98be81e22f1a22e46a58ef9c08b81ecb4f.tar.gz
Use '@' in url instead of %40
Also uses hack to install the right version of webpack before building. Builds correctly now.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24c2798e17e..19f22895d89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Jan 12 02:57:25 UTC 2017
+# Thu Jan 19 04:53:35 UTC 2017
pkgbase = hyper
pkgdesc = A terminal built on web technologies
pkgver = 1.1.0
- pkgrel = 2
+ pkgrel = 3
url = https://hyper.is/
arch = any
license = MIT
@@ -14,7 +14,7 @@ pkgbase = hyper
conflicts = hyperterm
replaces = hyperterm
source = https://github.com/zeit/hyper/archive/1.1.0.tar.gz
- source = https://raw.githubusercontent.com/zeit/art/master/hyper/mark/Hyper-Mark-120%403x.png
+ source = https://raw.githubusercontent.com/zeit/art/master/hyper/mark/Hyper-Mark-120@3x.png
source = Hyper.desktop
md5sums = d66c265ce750a96d994da6b33d561d53
md5sums = f3481e14cba331160339b3b5ab78872b
diff --git a/PKGBUILD b/PKGBUILD
index 4e189ce9893..d34eea9db09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=hyper
pkgver=1.1.0
-pkgrel=2
+pkgrel=3
epoch=
pkgdesc="A terminal built on web technologies"
arch=('any')
@@ -25,7 +25,7 @@ install=
changelog=
source=(
"https://github.com/zeit/$pkgname/archive/${pkgver}.tar.gz"
- "https://raw.githubusercontent.com/zeit/art/master/hyper/mark/Hyper-Mark-120%403x.png"
+ "https://raw.githubusercontent.com/zeit/art/master/hyper/mark/Hyper-Mark-120@3x.png"
"Hyper.desktop"
)
noextract=()
@@ -51,13 +51,21 @@ prepare() {
# for now use just npm since errors have been reported
npm install
+
+ # Also hacky but need to explicitly install webpack at the correct version
+ # or the app won't run. See https://github.com/zeit/hyper/issues/1418.
+ # Hopefully this can be removed asap
+ npm install webpack@2.2.0-rc.3
}
build() {
cd "$pkgname-$pkgver"
- # can't use npm_or_yarn b/c yarn rebuild doesn't work
- npm run pack
+ npm run build
+
+ # this is hacky, but otherwise the package.json dist rule tries to build
+ # for debian, rpm, etc.
+ ./node_modules/.bin/build --linux dir
}
package() {
@@ -79,5 +87,5 @@ package() {
# ln -s /usr/share/electron/lib{node,ffmpeg}.so .
install -Dm644 "$srcdir/Hyper.desktop" "$pkgdir/usr/share/applications/Hyper.desktop"
- install -Dm644 "$srcdir/Hyper-Mark-120%403x.png" "$pkgdir/usr/share/pixmaps/hyper.png"
+ install -Dm644 "$srcdir/Hyper-Mark-120@3x.png" "$pkgdir/usr/share/pixmaps/hyper.png"
}