summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Dowling2018-04-06 01:35:29 +1000
committerRyan Dowling2018-04-06 01:35:29 +1000
commit2a38d5243d03cdec900da3da0b36093325e4b9a6 (patch)
tree7ffa9abac385f89b5565ef2fd30d1e41b379218c
parent7e3258251c349eb962b3871fd5fbf499bc17fd32 (diff)
downloadaur-2a38d5243d03cdec900da3da0b36093325e4b9a6.tar.gz
fix: get package installing correctly (hopefully)
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 391c3b115ce3..15e7d2960cba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hyper-appimage
pkgdesc = A terminal built on web technologies
pkgver = 2.0.0.canary.15
- pkgrel = 13
+ pkgrel = 14
url = https://hyper.is
install = hyper-appimage.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 5a9e57e66f9a..c08fb85032f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=hyper-appimage
pkgver=2.0.0.canary.15
-pkgrel=13
+pkgrel=14
pkgdesc="A terminal built on web technologies"
arch=('x86_64')
url="https://hyper.is"
@@ -33,6 +33,9 @@ md5sums=(
)
prepare() {
+ # mark as executable so we can extract
+ chmod +x "${srcdir}/Hyper.AppImage"
+
# extract the AppImage
"./${srcdir}/Hyper.AppImage" --appimage-extract
}
@@ -40,7 +43,7 @@ prepare() {
package() {
# install the main files.
install -d "${pkgdir}/opt/${pkgname}"
- install "${srcdir}/squashfs-root/app/*" "${pkgdir}/opt/${pkgname}"
+ cp -a "${srcdir}/squashfs-root/app/." "${pkgdir}/opt/${pkgname}"
# make sure the main binary has the right permissions
chmod 0755 "${pkgdir}/opt/${pkgname}/hyper"
@@ -49,8 +52,10 @@ package() {
install -D "${srcdir}/Hyper.desktop" "${pkgdir}/usr/share/applications/Hyper.desktop"
# link the binary
- ln -s "${pkgdir}/opt/${pkgname}/hyper" "/usr/bin/hyper"
+ install -d "${pkgdir}/usr/bin"
+ ln -s "${pkgdir}/opt/${pkgname}/hyper" "${pkgdir}/usr/bin/hyper"
# install the icons
- install "${srcdir}/squashfs-root/usr/share/icons/hicolor/*" "${pkgdir}/usr/share/icons/hicolor"
+ install -d "${pkgdir}/usr/share/icons/hicolor"
+ cp -a "${srcdir}/squashfs-root/usr/share/icons/hicolor/." "${pkgdir}/usr/share/icons/hicolor"
}