summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Dowling2018-04-05 21:05:28 +1000
committerRyan Dowling2018-04-05 21:38:50 +1000
commit567c256e58012824b6a540f6abe6f6459b954b37 (patch)
tree19d0e86eab18aff4fbaa312181422add0a92fc81
downloadaur-567c256e58012824b6a540f6abe6f6459b954b37.tar.gz
feat: initial commit for testing
-rw-r--r--.SRCINFO12
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD50
-rw-r--r--README.md11
-rw-r--r--hyper-appimage.install13
5 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8b7fc0a25a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = hyper-appimage
+ pkgdesc = A terminal built on web technologies
+ pkgver = 2.0.0-canary.15
+ pkgrel = 1
+ url = https://hyper.is
+ install = hyper-appimage.install
+ arch = x86_64
+ license = MIT
+ conflicts = hyper
+ provides = hyper
+ source_x86_64 = https://github.com/zeit/hyper/releases/download/2.0.0-canary.15/hyper-2.0.0-canary.15-x86_64.AppImage
+pkgname = hyper-appimage
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..a79a2af0f48a
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2018 Ryan Dowling
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9348437267ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Ryan Dowling <ryan@ryandowling.me>
+
+pkgname=hyper-appimage
+pkgver=2.0.0-canary.15
+pkgrel=1
+pkgdesc="A terminal built on web technologies"
+arch=('x86_64')
+url="https://hyper.is"
+license=('MIT')
+conflicts=('hyper')
+provides=('hyper')
+depends=()
+noextract=('Hyper.AppImage')
+install=hyper-appimage.install
+options=()
+
+source_x86_64=(
+ "https://github.com/zeit/hyper/releases/download/${pkgver}/hyper-${pkgver}-x86_64.AppImage"
+ "https://raw.githubusercontent.com/zeit/art/master/hyper/mark/Hyper-Mark-120@3x.png"
+)
+
+md5sums_x86_64=(
+ '53e1b818d3e8f9ff647ab13e1549b55b',
+ 'f3481e14cba331160339b3b5ab78872b'
+)
+
+prepare() {
+ cd "${srcdir}"
+
+ mv "${srcdir}/hyper-${pkgver}-x86_64.AppImage" "${srcdir}/Hyper.AppImage"
+
+ mkdir -p usr/share/pixmaps
+ mkdir -p usr/share/applications
+ mkdir -p opt/appimages
+
+ # extract the hyper.desktop file out the AppImage file
+ 7z x "${srcdir}/Hyper.AppImage" hyper.desktop
+
+ # move the files to the correct places
+ mv "${srcdir}/Hyper-Mark-120@3x.png" usr/share/pixmaps
+ mv hyper.desktop usr/share/applications
+ mv Hyper.AppImage opt/appimages/
+}
+
+package() {
+ cd "${srcdir}"
+
+ cp -rp usr "${pkgdir}/usr"
+ cp -rp opt "${pkgdir}/opt"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..03be34a7ecad
--- /dev/null
+++ b/README.md
@@ -0,0 +1,11 @@
+# hyper-appimage
+
+Arch package for hyper based on the AppImage.
+
+Based on the existing [upwork-appimage](https://aur.archlinux.org/packages/upwork-appimage/).
+
+## Why?
+
+The `hyper` package from AUR installs NPM, Yarn, NodeJS and Electron just to install, which is not
+ideal for me as I want to control my own versions of those softwares and not have one package
+pollute that.
diff --git a/hyper-appimage.install b/hyper-appimage.install
new file mode 100644
index 000000000000..5d110998fdd6
--- /dev/null
+++ b/hyper-appimage.install
@@ -0,0 +1,13 @@
+post_install() {
+ xdg-icon-resource forceupdate
+ mkdir -p /opt/appimages
+ chmod 777 /opt/appimages/Hyper.AppImage
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ xdg-icon-resource forceupdate
+}