summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Dowling2018-04-06 02:49:33 +1000
committerRyan Dowling2018-04-06 03:05:37 +1000
commit91d2fbf30d19b94f4ca805c0970b8a64af490683 (patch)
tree0a889a8c4ef8a69d63c83cbca76541e2927393c3
parentf143569509650e81b508876a8035b329645c0bfe (diff)
downloadaur-91d2fbf30d19b94f4ca805c0970b8a64af490683.tar.gz
feat: initial commit
-rw-r--r--.SRCINFO36
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD52
-rw-r--r--README.md9
4 files changed, 75 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20bd43f61e06..caf29c13745b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,20 @@
pkgbase = hyper-bin
- pkgdesc = A hypervisor-agnostic Docker runtime
- pkgver = 0.5
+ pkgdesc = A terminal built on web technologies
+ pkgver = 2.0.0.canary.15
pkgrel = 1
- url = https://hyper.sh
- arch = any
- license = Apache
- makedepends = rpmextract
- depends = automake
- depends = cpio
- depends = device-mapper
- depends = sqlite
- depends = qemu
- source = hyper-0.5.rpm::https://s3.amazonaws.com/hyper-install/hyper-0.5-1.fc23.x86_64.rpm
- source = hyperstart-0.5.rpm::https://s3.amazonaws.com/hyper-install/hyperstart-0.5-1.fc23.x86_64.rpm
- md5sums = efc2c8e6945673ff0048a3b0fa579231
- md5sums = 6a1c80a26ecc96fa2bfbc81a613c5482
-
+ url = https://hyper.is
+ arch = x86_64
+ license = MIT
+ conflicts = hyper
+ provides = hyper
+ depends = libnotify
+ depends = libxss
+ depends = libxtst
+ depends = gconf
+ depends = libindicator
+ depends = libappindicator
+ options = !strip
+ options = !utx
+ source_x86_64 = https://github.com/zeit/hyper/releases/download/2.0.0-canary.15/hyper_2.0.0-canary.15_amd64.deb
+ md5sums_x86_64 = 51f3b3643c464b9bdef03ffede626126
pkgname = hyper-bin
-
-pkgname = hyperstart-bin
-
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..a79a2af0f48a
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2018 Ryan Dowling
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 8763eb62dd33..d5140bba2d33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,32 @@
-pkgbase=hyper-bin
-pkgname=("hyper-bin" "hyperstart-bin")
-pkgver=0.5
+# Maintainer: Ryan Dowling <ryan@ryandowling.me>
+
+pkgname=hyper-bin
+pkgver=2.0.0.canary.15
pkgrel=1
-pkgdesc="A hypervisor-agnostic Docker runtime"
-url="https://hyper.sh"
-arch=("any")
-license=("Apache")
-depends=("automake" "cpio" "device-mapper" "libvirt" "sqlite" "qemu")
-makedepends=("rpmextract")
-#optdepends=("")
-#backup=("")
-source=("hyper-$pkgver.rpm::https://s3.amazonaws.com/hyper-install/hyper-$pkgver-1.fc23.x86_64.rpm"
- "hyperstart-$pkgver.rpm::https://s3.amazonaws.com/hyper-install/hyperstart-$pkgver-1.fc23.x86_64.rpm")
-md5sums=('efc2c8e6945673ff0048a3b0fa579231'
- '6a1c80a26ecc96fa2bfbc81a613c5482')
+pkgdesc="A terminal built on web technologies"
+arch=('x86_64')
+url="https://hyper.is"
+license=('MIT')
+conflicts=('hyper' 'hyper-appimage')
+provides=('hyper')
+depends=('libnotify' 'libxss' 'libxtst' 'gconf' 'libindicator' 'libappindicator')
+options=('!strip' '!upx')
-package_hyper-bin() {
- requires=("hyperstart-bin")
- cd "$pkgdir"
- rpmextract.sh "$srcdir/hyper-$pkgver.rpm"
- mv "$pkgdir/lib/" "$pkgdir/usr/lib/"
-}
+_pkgver_correct=${pkgver/\.canary/-canary}
+
+source_x86_64=(
+ "https://github.com/zeit/hyper/releases/download/${_pkgver_correct}/hyper_${_pkgver_correct}_amd64.deb"
+)
+
+md5sums_x86_64=(
+ '51f3b3643c464b9bdef03ffede626126'
+)
+
+package() {
+ # extract the data file (already has everything as we need it)
+ tar -xf "${srcdir}/data.tar.xz" -C "${pkgdir}"
-package_hyperstart-bin() {
- cd "$pkgdir"
- rpmextract.sh "$srcdir/hyperstart-$pkgver.rpm"
+ # link the binary
+ install -d -m755 "${pkgdir}/usr/bin"
+ ln -sr "${pkgdir}/opt/Hyper/hyper" "${pkgdir}/usr/bin/hyper"
}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..0016ff7ae5ed
--- /dev/null
+++ b/README.md
@@ -0,0 +1,9 @@
+# hyper-bin
+
+Arch package for hyper installed by the deb binary.
+
+## Why?
+
+The `hyper` package from AUR installs NPM, Yarn, NodeJS and Electron just to install, which is not
+ideal for me as I want to control my own versions of those softwares and not have one package
+pollute that.