summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorimlonghao2020-02-08 07:06:06 +0000
committerimlonghao2020-02-08 07:06:06 +0000
commitf32d42421a7216f1660e1dd645634ce9b96f5de8 (patch)
tree6423b146434cbdf3e0ce197d4ae377220d9487d9
parent0673233a5574fa579e0e1ead6500cad7bd3a3f0e (diff)
downloadaur-f32d42421a7216f1660e1dd645634ce9b96f5de8.tar.gz
New version 3.0.2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 24 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8cc79a9870b3..235f5e1d5d6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,21 @@
pkgbase = hyper-bin
pkgdesc = A terminal built on web technologies
- pkgver = 2.0.0
+ pkgver = 3.0.2
pkgrel = 1
url = https://hyper.is
arch = x86_64
license = MIT
- depends = gconf
- depends = libnotify
- depends = libappindicator
- depends = libxtst
- depends = nss
+ depends = gtk3
depends = libxss
+ depends = nss
provides = hyper
conflicts = hyper
conflicts = hyper-appimage
options = !strip
- options = !upx
- source_x86_64 = https://github.com/zeit/hyper/releases/download/2.0.0/hyper_2.0.0_amd64.deb
- md5sums_x86_64 = c2f69568ac4cc624f621f73dde8f1354
+ source = https://github.com/zeit/hyper/releases/download/3.0.2/hyper_3.0.2_amd64.deb
+ source = https://github.com/zeit/hyper/raw/3.0.2/LICENSE
+ sha256sums = d78cf1f3f3928be00426e6409638c17eed9d5fed782065571a8759e4cae6643b
+ sha256sums = f1042dc10a7346f5f9f141ae8878f6a6dd048fa4890d30fe37c676c65aa3aca0
pkgname = hyper-bin
diff --git a/PKGBUILD b/PKGBUILD
index 840b2d6c7540..b1c4f72d5e49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Ryan Dowling <ryan@ryandowling.me>
+# Maintainer: Hao Long <aur@esd.cc>
+# Contributor: Ryan Dowling <ryan@ryandowling.me>
pkgname=hyper-bin
-pkgver=2.0.0
+pkgver=3.0.2
pkgrel=1
pkgdesc="A terminal built on web technologies"
arch=('x86_64')
@@ -9,23 +10,21 @@ url="https://hyper.is"
license=('MIT')
conflicts=('hyper' 'hyper-appimage')
provides=('hyper')
-# from the DEB: Depends: gconf2, gconf-service, libnotify4, libappindicator1, libxtst6, libnss3, libxss1
-depends=('gconf' 'libnotify' 'libappindicator' 'libxtst' 'nss' 'libxss')
-options=('!strip' '!upx')
-
-source_x86_64=(
- "https://github.com/zeit/hyper/releases/download/${pkgver}/hyper_${pkgver}_amd64.deb"
-)
-
-md5sums_x86_64=(
- 'c2f69568ac4cc624f621f73dde8f1354'
-)
+depends=('gtk3' 'libxss' 'nss')
+options=('!strip')
+source=("https://github.com/zeit/hyper/releases/download/${pkgver}/hyper_${pkgver}_amd64.deb"
+ "https://github.com/zeit/hyper/raw/${pkgver}/LICENSE")
+sha256sums=('d78cf1f3f3928be00426e6409638c17eed9d5fed782065571a8759e4cae6643b'
+ 'f1042dc10a7346f5f9f141ae8878f6a6dd048fa4890d30fe37c676c65aa3aca0')
package() {
- # extract the data file (already has everything as we need it)
- tar -xf "${srcdir}/data.tar.xz" -C "${pkgdir}"
+ # extract the data file (already has everything as we need it)
+ tar -xf "${srcdir}/data.tar.xz" -C "${pkgdir}"
+
+ # link the binary
+ install -d -m755 "${pkgdir}/usr/bin"
+ ln -sr "${pkgdir}/opt/Hyper/resources/bin/hyper" "${pkgdir}/usr/bin/hyper"
- # link the binary
- install -d -m755 "${pkgdir}/usr/bin"
- ln -sr "${pkgdir}/opt/Hyper/resources/bin/hyper" "${pkgdir}/usr/bin/hyper"
+ # License
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}