summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikolay Korotkiy2018-11-28 14:35:31 +0300
committerNikolay Korotkiy2018-11-28 14:35:31 +0300
commitd86881e62966aae1c071a3aea378052f0cce5e1f (patch)
treed4872b4a3ced9e6ce123ce9e5129e73a117c2506
parent40cca9da5f4692becd83f241a08acc16a072cf4e (diff)
downloadaur-d86881e62966aae1c071a3aea378052f0cce5e1f.tar.gz
Add cli tool, .desktop file
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD43
-rw-r--r--hypercube.desktop10
3 files changed, 44 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05b9020538e9..8ba35b726ef1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
-# Generated by makepkg 5.0.2
-# Mon Mar 26 19:24:39 UTC 2018
+# Generated by makepkg 5.1.1
+# Wed Nov 28 11:32:39 UTC 2018
pkgbase = hypercube
pkgdesc = Graph visualization tool
pkgver = 1.7.0
- pkgrel = 1
+ pkgrel = 2
url = http://tumic.wz.cz/hypercube/
arch = i686
arch = x86_64
@@ -13,7 +13,9 @@ pkgbase = hypercube
provides = hypercube=1.7.0
conflicts = hypercube-git
source = https://github.com/tumic0/hypercube/archive/1.7.0.tar.gz
+ source = hypercube.desktop
sha256sums = e35e849feb2a58395f106ebd6d745bd2315bf215f089c12149372015b19e55dc
+ sha256sums = 2e40776d1f27d58ccdf1206de469f1b0b6c950793874af603aa97b71fe0434d8
pkgname = hypercube
diff --git a/PKGBUILD b/PKGBUILD
index b639ce4ece3f..6c8fc1395c52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,37 @@
# Maintainer: Nikolay Korotkiy <sikmir@gmail.com>
pkgname=hypercube
pkgver=1.7.0
-pkgrel=1
+pkgrel=2
pkgdesc='Graph visualization tool'
arch=('i686' 'x86_64')
-url="http://tumic.wz.cz/hypercube/"
+url='http://tumic.wz.cz/hypercube/'
license=('GPL3')
depends=('qt5-base')
makedepends=('qt5-tools')
provides=("${pkgname}=${pkgver}")
conflicts=(${pkgname}-git)
-source=("https://github.com/tumic0/${pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('e35e849feb2a58395f106ebd6d745bd2315bf215f089c12149372015b19e55dc')
+source=("https://github.com/tumic0/${pkgname}/archive/${pkgver}.tar.gz"
+ 'hypercube.desktop')
+sha256sums=('e35e849feb2a58395f106ebd6d745bd2315bf215f089c12149372015b19e55dc'
+ '2e40776d1f27d58ccdf1206de469f1b0b6c950793874af603aa97b71fe0434d8')
build() {
cd ${pkgname}-${pkgver}
- lrelease hypercube.pro
- qmake hypercube.pro
+ rm -rf build
+ mkdir -p build
+ cd build
+
+ lrelease ../hypercube.pro
+ qmake ../hypercube.pro
+ make
+
+ cd ..
+ rm -rf build-cli
+ mkdir -p build-cli
+ cd build-cli
+
+ qmake ../hypercube-cli.pro
make
}
@@ -26,12 +40,13 @@ package() {
gzip hypercube.1
- install -d 755 ${pkgdir}/usr/bin
- install -d 755 ${pkgdir}/usr/share/man/man1
- install -d 755 ${pkgdir}/usr/share/${pkgname}
- install -d 755 ${pkgdir}/usr/share/${pkgname}/examples
-
- install -m 755 hypercube ${pkgdir}/usr/bin/${pkgname}
- install -m 644 hypercube.1.gz ${pkgdir}/usr/share/man/man1
- install -m 644 examples/* ${pkgdir}/usr/share/${pkgname}/examples
+ install -dm755 ${pkgdir}/usr/share/${pkgname}/{examples,translations}
+ install -Dm755 build/hypercube ${pkgdir}/usr/bin/${pkgname}
+ install -Dm755 build-cli/hypercube-cli ${pkgdir}/usr/bin/${pkgname}-cli
+ install -Dm644 hypercube.1.gz ${pkgdir}/usr/share/man/man1/hypercube.1.gz
+ ln -s /usr/share/man/man1/hypercube.1.gz $pkgdir/usr/share/man/man1/hypercube-cli.1.gz
+ install -Dm644 examples/* ${pkgdir}/usr/share/${pkgname}/examples
+ install -Dm644 lang/*.qm ${pkgdir}/usr/share/${pkgname}/translations
+ install -Dm644 icons/hypercube.png ${pkgdir}/usr/share/pixmaps/${pkgname}.png
+ install -Dm644 ../hypercube.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
}
diff --git a/hypercube.desktop b/hypercube.desktop
new file mode 100644
index 000000000000..fe20146e77a0
--- /dev/null
+++ b/hypercube.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Hypercube
+Comment=Graph visualization tool
+Comment[cz]=Nástroj na vizualizaci grafů
+Comment[ru]=Инструмент для визуализации графов
+Exec=hypercube %F
+Icon=hypercube
+Terminal=false
+Type=Application
+Categories=Graphics;Viewer;Qt;