summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThayne McCombs2015-09-20 18:07:41 -0600
committerThayne McCombs2015-09-20 18:07:41 -0600
commit1fcc2669a0e5dfd020712a733e56945adcaa5d33 (patch)
treeeef77040ee0615303b4b883012a8ad1583df9aaf
downloadaur-1fcc2669a0e5dfd020712a733e56945adcaa5d33.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4dc23b055018
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = hyperfs
+ pkgdesc = A simple HTTP static file server
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/tmccombs/hyperfs
+ arch = i386
+ arch = x86_64
+ license = MIT
+ makedepends = rust
+ makedepends = cargo
+ depends = gcc-libs
+ source = https://github.com/bytecurry/hyperfs/archive/v1.0.0.tar.gz
+ md5sums = ae47cd66acf76c1b24c90acc50724a89
+
+pkgname = hyperfs
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6ae0b18a1f6c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..03206a3b9720
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Thayne McCombs <bytecurry.software@gmail.com>
+pkgname=hyperfs
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A simple HTTP static file server"
+arch=('i386' 'x86_64')
+url="https://github.com/tmccombs/hyperfs"
+license=('MIT')
+depends=('gcc-libs')
+makedepends=('rust' 'cargo')
+provides=()
+source=("https://github.com/bytecurry/hyperfs/archive/v$pkgver.tar.gz")
+md5sums=('ae47cd66acf76c1b24c90acc50724a89')
+
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -D target/release/hyperfs "$pkgdir/usr/bin/hyperfs"
+ install -D LICENSE "$pkgdir/usr/share/licenses/hyperfs/LICENSE"
+}