summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Wozniak2016-06-14 23:02:47 +0200
committerPatrick Wozniak2016-06-14 23:02:47 +0200
commitb190df3f59c0a4824d7f7e04949d4214be9594e7 (patch)
treea53bc1858c72fa72f7b1bee630628294ad28cd9e
parent5c0bd4916b707027a7456ca4555fb17745178f56 (diff)
downloadaur-b190df3f59c0a4824d7f7e04949d4214be9594e7.tar.gz
update to new hyperion-project structure
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore17
-rwxr-xr-x[-rw-r--r--]PKGBUILD26
-rw-r--r--hyperiond.service10
4 files changed, 34 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 250ac6d7f461..f72c03ca5939 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Apr 30 11:36:09 UTC 2016
+# Tue Jun 14 21:02:13 UTC 2016
pkgbase = hyperion-rpi-bin
pkgdesc = An opensource 'AmbiLight' implementation (build for raspberry pi) (binary)
- pkgver = 20160430.fc7bc3c.v1011
- pkgrel = 1
+ pkgver = 20160614.b8f7642.V1030
+ pkgrel = 2
url = https://github.com/tvdzwan/hyperion
arch = any
license = MIT
@@ -11,12 +11,10 @@ pkgbase = hyperion-rpi-bin
depends = python2
conflicts = hyperion-git
conflicts = hyperion-rpi-git
- backup = etc/conf.d/hyperion.config.json
- source = https://raw.githubusercontent.com/tvdzwan/hyperion/V1.01.1/deploy/hyperion_rpi.tar.gz
- source = hyperiond.service
+ backup = etc/hyperion/hyperion.config.json
+ source = http://tenet.dl.sourceforge.net/project/hyperion-project/release/hyperion_rpi.tar.gz
source = LICENSE
- sha256sums = be992190562031b43337374d6a573f6dff76ff7d466375c1e423b41f34fd6d1d
- sha256sums = aab12fb3d901ea4c8694bd713b1a2187beae6a6ed40f3355d12fc7ad50aaf3fe
+ sha256sums = 8ba700d59aec256fe510091042cf7fa61daed95f3ea7c0ab2a4a4d650e26873d
sha256sums = 85f28018f946ca13b6de640c45e011cd9fe56114d474cb990d4d1ff91ae1cd60
pkgname = hyperion-rpi-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f6b9f22a6171
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,17 @@
+# ---------------------------------------------------------------------------- #
+# FROM
+# https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index 02637a9072a2..a9e084fc3199 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# build for raspberry pi
pkgname=hyperion-rpi-bin
-pkgver=20160430.fc7bc3c.v1011
-pkgrel=1
+pkgver=20160614.b8f7642.V1030
+pkgrel=2
pkgdesc="An opensource 'AmbiLight' implementation (build for raspberry pi) (binary)"
arch=('any')
@@ -19,33 +19,29 @@ conflicts=(
)
backup=(
- 'etc/conf.d/hyperion.config.json'
+ "etc/${pkgname%-rpi-bin}/${pkgname%-rpi-bin}.config.json"
)
source=(
- "https://raw.githubusercontent.com/tvdzwan/hyperion/V1.01.1/deploy/hyperion_rpi.tar.gz"
- "hyperiond.service"
+ "http://tenet.dl.sourceforge.net/project/hyperion-project/release/${pkgname%-rpi-bin}_rpi.tar.gz"
"LICENSE"
)
sha256sums=(
- 'be992190562031b43337374d6a573f6dff76ff7d466375c1e423b41f34fd6d1d'
- 'aab12fb3d901ea4c8694bd713b1a2187beae6a6ed40f3355d12fc7ad50aaf3fe'
+ '8ba700d59aec256fe510091042cf7fa61daed95f3ea7c0ab2a4a4d650e26873d'
'85f28018f946ca13b6de640c45e011cd9fe56114d474cb990d4d1ff91ae1cd60'
)
package() {
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/${pkgname%-rpi-bin}/LICENSE"
- install -Dm644 "hyperiond.service" "$pkgdir/usr/lib/systemd/system/hyperiond.service"
cd "${pkgname%-rpi-bin}"
+ install -Dm644 "config/${pkgname%-rpi-bin}.config.json.example" "$pkgdir/etc/${pkgname%-rpi-bin}/${pkgname%-rpi-bin}.config.json"
+ install -Dm644 "services/${pkgname%-rpi-bin}.systemd.sh" "$pkgdir/usr/lib/systemd/system/${pkgname%-rpi-bin}d.service"
- install -Dm755 "bin/hyperiond" "$pkgdir/usr/bin/hyperiond"
- install -Dm755 "bin/hyperion-remote" "$pkgdir/usr/bin/hyperion-remote"
- install -Dm755 "bin/hyperion-v4l2" "$pkgdir/usr/bin/hyperion-v4l2"
+ mkdir -p "$pkgdir/usr/bin/"
+ cp -r "bin" "$pkgdir/usr/"
- install -Dm644 "config/hyperion.config.json" "$pkgdir/etc/conf.d/hyperion.config.json"
-
- install -d "$pkgdir/opt/hyperion/"
- cp -r "effects" "$pkgdir/opt/hyperion/"
+ mkdir -p "$pkgdir/opt/${pkgname%-rpi-bin}/effects/"
+ cp -r "effects" "$pkgdir/opt/${pkgname%-rpi-bin}/"
}
diff --git a/hyperiond.service b/hyperiond.service
deleted file mode 100644
index 44e4aa556e38..000000000000
--- a/hyperiond.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=An opensource 'AmbiLight' implementation
-Wants=graphical.target
-
-[Service]
-Type=simple
-ExecStart=/usr/bin/hyperiond /etc/conf.d/hyperion.config.json > /dev/null 2>&1
-
-[Install]
-WantedBy=multi-user.target