summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJake2018-03-13 01:17:35 +0100
committerJake2018-03-13 01:17:35 +0100
commit2acf316cc53a246ea4d38eb4098bd9f444f7ad59 (patch)
tree772a79f5ff64d6ac71440f57d320ba6e60c8913f
parentc7bf406fde90f1aba42530640d4ec207f5a1abd4 (diff)
downloadaur-2acf316cc53a246ea4d38eb4098bd9f444f7ad59.tar.gz
Adopt to new config structure
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--hyperion.systemd15
3 files changed, 27 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02993a07fd65..89211a3fc85a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hyperion.ng-git
pkgdesc = The reworked version (next generation) of Hyperion, ambient light software - PRE ALPHA
- pkgver = r1478.7c336b05
+ pkgver = r1567.e438bc62
pkgrel = 1
url = https://github.com/hyperion-project/hyperion.ng
arch = i686
@@ -20,9 +20,11 @@ pkgbase = hyperion.ng-git
provides = hyperion
conflicts = hyperion
conflicts = hyperion-git
- backup = etc/hyperion/hyperion.config.json
+ backup = etc/hyperion/config/hyperion.config.json
source = git+https://github.com/hyperion-project/hyperion.ng
+ source = hyperion.systemd
sha512sums = SKIP
+ sha512sums = 18ce37552465c654e159062d5e104b43d5bc19a3f31b76293b294bef95f1998bfe357bc70c259f3c495c2e5d4abfb9c7e47a0b76c5bd89c69d294dd9d37de1ac
pkgname = hyperion.ng-git
diff --git a/PKGBUILD b/PKGBUILD
index 02876f36d491..70a2543bed7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jake <ja.ke@posteo.de>
pkgname=hyperion.ng-git
-pkgver=r1478.7c336b05
+pkgver=r1567.e438bc62
pkgrel=1
pkgdesc="The reworked version (next generation) of Hyperion, ambient light software - PRE ALPHA"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
@@ -12,9 +12,11 @@ optdepends=('xorg-server: X11 grabbing')
makedepends=('cmake')
provides=("hyperion")
conflicts=('hyperion' 'hyperion-git')
-backup=('etc/hyperion/hyperion.config.json')
-source=("git+https://github.com/hyperion-project/${pkgname%-git}")
-sha512sums=('SKIP')
+backup=('etc/hyperion/config/hyperion.config.json')
+source=("git+https://github.com/hyperion-project/${pkgname%-git}"
+ "hyperion.systemd")
+sha512sums=('SKIP'
+ '18ce37552465c654e159062d5e104b43d5bc19a3f31b76293b294bef95f1998bfe357bc70c259f3c495c2e5d4abfb9c7e47a0b76c5bd89c69d294dd9d37de1ac')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -43,9 +45,9 @@ package() {
install -d ${pkgdir}/usr/share/hyperion/webconfig
cp -r assets/webconfig ${pkgdir}/usr/share/hyperion/
- install -Dm 644 config/hyperion.config.json.default "${pkgdir}/etc/hyperion/hyperion.config.json"
+ install -Dm 644 config/hyperion.config.json.default "${pkgdir}/etc/hyperion/config/hyperion.config.json"
- install -Dm 644 bin/service/hyperion.systemd "${pkgdir}/usr/lib/systemd/system/hyperiond.service"
+ install -Dm 644 ${srcdir}/hyperion.systemd "${pkgdir}/usr/lib/systemd/system/hyperiond.service"
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE"
}
diff --git a/hyperion.systemd b/hyperion.systemd
new file mode 100644
index 000000000000..fd4c05562107
--- /dev/null
+++ b/hyperion.systemd
@@ -0,0 +1,15 @@
+[Unit]
+Description=Hyperion ambient light systemd service
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/hyperiond hyperion.config.json --rootPath /etc/hyperion/
+WorkingDirectory=/usr/share/hyperion
+TimeoutStopSec=5
+KillMode=mixed
+Restart=always
+RestartSec=2
+StartLimitInterval=7
+
+[Install]
+WantedBy=multi-user.target