summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-14 17:08:49 +0800
committerzxp198210052023-11-14 17:08:49 +0800
commit0680f63e18a1a39596ba1e09850820a1ece39b4e (patch)
treeca43544cfb77ac72faa826ab5aadbe6c87b7003f
parentc9097320c4d634727bd23b4b4b67ca94ca40217d (diff)
downloadaur-0680f63e18a1a39596ba1e09850820a1ece39b4e.tar.gz
fix errors
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD42
-rw-r--r--hyperkeys.sh5
3 files changed, 58 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8086917daaba..3b3f34d7dbb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,35 @@
pkgbase = hyperkeys-bin
pkgdesc = Unleash you keyboard shorcuts
pkgver = 1.3.0
- pkgrel = 3
+ pkgrel = 4
url = https://hyperkeys.xureilab.com/
arch = x86_64
license = GPL3
- makedepends = asar
- depends = bash
+ makedepends = squashfuse
depends = electron20
+ depends = libx11
+ depends = gdk-pixbuf2
+ depends = libxext
+ depends = libdbusmenu-glib
+ depends = gtk2
+ depends = dbus-glib
+ depends = libxcb
+ depends = expat
+ depends = pango
+ depends = cairo
+ depends = at-spi2-core
+ depends = gtk3
+ depends = java-runtime
+ depends = libxmu
+ depends = libdbusmenu-gtk3
+ depends = xdotool
+ depends = perl
+ depends = python
provides = hyperkeys=1.3.0
conflicts = hyperkeys
source = hyperkeys-1.3.0.AppImage::https://github.com/xurei/hyperkeys/releases/download/v1.3.0/HyperKeys-1.3.0.AppImage
source = hyperkeys.sh
sha256sums = 2884e6025aa4dfee198f1279584e8ec798d8f9519cbe8c6ed1f4648b26e63711
- sha256sums = 6c5542dd0968280fb9c2bce2957dd0b7bb6e8b5ed4c870a7e909bf980d5d2aff
+ sha256sums = 5d04f8d8b55d211a4174ce1201307c1bdd004080b032d5c1da3e0100180ee2c8
pkgname = hyperkeys-bin
diff --git a/PKGBUILD b/PKGBUILD
index 9e935abe10e8..62ba8544eea9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,53 @@
pkgname=hyperkeys-bin
_appname=HyperKeys
pkgver=1.3.0
-pkgrel=3
+pkgrel=4
pkgdesc="Unleash you keyboard shorcuts"
arch=('x86_64')
url="https://hyperkeys.xureilab.com/"
-_githuburl="https://github.com/xurei/hyperkeys"
+_ghurl="https://github.com/xurei/hyperkeys"
license=('GPL3')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-depends=('bash' 'electron20')
-makedepends=('asar')
-source=("${pkgname%-bin}-${pkgver}.AppImage::${_githuburl}/releases/download/v${pkgver}/${_appname}-${pkgver}.AppImage"
+depends=(
+ 'electron20'
+ 'libx11'
+ 'gdk-pixbuf2'
+ 'libxext'
+ 'libdbusmenu-glib'
+ 'gtk2'
+ 'dbus-glib'
+ 'libxcb'
+ 'expat'
+ 'pango'
+ 'cairo'
+ 'at-spi2-core'
+ 'gtk3'
+ 'java-runtime'
+ 'libxmu'
+ 'libdbusmenu-gtk3'
+ 'xdotool'
+ 'perl'
+ 'python'
+)
+makedepends=(
+ 'squashfuse'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.AppImage::${_ghurl}/releases/download/v${pkgver}/${_appname}-${pkgver}.AppImage"
"${pkgname%-bin}.sh")
sha256sums=('2884e6025aa4dfee198f1279584e8ec798d8f9519cbe8c6ed1f4648b26e63711'
- '6c5542dd0968280fb9c2bce2957dd0b7bb6e8b5ed4c870a7e909bf980d5d2aff')
-prepare() {
+ '5d04f8d8b55d211a4174ce1201307c1bdd004080b032d5c1da3e0100180ee2c8')
+build() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
- asar pack "${srcdir}/squashfs-root/resources/app" "${srcdir}/${pkgname%-bin}.asar"
sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ find "${srcdir}/squashfs-root/resources" -type d -exec chmod 755 {} \;
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/${pkgname%-bin}.asar" -t "${pkgdir}/opt/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/lib"
+ cp -r "${srcdir}/squashfs-root/resources/app" "${pkgdir}/usr/lib/${pkgname%-bin}"
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
} \ No newline at end of file
diff --git a/hyperkeys.sh b/hyperkeys.sh
index cd80d88c8aac..0c2134b0c8a1 100644
--- a/hyperkeys.sh
+++ b/hyperkeys.sh
@@ -1,6 +1,9 @@
#!/bin/bash
_ELECTRON=/usr/bin/electron20
-_ASAR="/opt/hyperkeys/hyperkeys.asar"
+APPDIR=/usr/lib/hyperkeys
+export PATH="${APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${APPDIR}/lib:${LD_LIBRARY_PATH}"
+_ASAR="${APPDIR}/app"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else