summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-21 15:30:44 +0800
committerzxp198210052024-03-21 15:30:44 +0800
commit27794c72b53449493f5368ce91130a2c00637161 (patch)
tree05bb2a285cce7350834e9c9bc3c450a21b8a7fb0
parentfba851cb378f1e51616559b88b33845a5ba41e64 (diff)
downloadaur-27794c72b53449493f5368ce91130a2c00637161.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--hyperkeys.sh5
3 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 924d44ccafca..a207e4be9fca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = hyperkeys-bin
pkgdesc = Unleash you keyboard shorcuts
pkgver = 1.3.0
- pkgrel = 7
+ pkgrel = 8
url = https://hyperkeys.xureilab.com/
arch = x86_64
license = GPL-3.0-only
makedepends = fuse2
- depends = electron20
+ depends = electron20-bin
depends = java-runtime
depends = perl
depends = python>3
@@ -21,6 +21,6 @@ pkgbase = hyperkeys-bin
source = hyperkeys-1.3.0.AppImage::https://github.com/xurei/hyperkeys/releases/download/v1.3.0/HyperKeys-1.3.0.AppImage
source = hyperkeys.sh
sha256sums = 2884e6025aa4dfee198f1279584e8ec798d8f9519cbe8c6ed1f4648b26e63711
- sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = hyperkeys-bin
diff --git a/PKGBUILD b/PKGBUILD
index 319524db9545..5df3aee84fc1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=hyperkeys-bin
_appname=HyperKeys
pkgver=1.3.0
_electronversion=20
-pkgrel=7
+pkgrel=8
pkgdesc="Unleash you keyboard shorcuts"
arch=('x86_64')
url="https://hyperkeys.xureilab.com/"
@@ -13,7 +13,7 @@ license=('GPL-3.0-only')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
- "electron${_electronversion}"
+ "electron${_electronversion}-bin"
'java-runtime'
'perl'
'python>3'
@@ -34,11 +34,12 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('2884e6025aa4dfee198f1279584e8ec798d8f9519cbe8c6ed1f4648b26e63711'
- '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
diff --git a/hyperkeys.sh b/hyperkeys.sh
index 86cb3dc6a9bf..7ddcaab8d734 100644
--- a/hyperkeys.sh
+++ b/hyperkeys.sh
@@ -2,6 +2,7 @@
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
@@ -9,7 +10,7 @@ export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file